Closed Bug 1657428 Opened 1 year ago Closed 1 year ago

Youtube videos render more pixely/with less antialiasing

Categories

(Core :: Graphics: WebRender, defect)

Firefox 81
Unspecified
Windows
defect

Tracking

()

RESOLVED FIXED
81 Branch
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox79 --- unaffected
firefox80 --- unaffected
firefox81 --- fixed

People

(Reporter: philipp, Assigned: mattwoodrow)

References

(Regression)

Details

(Keywords: regression)

Attachments

(4 files)

Attached file about support info.txt

i've started noticing that youtube videos have started rendering much more pixely/with less antialiasing starting since yesterday and the following regression range:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=4ed6ec0c8220321b13c108ffaa7ab6cfc8d7698f&tochange=4558b3cfd6fe49647780a0ec86dfa97f0dd3adcb

though both changes in that range were targetting macos, i get the problems on a windows machine.

Flags: needinfo?(matt.woodrow)
Attached image bad render.PNG
See Also: → 1657107, 1657443

This is probably from https://phabricator.services.mozilla.com/D84328 which makes WR set a transform on the DirectComposition visual.

Regressed by: 1653166
No longer regressed by: 1653048
See Also: 1657107
Assignee: nobody → matt.woodrow
Status: NEW → ASSIGNED
Attachment #9168298 - Attachment description: Bug 1657428 - Use linear interpolation for DirectComposition visuals when we have scaling transforms. r?sotaro → Bug 1657428 - Use correct interpolation mode for native compositing layers. r?sotaro,mstange
Duplicate of this bug: 1657638
Duplicate of this bug: 1657644
Duplicate of this bug: 1657695
Duplicate of this bug: 1657734
Flags: needinfo?(matt.woodrow)
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/917a7b55541f
Use correct interpolation mode for native compositing layers. r=mstange
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 81 Branch
You need to log in before you can comment on or make changes to this bug.