Closed Bug 1657619 Opened 2 years ago Closed 2 years ago

Select All (Ctrl+A) in Message Source (Ctrl+U) no longer works unless I click on the text first

Categories

(Thunderbird :: General, defect)

defect

Tracking

(thunderbird_esr78 fixed, thunderbird80 fixed, thunderbird81 fixed)

VERIFIED FIXED
81 Branch
Tracking Status
thunderbird_esr78 --- fixed
thunderbird80 --- fixed
thunderbird81 --- fixed

People

(Reporter: stevem, Assigned: mkmelin)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/84.0.4147.105 Safari/537.36

Steps to reproduce:

This issue happened in Thunderbird 78.1.0 (64-bit), Windows 10 version 2004 build 19041.423.
I occasionally report spam e-mails I receive to SpamCop.
When I do, this is my process:

  1. I click on the spam e-mail entry in the folder list. (of course, this can be tested with any e-mail entry)
  2. Ctrl + U to see the Message Source (also can do View|Message Source in menu)
  3. Ctrl + A to select all the text - in previous versions of Thunderbird, this selected all the text, but it doesn't now. I have to click on the text then Ctrl+A to select all the text.
  4. Ctrl + C to copy the message source so I can paste that into the SpamCop entry form. (this step isn't key to this bug except to demonstrate the work flow)

Actual results:

In Step 3, I have to click on the text before doing Ctrl + A to select all the text. This disrupts the keyboard flow I had in version 68 of Ctrl+U|Ctrl+A|Ctrl-C.

Expected results:

In Step 3, I should have been able to do Ctrl+A to select all the text without having to click on the text first. In other words, the work flow should have been Ctrl+U|Ctrl+A|Ctrl+C instead of Ctrl+U|click text|Ctrl+A|Ctrl+C.
The former (Ctrl+U|Ctrl+A|Ctrl+C) is the way Thunderbird worked in version 68 before I upgraded to version 78.

Using Ctr+A to select the source without first clicking on the text is working in my TB 68.11.0 test.

Error console in 78.1.0, 80.0b1 and 81.0a1 shows:

12:40:50.415 An error occurred executing the cmd_selectAll command: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIController.doCommand]" nsresult: "0x80004005 (NS_ERROR_FAILURE)" location: "JS frame :: chrome://global/content/globalOverlay.js :: goDoCommand :: line 101" data: no] globalOverlay.js:104
goDoCommand chrome://global/content/globalOverlay.js:104
<anonymous> chrome://global/content/editMenuOverlay.js:87

Maybe the proper product and component is Toolkit:View Source?

Blocks: tb78found
Status: UNCONFIRMED → NEW
Component: Untriaged → General
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All

No, we have a fork of long removed Mozilla code.

Alice, can you find the regression for us. Thanks in advance.

Flags: needinfo?(alice0775)

Thanks Alice!
I guess not the largest of bugs, but since we have view source in a dedicated window and not in a tab (yet), I guess we can add back the focusing. The problems the m-c patch fixed was related to unexpected/unwanted tab selection.

Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #9168673 - Flags: review?(khushil324)
Comment on attachment 9168673 [details] [diff] [review]
bug1657619_viewsourcefocus.patch

Review of attachment 9168673 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. r=khushil
Attachment #9168673 - Flags: review?(khushil324) → review+
Regressed by: 1636968
Target Milestone: --- → 81 Branch

Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/c36cff7af6a1
focus the content of view source on load so that selection works directly without having to click into the content. r=khushil

Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED

Comment on attachment 9168673 [details] [diff] [review]
bug1657619_viewsourcefocus.patch

[Approval Request Comment]
Regression caused by (bug #): Bug 1636968
User impact if declined: Small annoyance, user needs one more click.
Testing completed (on c-c, etc.): Yes.
Risk to taking this patch (and alternatives if risky): Low, one liner.

Attachment #9168673 - Flags: approval-comm-esr78?
Attachment #9168673 - Flags: approval-comm-beta?

Comment on attachment 9168673 [details] [diff] [review]
bug1657619_viewsourcefocus.patch

[Triage Comment]
Approved for beta

Attachment #9168673 - Flags: approval-comm-beta? → approval-comm-beta+

Fixed in my testing of the 80.0b2 release candidate on Ubuntu 18.04.4.

Comment on attachment 9168673 [details] [diff] [review]
bug1657619_viewsourcefocus.patch

[Triage Comment]
Approved for esr78

Attachment #9168673 - Flags: approval-comm-esr78? → approval-comm-esr78+
Status: RESOLVED → VERIFIED

This is fixed for me in 78.2.0. Thanks everyone!

You need to log in before you can comment on or make changes to this bug.