Closed Bug 1659321 Opened 2 years ago Closed 2 years ago

vCards for accounts are broken

Categories

(Thunderbird :: Account Manager, defect)

x86_64
Linux
defect

Tracking

(thunderbird_esr68 unaffected, thunderbird_esr78 affected)

RESOLVED DUPLICATE of bug 1653647
Tracking Status
thunderbird_esr68 --- unaffected
thunderbird_esr78 --- affected

People

(Reporter: public, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, regressionwindow-wanted, Whiteboard: smoketestb78.2.0-pre)

Attempting to edit the vCard associated with an account fails, at least on Thunderbird 78.2.0-pre build1 on Linux x64.

STR:
0. Make sure there is at least one email identity

  1. Open the account settings and select an email identity (the top-level node)
  2. Click on "Edit Card..." besides "Attach my vCard to messages". It does not matter if "Attach my vCard to messages" is actually enabled.

Expected:
No errors are logged and a dialog to edit your own vCard opens.

Actual:
An exception is logged in the error console (abCard.js:623:14):

Uncaught TypeError: document.getElementById(...) is null
    HideNonVcardFields chrome://messenger/content/addressbook/abCard.js:623
    OnLoadNewCard chrome://messenger/content/addressbook/abCard.js:157
    onload chrome://messenger/content/addressbook/abNewCardDialog.xhtml:1

A contact dialog opens (in new contact mode, permitting to select an address book to save into – which makes no sense in this context!). The dialog itself works as expected, but any changes performed will not be present when opening the dialog again.

Also, attaching the vCard to emails has no effect (I suspect a second bug there, as TB 68 would create an empty attachment if the vCard is empty, and TB 78 does not add any attachments at all).

Flags: needinfo?(geoff)

And bug 1659321? EDIT: Grrr, bug 1659321 is this bug here, I guess I meant to say bug 1659323, but by the looks of it that's a different issue.

Flags: needinfo?(geoff)
See Also: → 1653187, 1653647

Bug 1653647 will handle this.

Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1653647
You need to log in before you can comment on or make changes to this bug.