Beginning on October 25th, 2016, Persona will no longer be an option for authentication on BMO. For more details see Persona Deprecated.
Last Comment Bug 166100 - allow for the use of an external editor in (text only) mail composition
: allow for the use of an external editor in (text only) mail composition
Status: VERIFIED DUPLICATE of bug 13474
Product: MailNews Core
Classification: Components
Component: Composition (show other bugs)
: Trunk
: All All
: -- enhancement with 4 votes (vote)
: ---
Assigned To: Jean-Francois Ducarroz
: esther
: 175475 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2002-09-01 16:59 PDT by Juan Lanus
Modified: 2008-07-31 01:22 PDT (History)
0 users
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---


Description Juan Lanus 2002-09-01 16:59:04 PDT
We nerds have our favourite editors, mine is vim.
Each one of us is most productive while using the usual editor.
It would be fine to be able to select in preferences a program to run into the
mail composition window.
Also, commercial implementations might build on this feature to further
customize their versions with specialized editors.
Comment 1 Gerhard Häring 2002-09-01 17:16:03 PDT
Yeah, that would certainly be tremendously useful. In particular because editors
like vim have very good ways for reformatting email messages, while still
keeping the quoting intact.

Mahogany and (hell!) even M$ Outlook can be talked into having an external
editor. My MUA of choice (mutt) of course too.

As for implementation strategy, Mahogany allows you to press Ctrl+E in the
normal editor Window, where it will then fire up your configured external editor
(with a temp file). Once you close the external editor, the temp file will be
loaded into the integrated editor. That shouldn't really be difficult to
implement for Mozilla.
Comment 2 Mats Palmgren (:mats) 2002-09-01 18:52:41 PDT
Dupe of bug 13474 (via bug 72539)

*** This bug has been marked as a duplicate of 13474 ***
Comment 3 R.K.Aa. 2002-10-19 09:52:42 PDT
*** Bug 175475 has been marked as a duplicate of this bug. ***
Comment 4 Vedran Miletic 2003-08-04 07:21:13 PDT

Note You need to log in before you can comment on or make changes to this bug.