Closed Bug 1661683 Opened 8 months ago Closed 8 months ago

bootstrap fails on missing module zstandard

Categories

(Firefox Build System :: Bootstrap Configuration, defect)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1660559

People

(Reporter: freddy, Unassigned)

References

(Blocks 1 open bug)

Details

bootstrap fails for me without any other cli parameters, but giving a log with--no-system-changes for extra brevity.

$ ./mach bootstrap --no-system-changes
Using an experimental bootstrapper for Archlinux.

Note on Artifact Mode:

Artifact builds download prebuilt C++ components rather than building
them locally. Artifact builds are faster!

Artifact builds are recommended for people working on Firefox or
Firefox for Android frontends, or the GeckoView Java API. They are unsuitable
for those working on C++ code. For more information see:
https://developer.mozilla.org/en-US/docs/Artifact_builds.

Please choose the version of Firefox you want to build:
  1. Firefox for Desktop Artifact Mode
  2. Firefox for Desktop
  3. GeckoView/Firefox for Android Artifact Mode
  4. GeckoView/Firefox for Android
Your choice: 2
Your version of Python 3 (3.8.5) is new enough.
Your version of Python 2 (2.7.18) is new enough.
 0:02.23 Setting up artifact node.tar.xz
 0:02.23 Using artifact from local cache: /home/freddy/.mozbuild/toolchains/1b124084d799a828-node.tar.xz
 0:02.27 rm tree: /home/freddy/.mozbuild/node
 0:02.34 untarring "/home/freddy/.mozbuild/node.tar.xz"
 0:02.21 Setting up artifact fix-stacks.tar.xz
 0:02.21 Using artifact from local cache: /home/freddy/.mozbuild/toolchains/32bc1852662ee3e0-fix-stacks.tar.xz
 0:02.21 rm tree: /home/freddy/.mozbuild/fix-stacks
 0:02.21 untarring "/home/freddy/.mozbuild/fix-stacks.tar.xz"
 0:02.22 Setting up artifact minidump_stackwalk.tar.xz
 0:02.22 Using artifact from local cache: /home/freddy/.mozbuild/toolchains/1ae5014d5ce573b8-minidump_stackwalk.tar.xz
 0:02.23 rm tree: /home/freddy/.mozbuild/minidump_stackwalk
 0:02.23 untarring "/home/freddy/.mozbuild/minidump_stackwalk.tar.xz"
 0:02.22 Setting up artifact clang.tar.zst
 0:02.22 Using artifact from local cache: /home/freddy/.mozbuild/toolchains/1c7aa3a7c16e8f51-clang.tar.zst
Requirement already satisfied: zstandard<=0.13.0,>=0.9.0 in /home/freddy/.mozbuild/_virtualenvs/mach/lib/python3.8/site-packages (0.13.0)
Requirement already satisfied: cffi>=1.11 in /home/freddy/.mozbuild/_virtualenvs/mach/lib/python3.8/site-packages (from zstandard<=0.13.0,>=0.9.0) (1.14.2)
Requirement already satisfied: pycparser in /home/freddy/.mozbuild/_virtualenvs/mach/lib/python3.8/site-packages (from cffi>=1.11->zstandard<=0.13.0,>=0.9.0) (2.20)
WARNING: You are using pip version 19.3.1; however, version 20.2.2 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Error running mach:

    ['artifact', 'toolchain', '--bootstrap', '--from-build', 'linux64-clang']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file artifact| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

ModuleNotFoundError: No module named 'zstandard'

  File "/home/freddy/gecko/python/mozbuild/mozbuild/artifact_commands.py", line 472, in artifact_toolchain
    unpack_file(local)
  File "/home/freddy/gecko/python/mozbuild/mozbuild/action/tooltool.py", line 918, in unpack_file
    import zstandard
  File "/home/freddy/gecko/build/mach_bootstrap.py", line 474, in __call__
    module = self._original_import(name, globals, locals, fromlist, level)
Sentry is attempting to send 0 pending error messages
Waiting up to 2 seconds
Press Ctrl-C to quit
Error running mach:

    ['bootstrap', '--no-system-changes']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file bootstrap| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

subprocess.CalledProcessError: Command '['/usr/bin/python3', '/home/freddy/gecko/mach', 'artifact', 'toolchain', '--bootstrap', '--from-build', 'linux64-clang']' returned non-zero exit status 1.

  File "/home/freddy/gecko/python/mozboot/mozboot/mach_commands.py", line 45, in bootstrap
    bootstrapper.bootstrap()
  File "/home/freddy/gecko/python/mozboot/mozboot/bootstrap.py", line 488, in bootstrap
    self.maybe_install_private_packages_or_exit(state_dir,
  File "/home/freddy/gecko/python/mozboot/mozboot/bootstrap.py", line 425, in maybe_install_private_packages_or_exit
    self.instance.ensure_stylo_packages(state_dir, checkout_root)
  File "/home/freddy/gecko/python/mozboot/mozboot/linux_common.py", line 73, in ensure_stylo_packages
    self.install_toolchain_artifact(state_dir, checkout_root, stylo.LINUX_CLANG)
  File "/home/freddy/gecko/python/mozboot/mozboot/base.py", line 356, in install_toolchain_artifact
    subprocess.check_call(cmd, cwd=state_dir)
  File "/usr/lib/python3.8/subprocess.py", line 364, in check_call
    raise CalledProcessError(retcode, cmd)
Sentry is attempting to send 0 pending error messages
Waiting up to 2 seconds
Press Ctrl-C to quit

within the virtualenv, zstandard is already installed:

$ pip install zstandard
Requirement already satisfied: zstandard in /home/freddy/.mozbuild/_virtualenvs/mach/lib/python3.8/site-packages (0.13.0)
Requirement already satisfied: cffi>=1.11 in /home/freddy/.mozbuild/_virtualenvs/mach/lib/python3.8/site-packages (from zstandard) (1.14.2)
Requirement already satisfied: pycparser in /home/freddy/.mozbuild/_virtualenvs/mach/lib/python3.8/site-packages (from cffi>=1.11->zstandard) (2.20)

installing it outside of the venv (using pip install zstandard) helped :|

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1660559
You need to log in before you can comment on or make changes to this bug.