Closed Bug 1665115 Opened 9 months ago Closed 8 months ago

Alias gets readded to addressbar after being translated into search-mode indicator

Categories

(Firefox :: Address Bar, defect, P2)

Firefox 82
Desktop
All
defect
Points:
2

Tracking

()

RESOLVED FIXED
83 Branch
Iteration:
83.2 - Oct 5 - Oct 18
Tracking Status
firefox-esr68 --- unaffected
firefox-esr78 --- unaffected
firefox80 --- unaffected
firefox81 --- unaffected
firefox82 --- disabled
firefox83 --- fixed

People

(Reporter: aflorinescu, Assigned: adw)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

[Sugested Severity:]

S4

[Description:]

An edge case when the @shortcut is translated to search-mode indicator and the @alias is readded.

[Environment:]

Ubuntu 20.04 / Windows 10 / Mac 10.13.6
82.0a1 2020-09-15

[Steps:]
  1. Open Firefox.
  2. New tab.
  3. type @google+space -> alias gets transformed into search-mode indicator.
  4. Press + to create a new tab.
  5. Navigate back to the step 3 tab.
[Actual Result:]

google search mode-indicator + @google present in the tab.

[Expected Result:]

google search mode-indicator

[Regression Range]

On 81.0 2020-09-14, flipping the Browser.urlbar.update2.* prefs, the issue doesn't reproduce, so I'd guess it's a regression caused by bug 1647890.

I'll get back with a confirmed regression range at a later point.

Severity: -- → S4
Points: --- → 2
Priority: -- → P2

I bet we're restoring userTypedValue. We need to null it when it's converted into the search mode indicator -- or it might not be quite that simple. It may be more like, we need to remove the prefix that got converted into the indicator.

I wonder whether we could rely on this behavior to restore search mode per tab, instead of needing the map that we use now. When we added that map, bug 1658964 hadn't yet landed and fixed the problem where aliases at the beginning of the input value weren't converted to search mode.

Typing @google test (i.e., with a query after the alias) seems to work correctly. Pasting it doesn't, so we should be sure to fix that too.

(In reply to Drew Willcoxon :adw from comment #1)

Typing @google test (i.e., with a query after the alias) seems to work correctly. Pasting it doesn't, so we should be sure to fix that too.

Pasting @google query_string works for me.

Assignee: nobody → adw
Status: NEW → ASSIGNED
Iteration: --- → 82.2 - Sep 7 - Sep 20
QA Whiteboard: [qa-regression-triage]

:adw, since this bug is a regression, could you fill (if possible) the regressed_by field?
For more information, please visit auto_nag documentation.

Flags: needinfo?(adw)
Flags: needinfo?(adw)
Regressed by: 1658964

Calling this fix-optional for 82 given the S4 severity.

Iteration: 82.2 - Sep 7 - Sep 20 → 83.1 - Sept 21 - Oct 4

browser.urlbar.update2.* prefs are only enabled n Nightly.

Iteration: 83.1 - Sept 21 - Oct 4 → 83.2 - Oct 5 - Oct 18

Comment on attachment 9181166 [details]
Bug 1665115 - Add a test to make sure search mode is duplicated when duplicating tabs.

Revision D93293 was moved to bug 1659203. Setting attachment 9181166 [details] to obsolete.

Attachment #9181166 - Attachment is obsolete: true
Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/582e4890127f
Update userTypedValue when entering search mode so that search strings are properly restored. r=mak
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch
You need to log in before you can comment on or make changes to this bug.