Closed Bug 1666041 Opened 2 years ago Closed 2 years ago

Let the bug reports be edited by authors

Categories

(bugzilla.mozilla.org :: User Interface, enhancement)

enhancement

Tracking

()

RESOLVED WONTFIX

People

(Reporter: piotr.skowronek, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:80.0) Gecko/20100101 Firefox/80.0

Steps to reproduce:

When I report a bug (via bugzilla.mozilla.org) to either Firefox or Thunderbird I find that I made typos or other grammatical errors in the final post no matter how many times a read it before posting. As I said, I try to re-read the post before I submit, but I guess according to 'Barker's proof' aka 'Muprhy's law' (https://en.wikipedia.org/wiki/Muphry%27s_law) I can see a mistake only when the post is published.

Actual results:

I'm unable to edit my post to fix errors.

Expected results:

I should be able to edit the post, at least for the limited time after submission (1h?). This should improve the quality of bug reports or lower the number of correctional comments (as there's no other option for a generic bug reporter).

"times a read it before posting" -> "times I read it before posting" /a typo was not made deliberately/

Hmm, you can? There should be a pencil icon in the row of buttons at the top right of any comments you wrote (including the original bug description).

Assignee: create-and-change → nobody
Component: Creating/Changing Bugs → User Interface
Product: Bugzilla → bugzilla.mozilla.org
QA Contact: default-qa

See also bug 540 (yes, a 3 digit bug). This might be a duplicate.

(In reply to Dave Miller [:justdave] (justdave@thunderbird.net) from comment #2)

Hmm, you can? There should be a pencil icon in the row of buttons at the top right of any comments you wrote (including the original bug description).

I see no pencil button, neither for description nor comments. Where is that?

(In reply to Dave Miller [:justdave] (justdave@thunderbird.net) from comment #3)

See also bug 540 (yes, a 3 digit bug). This might be a duplicate.

So, I can or cannot? :)

From that 3 digit bug (that is 22 yrs old!) I assume the feature is there, the only thing is to add certain rights to certain groups for all the projects under bugzilla.mozilla.org. Maybe this bug should be re-assigned to administration of bugzilla.mozilla.org?

(In reply to Dave Miller [:justdave] (justdave@thunderbird.net) from comment #3)

See also bug 540 (yes, a 3 digit bug). This might be a duplicate.

Dave, regular BMO users without special rights like editbugs apparently do not have any option of editing bug descriptions/comments, not even for a limited timespan. Which is a true PITA!!! In 2020 just imagine...

Component: User Interface → Administration

This is a substantial workflow obstacle and prevents bug management from being done as efficiently as it should.
If reporter reports something wrong, the wrong part hangs around forever without any way of fixing it. Even with editbugs rights, I cannot fix someone else's bug description.

Status: UNCONFIRMED → NEW
Ever confirmed: true

(In reply to Thomas D. (:thomas8) from comment #5)

(In reply to Dave Miller [:justdave] (justdave@thunderbird.net) from comment #3)

See also bug 540 (yes, a 3 digit bug). This might be a duplicate.

Dave, regular BMO users without special rights like editbugs apparently do not have any option of editing bug descriptions/comments, not even for a limited timespan. Which is a true PITA!!! In 2020 just imagine...

The decision to only allow edits by members of editbugs was made in Bug 1484477. I see no pressing reason to change that in 2020.

(In reply to Thomas D. (:thomas8) from comment #6)

If reporter reports something wrong, the wrong part hangs around forever without any way of fixing it. Even with editbugs rights, I cannot fix someone else's bug description.

That's bug 1535000 which is close to landing (blocked by bug 1665646 which is in progress).

Status: NEW → RESOLVED
Closed: 2 years ago
Component: Administration → User Interface
Resolution: --- → WONTFIX

(In reply to :glob 🎈 from comment #7)

(In reply to Thomas D. (:thomas8) from comment #5)

(In reply to Dave Miller [:justdave] (justdave@thunderbird.net) from comment #3)
The decision to only allow edits by members of editbugs was made in Bug 1484477. I see no pressing reason to change that in 2020.

Can we discuss this a lil' bit more? In this bug's description I've stated my reasoning. Could you refer to it and explain why you still don't see the reason to change that (especially in 2020 where every other bug trackers allow that)? I went thru Bug 1484477 and I see the discussion in this bug took place when Bugzilla just started to have edit option - the discussion is mainly around editbugs group. Now, let's give generic user an option to edit their bugs, ideally for limited time (1 hr or so) if possible.

(In reply to Thomas D. (:thomas8) from comment #6)

If reporter reports something wrong, the wrong part hangs around forever without any way of fixing it. Even with editbugs rights, I cannot fix someone else's bug description.

That's bug 1535000 which is close to landing (blocked by bug 1665646 which is in progress).

Now busy ppl gathered around Mozilla who read and understand bugs reported by generic users, must try to edit their description instead to let generic users update their descriptions if they spot an error? And I'm not saying about typos, I'm saying fixing crucial errors like forgotten 'not' or fixing double meaning sentences (not every one is english native).

Duplicate of this bug: 1749259
Duplicate of this bug: 1749259
You need to log in before you can comment on or make changes to this bug.