Closed Bug 1669927 Opened 2 years ago Closed 2 years ago

Can't import ICS files into calendar

Categories

(Thunderbird :: Untriaged, defect)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1652984

People

(Reporter: mail, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:81.0) Gecko/20100101 Firefox/81.0

Steps to reproduce:

Thunderbird 78.3.2 (64bit), Win10

In the calendar use the top menu to import events - select ICS file - click import all button in the popup window.

I tried also various test ICS files from the Internet and some old ICS files which worked in former TB versions.

Actual results:

This will result into an error message: "Beim importieren trat ein Fehler auf" (Translated: An error occurred during the import). Thunderbird error log shows the following:

[OverlayManager] Injecting into new window: chrome://messenger/content/importDialog.xhtml
[OverlayManager] Injecting into new window: chrome://calendar/content/calendar-ics-file-dialog.xhtml
Import error: TypeError: proxy must report the same value for the non-writable, non-configurable property '"addItem"' import-export.js:211
putItemsIntoCal chrome://calendar/content/import-export.js:211
importRemainingItems chrome://calendar/content/calendar-ics-file-dialog.js:218
_fireButtonEvent chrome://global/content/elements/dialog.js:487
_doButtonCommand chrome://global/content/elements/dialog.js:466
_handleButtonCommand chrome://global/content/elements/dialog.js:460
_handleButtonCommand self-hosted:844
loadEventsFromFile chrome://calendar/content/import-export.js:37
InterpretGeneratorResume self-hosted:1151
AsyncFunctionNext self-hosted:693

Expected results:

Import the ICS file into local calendar ...

Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1652984
You need to log in before you can comment on or make changes to this bug.