Closed Bug 1652984 Opened 6 months ago Closed 2 months ago

error when importing .ics file into calendar

Categories

(Calendar :: Import and Export, defect, P2)

Thunderbird 78

Tracking

(thunderbird_esr78+ verified, thunderbird84 verified)

VERIFIED FIXED
85 Branch
Tracking Status
thunderbird_esr78 + verified
thunderbird84 --- verified

People

(Reporter: chriechers, Assigned: rnons)

References

(Blocks 1 open bug)

Details

(Keywords: regression)

Attachments

(7 files)

TB78.0 beta4 on Linux
Upon pressing the 'Import All' button, an error pops up when trying to import an .ics file into a Google Calendar - see screenshot.

The error console shows:
Import error: TypeError: proxy must report the same value for the non-writable, non-configurable property '"addItem"' import-export.js:211
putItemsIntoCal chrome://calendar/content/import-export.js:211
importRemainingItems chrome://calendar/content/calendar-ics-file-dialog.js:218
_fireButtonEvent chrome://global/content/elements/dialog.js:487
_doButtonCommand chrome://global/content/elements/dialog.js:466
_handleButtonCommand chrome://global/content/elements/dialog.js:460
_handleButtonCommand self-hosted:844
loadEventsFromFile chrome://calendar/content/import-export.js:37
AsyncFunctionNext self-hosted:693

The .ics file imports just fine into the same Google Calendar using TB 68.

Blocks: tb78found

Do you have a sample .ics?

Keywords: regression

This is an .ics generated by booking.com, some information is redacted. See attachment.

Attached file .ics file

Import of that worked fine on trunk. Didn't try 78 yet, maybe changes from 78 to trunk?

I have similar problem on Thunderbird 80.0b1 (64-bit) on Linux.

I have an existing CalDAV calendar on GMail, accessible through Thunderbird. In Thunderbird, I export it to an ICS file. Then I add a new empty CalDAV calendar on another service (Migadu). I can create an event in that calendar in Thunderbird. I unsubscribe from the GMail calendar, then try to import the ICS file into the remaining (Migadu) calendar. If I click "Import all" in the dialog, I get the same error message shown by original poster, above. If instead I click "Add event" on every single event in the import dialog, they all seem to work, then I close the dialog with the X close button in upper-right, but none of the events appear in my calendar.

Error console:

Error while loading 'jar:file:///opt/thunderbird/omni.ja!/chrome/messenger/search-extensions/twitter/manifest.json' (NS_ERROR_FILE_NOT_FOUND) Extension.jsm:600
1596840190080 addons.xpi WARN Exception running bootstrap method startup on twitter@search.mozilla.org: Error: Error while loading 'jar:file:///opt/thunderbird/omni.ja!/chrome/messenger/search-extensions/twitter/manifest.json' (NS_ERROR_FILE_NOT_FOUND)(resource://gre/modules/Extension.jsm:600:20) JS Stack trace: readJSON/</<@Extension.jsm:600:20
onStopRequest@NetUtil.jsm:128:18
openWindowPrompt@Prompter.jsm:1229:17
openPrompt@Prompter.jsm:1087:12
openPromptSync@Prompter.jsm:1070:10
nsIPrompt_promptPassword@Prompter.jsm:1559:10
promptPassword@Prompter.jsm:1291:44
BrowseInTab background.js:36:9
Successfully loaded OpenPGP library librnp.so from /opt/thunderbird/librnp.so RNPLib.jsm:46:13
public keys: 2, secret keys: 2 RNPLib.jsm:194:15
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 684" data: no] L10nRegistry.jsm:684:19
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 684" data: no] L10nRegistry.jsm:684:19
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]" nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)" location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 684" data: no] L10nRegistry.jsm:684:19
Successfully loaded OTR library libotr.so.5 from /opt/thunderbird/libotr.so.5 OTRLib.jsm:43:13
TypeError: rangeStart is null CalRecurrenceInfo.jsm:491:23
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]'[JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]' when calling method: [calIRecurrenceInfo::getOccurrences] CalStorageCalendar.jsm:695
TypeError: rangeStart is null CalRecurrenceInfo.jsm:491:23
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]'[JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]' when calling method: [calIRecurrenceInfo::getOccurrences] CalStorageCalendar.jsm:695
TypeError: rangeStart is null CalRecurrenceInfo.jsm:491:23
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]'[JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]' when calling method: [calIRecurrenceInfo::getOccurrences] CalStorageCalendar.jsm:695
1596840249235 Telemetry::CoveragePing ERROR no endpoint base set Log.jsm:723
TypeError: rangeStart is null CalRecurrenceInfo.jsm:491:23
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]'[JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]' when calling method: [calIRecurrenceInfo::getOccurrences] CalStorageCalendar.jsm:695
TypeError: rangeStart is null CalRecurrenceInfo.jsm:491:23
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]'[JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]' when calling method: [calIRecurrenceInfo::getOccurrences] CalStorageCalendar.jsm:695
TypeError: rangeStart is null 2 CalRecurrenceInfo.jsm:491:23
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]'[JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]' when calling method: [calIRecurrenceInfo::getOccurrences] 2 CalStorageCalendar.jsm:695
TypeError: rangeStart is null CalRecurrenceInfo.jsm:491:23
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]'[JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]' when calling method: [calIRecurrenceInfo::getOccurrences] CalStorageCalendar.jsm:695
TypeError: rangeStart is null CalRecurrenceInfo.jsm:491:23
NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]'[JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]' when calling method: [calIRecurrenceInfo::getOccurrences] CalStorageCalendar.jsm:695

I can reproduce it now. Maybe that event needed to be added first and the import again?
Not sure what's needed. Perhaps what https://searchfox.org/comm-central/rev/085526b22865ea90738d779fa14bf711d46f69d3/calendar/base/modules/utils/calAsyncUtils.jsm#31 returns on rejections is not liked?

Component: General → Import and Export
Product: Thunderbird → Calendar
Version: 78 → unspecified
Attached file error console output
Even though the new calendar has one event in it, importing an ICS file still fails.

Even though the new calendar has one event in it, importing an ICS file still fails.

23:43:48.913 [OverlayManager] Injecting into new window: chrome://global/content/commonDialog.xhtml
23:43:58.362 [OverlayManager] Injecting into new window: chrome://calendar/content/calendar-properties-dialog.xhtml
23:44:21.780 Lightning:
Parsing failed for parts of the item (while this is considered to be a minor issue, we continue processing the item):
BEGIN:VCALENDAR

PRODID:-//Mozilla.org/NONSGML Mozilla Calendar V1.1//EN

VERSION:2.0

BEGIN:VTIMEZONE

TZID:Europe/Madrid

BEGIN:DAYLIGHT

TZOFFSETFROM:+0100

TZOFFSETTO:+0200

TZNAME:CEST

DTSTART:19700329T020000

RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=3

END:DAYLIGHT

BEGIN:STANDARD

TZOFFSETFROM:+0200

TZOFFSETTO:+0100

TZNAME:CET

DTSTART:19701025T030000

RRULE:FREQ=YEARLY;BYDAY=-1SU;BYMONTH=10

END:STANDARD

END:VTIMEZONE

BEGIN:VEVENT

CREATED:20191017T093830Z

LAST-MODIFIED:20191022T131922Z

DTSTAMP:20191022T131922Z

UID:935afa5f-bc62-4a0d-9f46-8a49890c31cf

SUMMARY:Aircon techs coming

STATUS:CONFIRMED

X-MOZ-LASTACK:20191022T075203Z

DTSTART;TZID=Europe/Madrid:20191022T090000

DTEND;TZID=Europe/Madrid:20191022T100000

X-LIC-ERROR:No value for LOCATION property. Removing entire property:

SEQUENCE:0

TRANSP:OPAQUE

X-MOZ-GENERATION:1

BEGIN:VALARM

ACTION:DISPLAY…
CalIcsParser.jsm:147
23:44:22.076 [OverlayManager] Injecting into new window: chrome://calendar/content/calendar-ics-file-dialog.xhtml
23:44:30.329
Import error: TypeError: proxy must report the same value for the non-writable, non-configurable property '"addItem"' 138 import-export.js:211
23:46:18.639 WebGL context was lost. Troubleshoot.jsm:658:17
23:46:18.644 Failed to create WebGL context: WebGL creation failed:

  • tryNativeGL
  • Exhausted GL driver options. Troubleshoot.jsm:625:21
    23:46:57.849 [OverlayManager] Injecting into new window: chrome://devtools/content/webconsole/index.html


The ICS file contains events that occurred in the past, recurring events that started in the past and continue into the future, and more.

In TB 80.0b4, I was able to cut and paste events from old calendar to new calendar, so now importing an ICS file is not a gating factor for me.

But when I start up TB, I get messages like this in my error console:

NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS: [JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]'[JavaScript Error: "rangeStart is null" {file: "resource:///modules/CalRecurrenceInfo.jsm" line: 491}]' when calling method: [calIRecurrenceInfo::getOccurrences]

I am guessing that some events pasted in from the old calendar have an old format, or have a starting date well in the past, and something is objecting to that. Can you please fix that somehow ? Thanks.

The problem still exists in TB78.2.0 pre - build1.

From the error console:
Import error: TypeError: proxy must report the same value for the non-writable, non-configurable property '"addItem"' import-export.js:211
putItemsIntoCal chrome://calendar/content/import-export.js:211
importSingleItem chrome://calendar/content/calendar-ics-file-dialog.js:178
bind_applyFunctionN self-hosted:1042
importSingleItem self-hosted:1005
loadEventsFromFile chrome://calendar/content/import-export.js:37
AsyncFunctionNext self-hosted:693

Duplicate of this bug: 1668085
Priority: -- → P2
Duplicate of this bug: 1669927
OS: Linux → All
Hardware: x86_64 → All
Version: unspecified → Thunderbird 78

I have had this issue after upgrading Thunderbird to 78.3.1: I was trying to import an ICS file into a locally-hosted Radicale CalDAV service. (I know: Radicale is quite rough around the edges but it seems to work okay for me.) The import simply says "an error occured and the import failed", and the same non-helpful error appears in the log (TypeError: proxy must report the same value for the non-writable, non-configurable property '"addItem"'...)

I did a test and found that the same ICS file could be imported to a freshly created local calendar. I was able to work around the issue by importing the ICS into the empty local calendar then selecting all the entries and cutting them, then pasting into the CalDAV calendar.

The problem still exists in TB 78.3.3 (64-bit) on Windows 10 Pro (fresh install).
Different from the initial error report: There is no visible error message to the user. It just silently fails (writes to the error console only).

However it should be clarified that this issue needs to be narrowed down to a) remote calendars and b) .ics-file import only:

  1. Import of .ics-files into a local calendar does work (confirms Jason's finding in Comment 13).
  2. Manual creation of items into remote calendars does work, are replicated
  3. Creating items in a local calendar first and then editing them to a remote calendar does work (quite similar to the Cut&Paste that Jason describes in Comment 13). So this is a work around.

The only thing that doesn't work is importing ics into remote calendars.

The error console stills shows this error message as reported initially or in Comment 10:
Import error: TypeError: proxy must report the same value for the non-writable, non-configurable property '"addItem"' import-export.js:211
putItemsIntoCal chrome://calendar/content/import-export.js:211 (further lines omitted).
which seems to refer to this javascript code in import-export.js at around line 200:

let pcal = cal.async.promisifyCalendar(destCal);
for (let item of aItems) {
// XXX prompt when finding a duplicate.
try {
await pcal.addItem(item);

Assignee: nobody → remotenonsense
Status: NEW → ASSIGNED
Attachment #9183712 - Attachment description: Bug 1652984 - Fix importing ics file into CalDAV calendar. r=mkmelin → Bug 1652984 - Fix importing ics file into CalDAV calendar. r=Fallen

(In reply to pcs2009 from comment #15)

The problem still exists in TB 78.3.3 (64-bit) on Windows 10 Pro (fresh install).
Different from the initial error report: There is no visible error message to the user. It just silently fails (writes to the error console only).

However it should be clarified that this issue needs to be narrowed down to a) remote calendars and b) .ics-file import only:

  1. Import of .ics-files into a local calendar does work (confirms Jason's finding in Comment 13).
  2. Manual creation of items into remote calendars does work, are replicated
  3. Creating items in a local calendar first and then editing them to a remote calendar does work (quite similar to the Cut&Paste that Jason describes in Comment 13). So this is a work around.

The only thing that doesn't work is importing ics into remote calendars.

The error console stills shows this error message as reported initially or in Comment 10:
Import error: TypeError: proxy must report the same value for the non-writable, non-configurable property '"addItem"' import-export.js:211
putItemsIntoCal chrome://calendar/content/import-export.js:211 (further lines omitted).
which seems to refer to this javascript code in import-export.js at around line 200:

let pcal = cal.async.promisifyCalendar(destCal);
for (let item of aItems) {
// XXX prompt when finding a duplicate.
try {
await pcal.addItem(item);

I can confirm all this still being the same in version 78.4.2.

The problem persists in Thunderbird 78.4.3:

Import error: TypeError: proxy must report the same value for the non-writable, non-configurable property '"addItem"' import-export.js:211
    putItemsIntoCal chrome://calendar/content/import-export.js:211
    importSingleItem chrome://calendar/content/calendar-ics-file-dialog.js:178
    bind_applyFunctionN self-hosted:1042
    importSingleItem self-hosted:1005
    loadEventsFromFile chrome://calendar/content/import-export.js:37
    AsyncFunctionNext self-hosted:693
´´´

ics file that cannot be imported to Thunderbird 78.4.3 running on Win10, Version 2004.

Would be nice if this can make it into v78.5.0.

(In reply to Christian Riechers from comment #0)

Created attachment 9163779 [details]
calendar_import_error.png

TB78.0 beta4 on Linux
Upon pressing the 'Import All' button, an error pops up when trying to import an .ics file into a Google Calendar - see screenshot.

The error console shows:
Import error: TypeError: proxy must report the same value for the non-writable, non-configurable property '"addItem"' import-export.js:211
putItemsIntoCal chrome://calendar/content/import-export.js:211
importRemainingItems chrome://calendar/content/calendar-ics-file-dialog.js:218
_fireButtonEvent chrome://global/content/elements/dialog.js:487
_doButtonCommand chrome://global/content/elements/dialog.js:466
_handleButtonCommand chrome://global/content/elements/dialog.js:460
_handleButtonCommand self-hosted:844
loadEventsFromFile chrome://calendar/content/import-export.js:37
AsyncFunctionNext self-hosted:693

The .ics file imports just fine into the same Google Calendar using TB 68.

Have the same issue now with TB 84.0b1 and has been this way since 80.0 i think (not been able to regress test as yet as to when it stopped working)

I can double click the ICS file (as per bug fix 357480) and that works, comes up with the cal options, which one to open it. If I select the specific cal and then the Import button on the Event itself then the OK it does nothing. No Event set up
If I select Import All on the main window, I get the same msg as Christian
If I get an invite and save the ICS file and import, same issue.
If I Accept the invite within the email the Event is added!

BTW - had to go to an ICS file in Finder and change its default opening prog for the 357480 bug to work

Attachment #9183712 - Attachment description: Bug 1652984 - Fix importing ics file into CalDAV calendar. r=Fallen → Bug 1652984 - Part 1: Fix importing ics file into CalDAV calendar. r=darktrojan

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/d499974a1e21
Part 1: Fix importing ics file into CalDAV calendar. r=darktrojan

Comment on attachment 9183712 [details]
Bug 1652984 - Part 1: Fix importing ics file into CalDAV calendar. r=darktrojan

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: Can't import ics file into CalDAV calendar, and can't select CalDAV in the calendar-creation dialog, see bug 1670420 and bug 1670724
Testing completed (on c-c, etc.): manually test
Risk to taking this patch (and alternatives if risky): it doesn't work anyway.

Attachment #9183712 - Flags: approval-comm-beta?

Comment on attachment 9183712 [details]
Bug 1652984 - Part 1: Fix importing ics file into CalDAV calendar. r=darktrojan

[Triage Comment]
Approved for beta

Attachment #9183712 - Flags: approval-comm-beta? → approval-comm-beta+
Target Milestone: --- → 85 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/3a8db8b96912
Part 2: Fix calIcalProperty.valueAsIcalString for GEO field. r=darktrojan

Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Blocks: 1670724

In my testing of the 84.0b3 release candidate on Ubuntu 18.04 LTS I successfully imported the above attached .ics file into my Google calendar and the events appear in the month of July.

Status: RESOLVED → VERIFIED

Comment on attachment 9183712 [details]
Bug 1652984 - Part 1: Fix importing ics file into CalDAV calendar. r=darktrojan

[Approval Request Comment]
Regression caused by (bug #): unknown
User impact if declined: ics import fails in some cases
Testing completed (on c-c, etc.): c-c and beta
Risk to taking this patch (and alternatives if risky): Should be safe

Attachment #9183712 - Flags: approval-comm-esr78?

Comment on attachment 9183712 [details]
Bug 1652984 - Part 1: Fix importing ics file into CalDAV calendar. r=darktrojan

[Triage Comment]
Approved for esr78

Attachment #9183712 - Flags: approval-comm-esr78? → approval-comm-esr78+

Comment on attachment 9189075 [details]
Bug 1652984 - Part 2: Fix calIcalProperty.valueAsIcalString for GEO field. r=darktrojan

[Triage Comment]
This was already taken on beta.
Approved for esr78 - to go with part 1

Attachment #9189075 - Flags: approval-comm-esr78+
Attachment #9189075 - Flags: approval-comm-beta+

This will not apply on c-esr78; not even close. The changes for calendar/base/content/dialogs/calendar-creation.js are updating lines in a function named fillProviders around line 427. The version of that file on c-esr78 only has 53 lines and no function named fillProviders.

Flags: needinfo?(remotenonsense)

(In reply to Rob Lemley [:rjl] from comment #32)

This will not apply on c-esr78; not even close. The changes for calendar/base/content/dialogs/calendar-creation.js are updating lines in a function named fillProviders around line 427. The version of that file on c-esr78 only has 53 lines and no function named fillProviders.

I merged the two parts into this patch, the changes to calendar-creation.js is irrelevant. Tested on local esr78 build.

Flags: needinfo?(remotenonsense) → needinfo?(rob)
Attachment #9192541 - Flags: review+
Flags: needinfo?(rob)
Attachment #9189075 - Flags: approval-comm-esr78+

Comment on attachment 9192541 [details] [diff] [review]
1652984-esr78.patch

Thanks!

[Triage Comment]
Previously approved by wsmwk.

Attachment #9192541 - Flags: approval-comm-esr78+

Also verified in testing of the Thunderbird 78.6.0 release candidate on Windows 10.

Is this supposed to be fixed in the released version 78.6.0?

Thanks

(In reply to rodrigo from comment #37)

Is this supposed to be fixed in the released version 78.6.0?

Thanks

Yes, does it work for you?

(In reply to Ping Chen (:rnons) from comment #38)

(In reply to rodrigo from comment #37)

Is this supposed to be fixed in the released version 78.6.0?

Thanks

Yes, does it work for you?

Hi. Yes, but it is missing a very important feature: drag and drop.

I am using 78.6.0 32-bit and standard ics file. I used to be able to drag the downloaded ics file to the Events pane and it would automatically bring up and fill the "New Event" window with the appropriate information from the ics file. Now the "New Event" window pops up but the ics file is added only as an attachment. It is not processed.

If I import it via Events and Tasks / Import, then it imports correctly via "Import" window. This is what was apparently fixed. I thought it would also fix the drag-and-drop to New Event functionality.

Is drag and drop to populate New Event window part of this effort? Different bug? Feature request?

Thanks

(In reply to rodrigo from comment #39)

I am using 78.6.0 32-bit and standard ics file. I used to be able to drag the downloaded ics file to the Events pane and it would automatically bring up and fill the "New Event" window with the appropriate information from the ics file. Now the "New Event" window pops up but the ics file is added only as an attachment. It is not processed.

I see, I didn't know about this feature.

Is drag and drop to populate New Event window part of this effort? Different bug? Feature request?

It's not part of this bug, and seems no other bugs tracking it. Do you mind filing a new bug? Thanks.

I didn't know about this method either.

Tried dragging an .ics Canadian Holiday calendar from my File Manager to the Events section of the Today pane in TB 78.6.0.
An event dialog opened with the file only added as an attachment.

Tested it with an exported calendar from 78.6.0.
Opened my Thunderbird 68.10.0 graciously not updated by Ubuntu yet.
Dragged and dropped the calendar into the Events section of the Today Pane.
All the events opened in a tab available for editing and saving.

(In reply to Ping Chen (:rnons) from comment #40)

(In reply to rodrigo from comment #39)

I am using 78.6.0 32-bit and standard ics file. I used to be able to drag the downloaded ics file to the Events pane and it would automatically bring up and fill the "New Event" window with the appropriate information from the ics file. Now the "New Event" window pops up but the ics file is added only as an attachment. It is not processed.

I see, I didn't know about this feature.

Is drag and drop to populate New Event window part of this effort? Different bug? Feature request?

It's not part of this bug, and seems no other bugs tracking it. Do you mind filing a new bug? Thanks.

Thank you. I have opened a new bug 1683460

Duplicate of this bug: 1681252

Humm As for the drag and drop feature, new to me too

Regarding the import failure, was not aware this had been fixed - weird, will test out in a mo,
came here to find my original bug release on this issue (well thought I had raised one, must have added to this one instead)

No - not loosing my marbles (they went years ago :-( )

The drag and drop must be a Windows thing as not working on the macOS 10.15.7
Tried direct from email, from downloads, into Cal itslef or just the New Event pane, not a dicky-bird

You need to log in before you can comment on or make changes to this bug.