Closed Bug 1671401 Opened 2 years ago Closed 2 years ago

Scrollbar on bugzilla page becomes almost invisible on Windowsx64+ Intel with "widget.disable-native-theme-for-content = true"

Categories

(Core :: Widget: Win32, defect)

defect

Tracking

()

RESOLVED FIXED
83 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox81 --- unaffected
firefox82 --- unaffected
firefox83 --- disabled

People

(Reporter: mayankleoboy1, Assigned: heycam)

References

(Regression)

Details

(Keywords: nightly-community, regression)

Attachments

(3 files)

Use nightly on Windowsx64+ Intel

Set widget.disable-native-theme-for-content = true

Open https://bugzilla.mozilla.org/buglist.cgi?resolution=---&resolution=DUPLICATE&chfieldto=Now&chfield=%5BBug%20creation%5D&query_format=advanced&chfieldfrom=24h&product=Core&list_id=15452820

ER: Scrollbar is visible
AR: Scrollbar becomes invisible

2020-10-15T19:22:10.756000: DEBUG : Found commit message:
Bug 1669368 - Use LookAndFeelCache to pass Gtk theme-derived scrollbar colors to content processes. r=spohl

Differential Revision: https://phabricator.services.mozilla.com/D93467

2020-10-15T19:22:10.756000: DEBUG : Did not find a branch, checking all integration branches
2020-10-15T19:22:10.756000: INFO : The bisection is done.
2020-10-15T19:22:10.771000: INFO : Stopped

Regressed by: 1669368
Has Regression Range: --- → yes
Summary: Scrollbar on bugzilla page becomes almost invisible → Scrollbar on bugzilla page becomes almost invisible on Windowsx64+ Intel with "widget.disable-native-theme-for-content = true"

Gnome Xwayland, Debian Testing
Scrollbar thumb is invisible until hovered.

Edit: Breeze theme. (Gnome with Plasma-style window buttons.)

Flags: needinfo?(cam)
OS: Unspecified → All
Hardware: Unspecified → All
See Also: → 1671516

Darkspirit, what Gtk theme are you using on Linux?

Definitely there wasn't an intention to change the colors that were being used on Windows, though.

Flags: needinfo?(cam) → needinfo?(jan)

(Thanks you answered in an edit.)

Flags: needinfo?(jan)
Assignee: nobody → cam
Status: NEW → ASSIGNED

(I answered only seconds before you asked. Sorry :D)
I must have seen this article: https://www.computerbase.de/2016-07/linux-gnome-mit-breeze-im-kde-look/
Download https://github.com/dirruk1/gnome-breeze/archive/master.zip, extract it to ~/.themes (example path: ~/.themes/gnome-breeze-master/README.md), select it with Gnome Tweak Tool.

I have a patch for the problem on Windows, but I can't reproduce the issue with the Breeze theme.

Attached image screen shot

This is what Firefox looks like for me when I use the Breeze theme (not the dark one), when the scrollbar isn't hovered over.

Attached image screen shot (hovering)

And hovered over the thumb. The colors do match what I see in other applications (e.g. gedit), though we are drawing them with an Adwaita-like shape rather than what the Breeze theme itself uses.

Duplicate of this bug: 1671516

Darkspirit, I see that the theme has different variants for a few different Gtk versions, and some of them use images. Although I would've thought that Debian testing had a new enough Gtk to end up with the gtk-3.20 version of the theme, which uses only solid colors.

Bug 1671304 should detect themes with images that we can't handle, and fall back to using some pre-defined colors.

Otherwise on Windows, we have a ColorID::Scrollbar but not any of the other scrollbar part
colors, and the Windows-provided value for Scrollbar doesn't work well
with the default values for the other scrollbar parts that come from the
non-native theme.

Pushed by cmccormack@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/67cc13c5744b
Use separate Scrollbar and ThemedScrollbar ColorIDs. r=spohl
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 83 Branch
You need to log in before you can comment on or make changes to this bug.