Closed Bug 1671516 Opened 9 months ago Closed 9 months ago

Non-native scrollbar does not show the scrollbar thumb unless you mouse over the thumb

Categories

(Core :: Widget: Gtk, defect)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED DUPLICATE of bug 1671401
Fission Milestone MVP
Tracking Status
firefox-esr78 --- unaffected
firefox81 --- unaffected
firefox82 --- unaffected
firefox83 --- affected

People

(Reporter: cpeterson, Unassigned)

References

(Regression)

Details

@ heycam, I suspect this is a regression from your scrollbar bug 1670853.

Steps to reproduce

  1. Set widget.disable-native-theme-for-content = true.
  2. Restart Firefox.
  3. Load a page that is long enough to show the page scrollbar.
  4. Scroll down the page.

Expected result

The page's scrollbar should show the scrollbar thumb.

Actual result

The page's scrollbar does not show the scrollbar thumb unless you mouse over the thumb.

Flags: needinfo?(cam)
See Also: → 1671401

Chris, is this on Linux? Can you tell me what Gtk theme you are using?

Flags: needinfo?(cam) → needinfo?(cpeterson)

(In reply to Cameron McCormack (:heycam) from comment #1)

Chris, is this on Linux? Can you tell me what Gtk theme you are using?

No. I'm running Windows 10 in dark mode.

Flags: needinfo?(cpeterson)
OS: Unspecified → Windows 10

Thanks. I have a patch that should fix that, which I'll post on bug 1671401.

Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1671401
You need to log in before you can comment on or make changes to this bug.