Closed Bug 1672401 Opened 1 month ago Closed 16 days ago

PiP description is displayed incorrectly on whereby.com

Categories

(Toolkit :: Video/Audio Controls, defect, P3)

Firefox 84
defect

Tracking

()

VERIFIED FIXED
84 Branch
Tracking Status
firefox82 --- wontfix
firefox83 --- wontfix
firefox84 --- verified

People

(Reporter: alin.ilea, Assigned: jack1391)

References

(Blocks 2 open bugs, )

Details

Attachments

(3 files)

Attached image 2020-10-21_17h20_03.png

Affected versions:

Nightly 84.0a1

Tested on:

Ubuntu 18.04, Windows 10

Steps:

  1. Launch Firefox Nightly with new profile and go to https://whereby.com
  2. Join a meeting.
  3. Click on the PiP icon.

Actual result:

The PiP description is displayed incorrectly (is displayed like in RTL).

Expected result:

The PiP description should be displayed accordingly like in any video.

Note: The PiP icon is not displayed in Beta 83 and Release 82 on whereby.com

I'm assuming they are doing something to mirror the video by applying transform: scaleX(-1)?

Can we set transform: initial !important on the PiP CSS?

Flags: needinfo?(mconley)

Yeah, I think generally transform: scaleX(-1) is how this works. Unfortunately, setting transform: initial !important doesn't work on child elements for something set to scaleX(-1);:

https://jsbin.com/duyuzebewu/edit?html,css,output

We can, however, maybe used the privileged getTransformToViewport method here: https://searchfox.org/mozilla-central/rev/dbced93f1c57942501c23d4633d01ce59d9087a1/dom/webidl/Element.webidl#169. If we call that on the <video>, then if it (or one of its ancestors) is transformed such that the .a field on the DOMMatrix is -1, then we should set transform: scaleX(-1) on the UAWidget, perhaps when the mouse first moves over the video.

Blocks: 1662870
Flags: needinfo?(mconley)
Assignee: nobody → jack1391
Duplicate of this bug: 1673674
Severity: -- → S3
Status: NEW → ASSIGNED
Priority: -- → P3
Duplicate of this bug: 1550416
See Also: → 1668863
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1ecbca0ad84f
Picture-in-Picture description is displayed incorrectly on whereby.com. r=mconley,Gijs
Status: ASSIGNED → RESOLVED
Closed: 16 days ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch
Attached image Beta screenshot

This happens for me on Beta 83.0b10 build ID 20201108174701

This happens for me on Beta 83 build

And has existed longer according to the duplicate bugs like bug 1592909.

Verified - Fixed in latest Nightly 84.0a1 (2020-11-09) (build id: 20201109215349).

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.