Closed Bug 1673861 Opened 11 months ago Closed 11 months ago

Footer buttons in panelpopups have a border radius

Categories

(Thunderbird :: Theme, defect)

defect

Tracking

(thunderbird_esr78 fixed, thunderbird83 fixed)

RESOLVED FIXED
84 Branch
Tracking Status
thunderbird_esr78 --- fixed
thunderbird83 --- fixed

People

(Reporter: Paenglab, Assigned: Paenglab)

Details

(Keywords: regression)

Attachments

(2 files, 1 obsolete file)

In panelpopups the big buttons on bottom, like the Add-on installation confirmation or the edit contact panel opened through the address star in the message header, have on Linux and better visible on Mac a border radius. They should have none. On Windows 10 this isn't visible as we have a button border radius of 0px.

This is probably a regression of bug 1650789.

When I was on it, I simplified the editContactPanel styles by using the toolkit classes instead of our own. I also moved the shared code to a shared file.

For the issue with the border-radius is only the change in messenger.css needed.

Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #9184247 - Flags: review?(alessandro)
Comment on attachment 9184247 [details] [diff] [review]
1673861-no-border-radius-panel-buttons.patch

Review of attachment 9184247 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good, thanks.
I noticed that now the `Done` button when viewing the contact popup is way larger than the other 2 buttons.
Is this on purpose?
Could it be fixed so the 3 buttons expand to uniformly fill the available space?
Attachment #9184247 - Flags: review?(alessandro) → review+

Reverted the flex rule that the popup-notification-primary-button class uses in editContactPanel.css to make them the same width.

Attachment #9184247 - Attachment is obsolete: true
Attachment #9184368 - Flags: review+
Target Milestone: --- → 84 Branch

Pushed by mkmelin@iki.fi:
https://hg.mozilla.org/comm-central/rev/275c4b654b7e
Remove the border-radius of the panel's bottom buttons. r=aleca

Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED

Comment on attachment 9184368 [details] [diff] [review]
1673861-no-border-radius-panel-buttons.patch

[Approval Request Comment]
Regression caused by (bug #): 1650789
User impact if declined: weird appearance of the footer buttons in panelpopups
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9184368 - Flags: approval-comm-beta?

[Approval Request Comment]
Regression caused by (bug #): 1650789
User impact if declined: weird appearance of the footer buttons in panelpopups
Testing completed (on c-c, etc.): on c-c
Risk to taking this patch (and alternatives if risky): low

Attachment #9184507 - Flags: approval-comm-esr78?

Comment on attachment 9184368 [details] [diff] [review]
1673861-no-border-radius-panel-buttons.patch

[Triage Comment]
Approved for beta

Attachment #9184368 - Flags: approval-comm-beta? → approval-comm-beta+

Comment on attachment 9184507 [details] [diff] [review]
1673861-no-border-radius-panel-buttons-ESR.patch

[Triage Comment]
Approved for esr78

Attachment #9184507 - Flags: approval-comm-esr78? → approval-comm-esr78+
You need to log in before you can comment on or make changes to this bug.