Closed Bug 1674000 Opened 1 year ago Closed 1 year ago

Use better colors for the search mode indicator in Windows high-contrast mode

Categories

(Firefox :: Address Bar, defect, P3)

defect
Points:
1

Tracking

()

VERIFIED FIXED
84 Branch
Iteration:
84.1 - Oct 19 - Nov 01
Tracking Status
firefox83 --- verified
firefox84 --- verified

People

(Reporter: adw, Assigned: adw)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Currently the search indicator uses the default/light colors in Windows high-contrast mode. They look out of place, and as Tim suggests, we should use system colors anyway:

High-contrast mode can also be completely light with black borders on Windows, not sure that would fit well in this case. Best choice for HC-mode would be using system colors (Highlight + HighlightText maybe?).

See Also: → 1671668, 1673011

Here's what this looks like in all of Windows 10's high-contrast themes. I tried keeping the border the same color as the text but I don't think it looked good, so I made it the same color as the background.

{F2546521}

Pushed by dwillcoxon@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e7f1f7237720
Use better colors for the search mode indicator in Windows high-contrast themes. r=ntim
Flags: needinfo?(adw)
Flags: qe-verify+
Flags: in-testsuite-
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 84 Branch
Attached patch Beta patchSplinter Review

Approval Request Comment
[Feature/Bug causing the regression]:
Quantumbar update2, search mode

[User impact if declined]:
The new search mode indicator looks pretty bad in Windows high-contrast themes. This patch improves its appearance.

[Is this code covered by automated tests?]:
No, this is a CSS-only change.

[Needs manual test from QE? If yes, steps to reproduce]:
Yes, enter search mode in a high-contrast theme on Windows. This is the expected appearance for each of the four high-contrast themes on Windows 10: https://d3kxowhw4s8amj.cloudfront.net/file/data/oclsbldzqshuf3rojw7n/PHID-FILE-gmxisup4rbv5d3p6fquk/high-contrast-1674000.png

[Is the change risky?]:
No, low risk

[Why is the change risky/not risky?]:
This is a CSS-only change.

I'm posting a new patch for beta instead of requesting uplift on the Phabricator revision because bug 1674031 landed in between bug 1671668, which was uplifted, and this bug, so the Phabricator revision doesn't apply cleanly to beta due to a one-line conflict. Bug 1674031 is cleanup and therefore doesn't need to be uplifted, but it also wouldn't hurt if anyone preferred to do that instead.

I've verified this patch on beta on Windows and Mac.

Flags: needinfo?(adw)
Attachment #9184702 - Flags: approval-mozilla-beta?
QA Whiteboard: [qa-triaged]

Comment on attachment 9184702 [details] [diff] [review]
Beta patch

approved for 83.0b7

Attachment #9184702 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Verified as fixed using latest Nightly 84.0a1 2020-10-29 under Win 10 64-bit.
Leaving the flags until 83 Beta 7 build will be available for verification.

Verified as fixed using Firefox 83 beta 7, Win 10 x64.

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
Blocks: 1677102
You need to log in before you can comment on or make changes to this bug.