Mozilla stalled at splash screen on startup (XUL FastLoad File corruption) (XUL.mfasl)

VERIFIED DUPLICATE of bug 169777

Status

()

Core
XUL
--
critical
VERIFIED DUPLICATE of bug 169777
16 years ago
10 years ago

People

(Reporter: Greg K., Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({hang})

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2a) Gecko/20020906
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2a) Gecko/20020906

This morning, FizzillaCFM/2002090608 failed to start up. It reached the splash
screen and showed, "Starting up...", but failed to complete startup. I let the
process continue for about five minutes, with no success. CPU usage contined
between 10% and 60% by Mozilla during this time.

Experimenting with removing certain files from my profile (cache, etc.), I was
able to get it to start up after removing the XUL FastLoad File.

I'm using the Pinstripe theme, a version updated with the changes for bug 161226.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. Start Mozilla


Actual Results:  
Mozilla stalls on startup.

Expected Results:  
Mozilla should have completed startup.

I'll make the XUL FastLoad File in question available via my web server. URL to
come.
(Reporter)

Comment 1

16 years ago
The XUL FastLoad File is available from [http://greg.tcp.com/mozilla/167523/XUL
FastLoad File.sit.bin].

Comment 2

16 years ago
-> ben, cc: brendan for fastload issues
Assignee: hyatt → ben
Status: UNCONFIRMED → NEW
Ever confirmed: true
Unless someone catches Mozilla in a debugger, this may not be debugable from the
FastLoad file.  Greg, do you have a debugger, or a way to trace system calls, or
otherwise to see what Mozilla is doing while stalled with the bad FastLoad file
in place?

/be

Comment 4

16 years ago
I got also this some times. But It is not a real Hang (for me). After 10 or 15
minutes Mozilla worked Correctly (Mac OS 9.1 and many builds)
(Reporter)

Comment 5

16 years ago
Created attachment 98499 [details]
Sampler data taken while Mozilla is trying to start up

Brendan, here is about five seconds worth of Sampler data taken while Mozilla's
trying to start up.
(Reporter)

Comment 6

16 years ago
Jean-Pierre is right. I let Mozilla continue, and it completed starting up
sometime during my 15 minutes away from the machine.

I know Mozilla clears the cache after a crash, and that can take some time, but
this was happening even after I manually deleted the cache folder.
Ouch, we're suffering some kind of Mac-specific tiny-gram read storm, perhas due
to FastLoad file fragmentation(?).  Cc'ing necko and Mac gurus.

/be

Comment 8

16 years ago
OK, Mac OS 9 and MacOSX. It was not a dream

I am not sure, but i think also that opening the script manager and other 
circumstances. I repeat i am not sure

I'll signal it here next time

The rule is if Mozilla cause an great disk activity per moment and seems to loop, 
wait!!!

Comment 9

16 years ago
I'm having what seems to be the same problem. (I arrived here by searching for
`XUL FastLoad File'...) For me Mozilla starts up normally, but I get a 100%
reproducible hang (spinning wheel and skyrocketing CPU usage, have to force
quit) by the following steps:

  1. Load some page -- say http://www.mozilla.org
  2. Select some text -- say `Mozilla News'
  3. Hit `Find' (command-F)

I took a 1 minute call graph while Mozilla spinned and will attach it next. Like
greg's call graph, it involves nsFastLoadFileReader, and the problem ceases if I
delete the XUL FastLoad File before restarting Mozilla. Similar/related(?): bug
168516.

(Let me know if you want to see my corrupt FastLoad file, or if my case is
different enough that I should file it separately.) 
Summary: Mozilla stalled at splash screen on startup → Mozilla stalled at splash screen on startup (XUL FastLoad File corruption)

Comment 10

16 years ago
Created attachment 99831 [details]
Call graph after hitting `Find'

Updated

16 years ago
QA Contact: shrir → jrgm

Comment 11

16 years ago
> If you let Mozilla spin, does it eventually start up (after many minutes)?
> Please say yea or nay in the bug.
> 
> /be

Well in my case Mozilla starts up quite normally -- only the steps of comment 9
make it hang. (The call graph then is much the same as greg's, so that's why I
filed this here for now.) I've just let it spin for over an hour while I was
out, and it never stopped. Memory usage went from:

  PID COMMAND      %CPU   TIME   #TH #PRTS #MREGS RPRVT  RSHRD  RSIZE  VSIZE 
 1173 Mozilla      0.8%  0:12.85   6    88   341  15.1M  24.1M  30.3M  83.6M 

to:

  PID COMMAND      %CPU   TIME   #TH #PRTS #MREGS RPRVT  RSHRD  RSIZE  VSIZE 
 1173 Mozilla     85.0% 61:34.70   6    87   402   268M+ 7.48M   270M+  344M 
 

Comment 12

16 years ago
Looks like my FastLoad file became corrupt again. This time it's the same
symptom as Greg: Mozilla doesn't start up. Again, deleting the FastLoad file
solves the problem.

Of possible interest: the cause may well be the "crash while editing prefs" that
I experienced just before this (re)start. See bug 150893, comment 13 for the
stack trace of that crash; its timestamp coincides with the last modification
date of the corrupt FastLoad file. Greg, I think you also had a similar crash? 
(Reporter)

Comment 13

16 years ago
FZiegler, I've experienced that crash, but I don't know if it precipitated this
problem. As I recall, i encountered this problem first thing on starting up
Mozilla and my computer that morning so I don't know what I did previously.

Comment 14

16 years ago
*** Bug 176049 has been marked as a duplicate of this bug. ***

Updated

16 years ago
Keywords: hang

Comment 15

16 years ago
*** Bug 133223 has been marked as a duplicate of this bug. ***

Updated

16 years ago
OS: MacOS X → All
Hardware: Macintosh → All
Summary: Mozilla stalled at splash screen on startup (XUL FastLoad File corruption) → Mozilla stalled at splash screen on startup (XUL FastLoad File corruption) (XUL.mfasl)

Comment 16

16 years ago
*** Bug 181280 has been marked as a duplicate of this bug. ***

Comment 17

16 years ago
This is not only a Mac issue. I just had the same bug on Linux

Comment 18

16 years ago
We had the same problem on Debian Linux. Only as we deleted the XUL.mfasl file
and restored it from CVS (where we save our configs in regular intervals), the
Mozilla started to work again.

The first things which stopped working was a download.

Jörg
Blocks: 134576

Comment 19

16 years ago
> Only as we deleted the XUL.mfasl file and restored it from CVS (where we save 
> our configs in regular intervals), ...

Just a quick note: a fastload file is only used if it is used with the same
filepaths for the jar files, and they have exactly the same modified time. 
Otherwise, the fastload file will be deleted. You can save the XUL.mfasl with
the rest of your profile if you want, but I would recommend that you consider
it to be a "volatile" part of your profile, and to not bother saving it.

Comment 20

16 years ago
Experiencing this very issue with Mozilla/1.2.1 on Windows 2000 sp3
and 100% CPU Utilization and memory growing without bounds until I kill the
process, along with freezes when sending email such as bug 168516
with the same CPU Utilization and memory leakage.

Comment 21

16 years ago
Duplicate of bug 169777?

Comment 22

16 years ago
Yeah, you're right. This is a dupe. In fact, the other one was filed later, but
there has been more activity over there. Voters, please move your votes to the
other one if you care :)

*** This bug has been marked as a duplicate of 169777 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 23

16 years ago
v
Status: RESOLVED → VERIFIED
(Removing 'Blocks: bug 134576', to clear things up there.)
No longer blocks: 134576

Updated

10 years ago
Component: XP Toolkit/Widgets: XUL → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.