Closed Bug 1676250 Opened 4 years ago Closed 4 years ago overcounts impressions


(Firefox :: Address Bar, defect, P1)




85 Branch
85.1 - Nov 16 - Nov 29
Tracking Status
firefox83 --- wontfix
firefox84 + verified
firefox85 + verified


(Reporter: bugzilla, Assigned: bugzilla)




(1 file) is counted every time UrlbarProviderTabToSearch sends an onboarding result to the muxer. This is wrong in two ways:

  1. The probe is incremented on every keystroke rather than just once when the search engine domain is autofilled (see bug 1675611), and
  2. The probe is incremented when the user's typed query partially matches a search engine domain, but it is not autofilled. For example, searching for "a" matches "", but if the user's profile doesn't autofill "", the onboarding result is not shown but the probe is incremented.
Assignee: nobody → htwyford
Iteration: --- → 85.1 - Nov 16 - Nov 29

[Tracking Requested - why for this release]:
Some Telemetry is broken in 83. Data Science and Product have asked that we prioritize a fix. The fix is limited in scope to only the affected probe.

Pushed by
Stop overcounting r=adw
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch

Comment on attachment 9188677 [details]
Bug 1676250 - Stop overcounting r?adw!

Beta/Release Uplift Approval Request

  • User impact if declined: One Telemetry probe will continue to be broken on 84. It's a probe that measures a feature that's new to 83, so we'd like it fixed ASAP.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. On a new en-US profile, visit and bookmark it. Close the tab.
  1. Start typing "" in the address bar. Observe that a large "Search with" result is shown as the second result once you type a few characters.
  2. Continue typing all the letters of "". The large result should be shown the entire time.
  3. Click away from the address bar so it closes. Open about:telemetry and search for "".
  4. Observe the key tabtosearch_onboard-shown has a value of 1.
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Fix is limited in scope to just the affected probe. Worst case is that we record bad/no data for this single probe. Verified on Nightly with tests.
  • String changes made/needed:
Attachment #9188677 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9188677 [details]
Bug 1676250 - Stop overcounting r?adw!

Approved for 84.0b4.

Attachment #9188677 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

Verified as fixed on Windows 10 x64, Ubunutu 20.04 and on MacOS 10.15 on Firefox Nightly 85.0a1 (2020-11-22).

I tried to verify the bug on Firefox 84.0b4 also but the result of "tabtosearch_onboard-shown" is 2 after everytime I tried on all the OS's mentioned in the previous comment.
I thought at first that the changes are not landed on Firefox 84.0b4 yet but I verified in about:buildconfig and it shows that the changes should be on Firefox 84.0b4.
Could you please take a look at this?

Flags: needinfo?(htwyford)

I can't reproduce on 84b6. Are you sure that the Amazon tab-to-search result wasn't shown for a moment at some other point in your testing? For example, when you typed the a in about:telemetry? If it wasn't shown a second time, could you please upload a screen recording of the steps you took to get a value of 2?

Flags: needinfo?(htwyford) → needinfo?(hani.yacoub)

I followed the same steps while testing on Firefox Nightly 85.0a1 (2020-12-01) and on Firefox Beta 84.0b7.
"tabtosearch_onboard-shown" value while testing on Nightly was 1 and while testing on Beta the value was 2.

Below I attached a screen recording with the results of testing on Beta and on Nightly on MacOS 10.14.6

Flags: needinfo?(hani.yacoub) → needinfo?(htwyford)

Thanks for the screen recordings. In the Beta screen recording around 20s from the end, you can see that the Amazon tab-to-search item is shown a second time when you type the "a" in about:telemetry. That means this is working as expected. Thank you!

Flags: needinfo?(htwyford)

Based on comment 12 I will mark this as verified as fixed.
Thank you!

QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.