Closed Bug 1677272 Opened 2 years ago Closed 1 year ago

On Mac OS Big Sur, it takes significantly longer to highlight an item and to display contents of an item

Categories

(Thunderbird :: Folder and Message Lists, defect, P2)

Unspecified
macOS

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: nishi2015_1107, Unassigned)

References

Details

(Keywords: perf)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.16; rv:82.0) Gecko/20100101 Firefox/82.0

Steps to reproduce:

  1. Click an email item on a list of mail box

Actual results:

  1. It takes approximately 3 seconds that clicked email item is highlighted.
  2. It takes approximately 2 seconds to display the contents of the clicked item from highlighted.

Expected results:

  1. It should take within 0.3 second that clicked email item is highlighted.
  2. It should within 0.3 second to display contents of the clicked item from highlighted.

<Frequency>
Always(3/3)

<Note>
In case of previous ios 14, the issue was not reproduced.

OS: Unspecified → macOS
Summary: Bad performance on Big Sur → Too low performance on Big Sur
Summary: Too low performance on Big Sur → On Mac OS Big Sur, it takes significantly longer to highlight an item and to display contents of an item
Component: Untriaged → Folder and Message Lists
Keywords: perf

I have a question.
Is it only in Japan?

On Twitter of Japan, many users claim the issue.
https://twitter.com/search?q=thunderbird%20big%20sur&src=typeahead_click

Severity: -- → S2
Priority: -- → P2

Does not only affect Big Sur, I can confirm most of these issues with Catalina. Something happened in 78, as 77 is reportedly fine.

At least one person has reported the issue to be temporary. Please check Tools > Activity Manager and Tools > Developer Tools > Error Console for activity and events that might be impacting responsiveness

(In reply to Nicolas from comment #5)

Does not only affect Big Sur, I can confirm most of these issues with Catalina. Something happened in 78, as 77 is reportedly fine.

Really?
When I use Catalina, the issue was not reproduced...

(In reply to Wayne Mery (:wsmwk) from comment #6)

At least one person has reported the issue to be temporary. Please check Tools > Activity Manager and Tools > Developer Tools > Error Console for activity and events that might be impacting responsiveness

I understood. But I don't understand contents of Error Console.
Moreover, I have no idea how to attach the contents of Error Console to this ticket.

But I think it is necessary to analyze.
So, would it possible for you to explain how to convert Console contents to a kind of file ?

Flags: needinfo?(vseerror)

Sorry...
❌ would it possible for you to explain how to convert Console contents to a kind of file ?
○ would it be possible for you to explain how to convert Console contents to a kind of file ?

Flags: needinfo?(vseerror)

This is Error Console contents.

I attached a console export file.
If you have any questions or want me to ask something, please feel free to contact me.

Interestingly my Thunderbird 78 (de locale) works normally like ever on macOS Big Sur. According to your console it could be a L10n issue? Have you tried another locale (maybe en-US), if it behaves the same on your computer?

(In reply to NISHI from comment #7)

(In reply to Nicolas from comment #5)

(In reply to NISHI from comment #4)
...
Does not only affect Big Sur, I can confirm most of these issues with Catalina. Something happened in 78, as 77 is reportedly fine.

Really?
When I use Catalina, the issue was not reproduced...

I double checked, it seems I was wrong, sorry. I misunderstood and mixed a few issues here. It seems I am only having the extreme lags when scrolling the account pane (left pane). (see bug 1677380 )

I have same problem after updating to Big Sur. Before updating macOS, I had not have such problem while using Thunderbird.

And in my case, when I selected maximize/minimize button on the left corner of the screen, it seems resizing of the screen is affected. The screen is not expanded to suitable size, and it seems that the axis of the left corner is not set to correct position.

Big Sur 11.0.1 on Mac Book Pro, mid-2014, Quad core Intel Core i7 2.8GHz, 16GB Mem, 1TB SSD.

13:19:58.519 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658"  data: no] 2 L10nRegistry.jsm:658:19
13:19:58.831 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658"  data: no] 2 L10nRegistry.jsm:658:19
13:19:58.871 Error while loading 'jar:file:///Applications/Thunderbird.app/Contents/Resources/omni.ja!/chrome/messenger/search-extensions/twitter/manifest.json' (NS_ERROR_FILE_NOT_FOUND) Extension.jsm:570
13:19:58.872 1605586798871	addons.xpi	WARN	Exception running bootstrap method startup on twitter@search.mozilla.org: Error: Error while loading 'jar:file:///Applications/Thunderbird.app/Contents/Resources/omni.ja!/chrome/messenger/search-extensions/twitter/manifest.json' (NS_ERROR_FILE_NOT_FOUND)(resource://gre/modules/Extension.jsm:570:20) JS Stack trace: readJSON/</<@Extension.jsm:570:20
onStopRequest@NetUtil.jsm:128:18
13:19:59.361 OpenGL compositor Initialized Succesfully.
Version: 2.1 NVIDIA-16.0.13 
Vendor: NVIDIA Corporation
Renderer: NVIDIA GeForce GT 750M OpenGL Engine
FBO Texture Target: TEXTURE_2D
13:19:59.482 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658"  data: no] 2 L10nRegistry.jsm:658:19
13:20:01.384 OpenGL compositor Initialized Succesfully.
Version: 2.1 NVIDIA-16.0.13 
Vendor: NVIDIA Corporation
Renderer: NVIDIA GeForce GT 750M OpenGL Engine
FBO Texture Target: TEXTURE_2D
13:20:01.651 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658"  data: no] 2 L10nRegistry.jsm:658:19
13:20:01.651 [Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658"  data: no] 2 L10nRegistry.jsm:658:19
13:20:12.570 このページは非標準の “zoom” プロパティを使用しています。関連するプロパティの値で calc() を使用するか、"transform" に加えて "transform-origin: 0 0" を使用することを検討してください。 thunderbird
13:20:12.694 一部の Cookie は推奨される “sameSite“ 属性がありません 2
13:20:13.283 OpenGL compositor Initialized Succesfully.
Version: 2.1 NVIDIA-16.0.13 
Vendor: NVIDIA Corporation
Renderer: NVIDIA GeForce GT 750M OpenGL Engine
FBO Texture Target: TEXTURE_2D 2

(In reply to Nomis101 from comment #12)

Interestingly my Thunderbird 78 (de locale) works normally like ever on macOS Big Sur. According to your console it could be a L10n issue? Have you tried another locale (maybe en-US), if it behaves the same on your computer?

The attached file was an output when I set to English(United States).
See also an additional screenshot.
The issue is reproduced both en-US and Japanese.

When the Thunderbird is set to Japanese, its error console is output in Japanese, too.
As you may realize, a part of the file attached by jun.yamashita is written in Japanese.

(In reply to Nicolas from comment #13)

(In reply to NISHI from comment #7)
...
I double checked, it seems I was wrong, sorry. I misunderstood and mixed a few issues here. It seems I am only having the extreme lags when scrolling the account pane (left pane). (see bug 1677380 )

OK, understood.

Status: UNCONFIRMED → NEW
Ever confirmed: true

(In reply to Wayne Mery (:wsmwk) from comment #3)

Other slowness reports for Big Sur

hang report https://support.mozilla.org/en-US/questions/1313762 and https://support.mozilla.org/en-US/questions/1313810

Wayne,
No, I don't think it is isolated to only Japan or that it has anything to do with the "Language" set used...

I too am experiencing the same identical problem as "NISHI" and the problem (Sluggishness) is ONLY happening in Thunderbird, no other Apps or Programs or Internet Searches/Websites are affected...

I first thought that perhaps, it had something to do with my Email Provider but that is not the issue, as I can access it fine from other computers and cell phones...but that isn't the issue because the sluggishness is occurring right from the start when I just try to "Highlight" for instance one of the emails already in my "In-Box" on my Mac...

Oh I forgot to mention, I am in Tokyo and I also use both "English" and "Japanese" Language sets. just like "NISHI-san"...

Ans as "NISHI" mentioned, there is obviously a Blog Site which has many users experiencing the same issue...and none of them had this problem before upgrading to Big Sur and the latest version of Thunderbird...

I will go to that "Error Listing" that you mentioned and see if there is anything there...

Appreciate the support and help...

All the best,
Art

Wayne,
I just went to that Japanese Twitter URL: https://twitter.com/search?q=thunderbird%20big%20sur&src=typeahead_click and YES, many users are reporting the same identical problem...

Art

Most likely a core issue, not Thunderbird - perhaps one listed in https://mzl.la/3kIMMoE

https://support.mozilla.org/en-US/questions/1314299

I chaned Language setting both Firefox and Big Sur.
After restarting Big Sur, It seems that getting each mail from server seems that it not long time, but still it seems slowly than before I updateing macOS. It seems that retancy it still bad.

When I changed Language setting on the Firebird, I noticed that response from UI in the setting scehe is also very slow.

Some Japanese who twttes on Twitter are saying that installing Beta version will be Ok to fix this kind of problem (I'm not tryed yet).

The following are Debug Message after I restarted the system in English.

Best regards,

17:15:43.515
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658"  data: no] L10nRegistry.jsm:658:19
    loadSync resource://gre/modules/L10nRegistry.jsm:658
    fetchFile resource://gre/modules/L10nRegistry.jsm:573
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:478
    map self-hosted:240
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:473
    generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:415
    InterpretGeneratorResume self-hosted:1151
    next self-hosted:1099
    generateBundlesSync resource://gre/modules/L10nRegistry.jsm:177
    InterpretGeneratorResume self-hosted:1151
    next self-hosted:1099
    touchNext resource://gre/modules/Localization.jsm:167
    regenerateBundles resource://gre/modules/Localization.jsm:552
    activate resource://gre/modules/Localization.jsm:243
    <anonymous> chrome://messenger/content/mailWidgets.js:37
    <anonymous> chrome://messenger/content/customElements.js:34
    <anonymous> chrome://messenger/content/customElements.js:37
    observe resource://gre/modules/MailGlue.jsm:201
17:15:43.746 Successfully loaded OpenPGP library librnp.dylib from /Applications/Thunderbird.app/Contents/MacOS/librnp.dylib RNPLib.jsm:49:13
17:15:43.819
Error while loading 'jar:file:///Applications/Thunderbird.app/Contents/Resources/omni.ja!/chrome/messenger/search-extensions/twitter/manifest.json' (NS_ERROR_FILE_NOT_FOUND) Extension.jsm:570
    readJSON resource://gre/modules/Extension.jsm:570
    onStopRequest resource://gre/modules/NetUtil.jsm:128
17:15:43.819 1605773743819	addons.xpi	WARN	Exception running bootstrap method startup on twitter@search.mozilla.org: Error: Error while loading 'jar:file:///Applications/Thunderbird.app/Contents/Resources/omni.ja!/chrome/messenger/search-extensions/twitter/manifest.json' (NS_ERROR_FILE_NOT_FOUND)(resource://gre/modules/Extension.jsm:570:20) JS Stack trace: readJSON/</<@Extension.jsm:570:20
onStopRequest@NetUtil.jsm:128:18
17:15:43.841 RNPLib.createInputFromPath failed for /Users/Jun/Library/Thunderbird/Profiles/zi1esmgj.default/pubring.gpg - Unix error 2 during operation open on file /Users/Jun/Library/Thunderbird/Profiles/zi1esmgj.default/pubring.gpg (No such file or directory) RNPLib.jsm:141:17
17:15:43.894 RNPLib.createInputFromPath failed for /Users/Jun/Library/Thunderbird/Profiles/zi1esmgj.default/secring.gpg - Unix error 2 during operation open on file /Users/Jun/Library/Thunderbird/Profiles/zi1esmgj.default/secring.gpg (No such file or directory) RNPLib.jsm:141:17
17:15:43.894 public keys: 0, secret keys: 0 RNPLib.jsm:264:15
17:15:43.898
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658"  data: no] L10nRegistry.jsm:658:19
    loadSync resource://gre/modules/L10nRegistry.jsm:658
    fetchFile resource://gre/modules/L10nRegistry.jsm:573
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:478
    map self-hosted:240
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:473
    generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:415
    next self-hosted:1099
    generateBundlesSync resource://gre/modules/L10nRegistry.jsm:177
    next self-hosted:1099
    touchNext resource://gre/modules/Localization.jsm:167
    regenerateBundles resource://gre/modules/Localization.jsm:552
    activate resource://gre/modules/Localization.jsm:243
    <anonymous> chrome://openpgp/content/modules/trust.jsm:11
    <anonymous> chrome://openpgp/content/modules/keyRing.jsm:17
    <anonymous> chrome://openpgp/content/modules/windows.jsm:19
    loader chrome://openpgp/content/modules/lazy.jsm:20
    getService chrome://openpgp/content/modules/core.jsm:426
    getService chrome://openpgp/content/modules/core.jsm:183
    init chrome://openpgp/content/BondOpenPGP.jsm:100
    InterpretGeneratorResume self-hosted:1151
    AsyncFunctionNext self-hosted:693
17:15:44.185 OpenGL compositor Initialized Succesfully.
Version: 2.1 NVIDIA-16.0.13 
Vendor: NVIDIA Corporation
Renderer: NVIDIA GeForce GT 750M OpenGL Engine
FBO Texture Target: TEXTURE_2D
17:15:44.332
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658"  data: no] L10nRegistry.jsm:658:19
    loadSync resource://gre/modules/L10nRegistry.jsm:658
    fetchFile resource://gre/modules/L10nRegistry.jsm:573
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:478
    map self-hosted:240
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:473
    generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:415
    next self-hosted:1099
    generateBundlesSync resource://gre/modules/L10nRegistry.jsm:177
    next self-hosted:1099
    touchNext resource://gre/modules/Localization.jsm:167
    regenerateBundles resource://gre/modules/Localization.jsm:552
    activate resource://gre/modules/Localization.jsm:243
    <anonymous> resource:///modules/calendar/calCalendarDeactivator.jsm:10
    <anonymous> chrome://calendar/content/calendar-chrome-startup.js:27
17:15:45.920 OpenGL compositor Initialized Succesfully.
Version: 2.1 NVIDIA-16.0.13 
Vendor: NVIDIA Corporation
Renderer: NVIDIA GeForce GT 750M OpenGL Engine
FBO Texture Target: TEXTURE_2D
17:15:45.980
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658"  data: no] L10nRegistry.jsm:658:19
    loadSync resource://gre/modules/L10nRegistry.jsm:658
    fetchFile resource://gre/modules/L10nRegistry.jsm:573
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:478
    map self-hosted:240
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:473
    generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:415
    next self-hosted:1099
    generateBundlesSync resource://gre/modules/L10nRegistry.jsm:177
    next self-hosted:1099
    touchNext resource://gre/modules/Localization.jsm:167
    regenerateBundles resource://gre/modules/Localization.jsm:552
    activate resource://gre/modules/Localization.jsm:243
    <anonymous> resource:///modules/OTR.jsm:15
    <anonymous> resource:///modules/OTRUI.jsm:8
    connectedCallback chrome://messenger/content/chat/chat-conversation-info.js:117
    <anonymous> chrome://global/content/customElements.js:217
17:15:45.981
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658"  data: no] L10nRegistry.jsm:658:19
    loadSync resource://gre/modules/L10nRegistry.jsm:658
    fetchFile resource://gre/modules/L10nRegistry.jsm:573
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:478
    map self-hosted:240
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:473
    generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:415
    next self-hosted:1099
    generateBundlesSync resource://gre/modules/L10nRegistry.jsm:177
    next self-hosted:1099
    touchNext resource://gre/modules/Localization.jsm:167
    regenerateBundles resource://gre/modules/Localization.jsm:552
    activate resource://gre/modules/Localization.jsm:243
    <anonymous> resource:///modules/OTRUI.jsm:10
    connectedCallback chrome://messenger/content/chat/chat-conversation-info.js:117
    <anonymous> chrome://global/content/customElements.js:217
17:15:47.180 Successfully loaded OTR library libotr.5.dylib from /Applications/Thunderbird.app/Contents/MacOS/libotr.5.dylib OTRLib.jsm:43:13
17:15:53.055 OpenGL compositor Initialized Succesfully.
Version: 2.1 NVIDIA-16.0.13 
Vendor: NVIDIA Corporation
Renderer: NVIDIA GeForce GT 750M OpenGL Engine
FBO Texture Target: TEXTURE_2D
17:15:53.535
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658"  data: no] L10nRegistry.jsm:658:19
    loadSync resource://gre/modules/L10nRegistry.jsm:658
    fetchFile resource://gre/modules/L10nRegistry.jsm:573
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:478
    map self-hosted:240
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:473
    generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:415
    next self-hosted:1099
    generateBundlesSync resource://gre/modules/L10nRegistry.jsm:177
    next self-hosted:1099
    touchNext resource://gre/modules/Localization.jsm:167
    regenerateBundles resource://gre/modules/Localization.jsm:552
    activate resource://gre/modules/Localization.jsm:243
    getLanguageDisplayNames resource://gre/modules/mozIntl.jsm:810
    getLocaleDisplayNames resource://gre/modules/mozIntl.jsm:888
    map self-hosted:240
    getLocaleDisplayNames resource://gre/modules/mozIntl.jsm:867
    formatLocaleSetLabels chrome://messenger/content/preferences/general.js:942
    init chrome://messenger/content/preferences/general.js:243
    init chrome://messenger/content/preferences/preferences.js:76
    AsyncFunctionNext self-hosted:693
    openWindowPrompt resource:///actors/PromptParent.jsm:160
    receiveMessage resource:///actors/PromptParent.jsm:108
    openPrompt resource://gre/modules/Prompter.jsm:1182
    openPromptSync resource://gre/modules/Prompter.jsm:1070
    nsIPrompt_promptPassword resource://gre/modules/Prompter.jsm:1559
    promptPassword resource://gre/modules/Prompter.jsm:535
    promptPassword resource://gre/modules/LoginManagerAuthPrompter.jsm:578
    _promiseAuthPrompt resource:///modules/MsgAsyncPrompter.jsm:25
    _promiseAuthPrompt resource:///modules/MsgAsyncPrompter.jsm:23
    run resource:///modules/MsgAsyncPrompter.jsm:48
    AsyncFunctionNext self-hosted:693
17:15:53.536
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 658"  data: no] L10nRegistry.jsm:658:19
    loadSync resource://gre/modules/L10nRegistry.jsm:658
    fetchFile resource://gre/modules/L10nRegistry.jsm:573
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:478
    map self-hosted:240
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:473
    generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:415
    next self-hosted:1099
    generateBundlesSync resource://gre/modules/L10nRegistry.jsm:177
    next self-hosted:1099
    touchNext resource://gre/modules/Localization.jsm:167
    regenerateBundles resource://gre/modules/Localization.jsm:552
    activate resource://gre/modules/Localization.jsm:243
    getRegionDisplayNames resource://gre/modules/mozIntl.jsm:837
    getLocaleDisplayNames resource://gre/modules/mozIntl.jsm:897
    map self-hosted:240
    getLocaleDisplayNames resource://gre/modules/mozIntl.jsm:867
    formatLocaleSetLabels chrome://messenger/content/preferences/general.js:942
    init chrome://messenger/content/preferences/general.js:243
    init chrome://messenger/content/preferences/preferences.js:76
    AsyncFunctionNext self-hosted:693
    openWindowPrompt resource:///actors/PromptParent.jsm:160
    receiveMessage resource:///actors/PromptParent.jsm:108
    openPrompt resource://gre/modules/Prompter.jsm:1182
    openPromptSync resource://gre/modules/Prompter.jsm:1070
    nsIPrompt_promptPassword resource://gre/modules/Prompter.jsm:1559
    promptPassword resource://gre/modules/Prompter.jsm:535
    promptPassword resource://gre/modules/LoginManagerAuthPrompter.jsm:578
    _promiseAuthPrompt resource:///modules/MsgAsyncPrompter.jsm:25
    _promiseAuthPrompt resource:///modules/MsgAsyncPrompter.jsm:23
    run resource:///modules/MsgAsyncPrompter.jsm:48
    AsyncFunctionNext self-hosted:693
17:15:55.373
NotSupportedError: CustomElementRegistry.define: 'conversation-browser' has already been defined as a custom element conversation-browser.js:853
    <anonymous> chrome://chat/content/conversation-browser.js:853
    <anonymous> chrome://messenger/content/customElements.js:34
    <anonymous> chrome://messenger/content/customElements.js:37
    observe resource://gre/modules/MailGlue.jsm:201
    initHTMLDocument resource:///modules/imThemes.jsm:741
    onStateChange chrome://chat/content/conversation-browser.js:62
    openWindowPrompt resource:///actors/PromptParent.jsm:160
    receiveMessage resource:///actors/PromptParent.jsm:108
    openPrompt resource://gre/modules/Prompter.jsm:1182
    openPromptSync resource://gre/modules/Prompter.jsm:1070
    nsIPrompt_promptPassword resource://gre/modules/Prompter.jsm:1559
    promptPassword resource://gre/modules/Prompter.jsm:535
    promptPassword resource://gre/modules/LoginManagerAuthPrompter.jsm:578
    _promiseAuthPrompt resource:///modules/MsgAsyncPrompter.jsm:25
    _promiseAuthPrompt resource:///modules/MsgAsyncPrompter.jsm:23
    run resource:///modules/MsgAsyncPrompter.jsm:48
    AsyncFunctionNext self-hosted:693
17:16:42.426 OpenGL compositor Initialized Succesfully.
Version: 2.1 NVIDIA-16.0.13 
Vendor: NVIDIA Corporation
Renderer: NVIDIA GeForce GT 750M OpenGL Engine
FBO Texture Target: TEXTURE_2D
17:16:43.298
GEThttps://www.mozilla.org/media/css/BUNDLES/common.1037ac8485c6.css
[HTTP/2 200 OK 0ms]

	
GET
	https://www.mozilla.org/media/css/BUNDLES/common.1037ac8485c6.css
Status200
OK
VersionHTTP/2
Transferred9.89 KB (70.74 KB size)

	
age
	806423
cache-control
	max-age=315360000, public, immutable
cf-cache-status
	HIT
cf-ray
	5f0c45f56b92940d-NRT
cf-request-id
	065b8a0d640000940dec905000000001
content-encoding
	br
content-type
	text/css
date
	Thu, 12 Nov 2020 00:52:57 GMT
etag
	W/"1037ac8485c68b00a8265fd74d59c222"
expect-ct
	max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
last-modified
	Mon, 02 Nov 2020 13:49:32 GMT
server
	cloudflare
vary
	Accept-Encoding
x-amz-id-2
	LfWHHpoUxHL/9QrcZl2Bz4WptgcvgF/FVqT4MnXk8uewdcsSELtsbXKvZWmFKF0sFo/9/w+ZJ6Y=
x-amz-request-id
	7254727D94CF69A7
x-amz-version-id
	9XpyflxrG7JQF_p7IJdAduk_tC6c6ctw
X-Firefox-Spdy
	h2
	
Accept
	text/css,*/*;q=0.1
Accept-Encoding
	gzip, deflate, br
Accept-Language
	en-US,en;q=0.5
Connection
	keep-alive
Cookie
	optimizelySegments=%7B%22245984388%22%3A%22false%22%2C%22246002457%22%3A%22direct%22%2C%22246073289%22%3A%22none%22%2C%22246073290%22%3A%22unknown%22%7D; optimizelyEndUserId=oeu1444893068391r0.5366516974363936; optimizelyBuckets=%7B%7D; _ga=GA1.2.412578053.1444893069
Host
	www.mozilla.org
User-Agent
	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.16; rv:78.0) Gecko/20100101 Thunderbird/78.4.3
17:16:43.308 Unknown pseudo-class or pseudo-element ‘-ms-expand’.  Ruleset ignored due to bad selector. common.1037ac8485c6.css:1:14098
17:16:43.308
Unknown property ‘zoom’.  Declaration dropped. common.1037ac8485c6.css:1:20241
17:16:43.309
Unknown property ‘zoom’.  Declaration dropped. common.1037ac8485c6.css:1:31425
17:16:43.309
Unknown property ‘zoom’.  Declaration dropped. common.1037ac8485c6.css:1:31985
17:16:43.309
Unknown property ‘zoom’.  Declaration dropped. common.1037ac8485c6.css:1:32277
17:16:43.309
Unknown property ‘zoom’.  Declaration dropped. common.1037ac8485c6.css:1:36381
17:16:43.309
Unknown property ‘zoom’.  Declaration dropped. common.1037ac8485c6.css:1:39533
17:16:43.309
Unknown property ‘zoom’.  Declaration dropped. common.1037ac8485c6.css:1:45681
17:16:43.309
Unknown property ‘zoom’.  Declaration dropped. common.1037ac8485c6.css:1:45914
17:16:43.309
Unknown property ‘zoom’.  Declaration dropped. common.1037ac8485c6.css:1:49513
17:16:43.309
Unknown property ‘zoom’.  Declaration dropped. common.1037ac8485c6.css:1:51314
17:16:43.309
Unknown property ‘zoom’.  Declaration dropped. common.1037ac8485c6.css:1:51688
17:16:43.310
GEThttps://www.mozilla.org/media/css/BUNDLES/privacy_protocol.19216c872e80.css
[HTTP/2 200 OK 0ms]

17:16:43.321
Unknown property ‘zoom’.  Declaration dropped. privacy_protocol.19216c872e80.css:1:5493
17:16:43.321
Unknown property ‘zoom’.  Declaration dropped. privacy_protocol.19216c872e80.css:1:14364

山下様、
今、私は通常使っている英語れんごうでのエラーコンソールと日本語にした場合でのエラーコンソールを比べてみましたが、”ERROR”及び”EXCEPTION"は全く同じですね。

その為、おそらく、THUNDERBIRD v78.4.3 (64-bit) 内の問題だと思います。

それと、たった今、新しいバーション v78.5.0 があると THUNDERBIRD から報告がありましたので、ダウンロード・インストールして、もう一度、確認します。

その後、また、報告します。

よろしく、
バルフォア

山下様、
今、新しいバージョン、THUNDERBIRD v78.5.0 (64-bit) をダウンロード・インストールしましたが、THUNDERBIRD v78.4.3 (64-bit) と全く同じ、”ERROR”及び”EXCEPTION"が出てます。

やはり、THUNDERBIRD 内の問題だと思います。

以上です。

よろしく、
バルフォア

Just for info to non-Japanese speakers...

The last two posts that I did, were in response to "Jun Yamashita" post.

I did a check on the "Error Console" for Thunderbird v78.4.3 (64 Bit) in both English and Language Sets and as I was typing, I got a message that a new version was available (v78.5.0).

Anyway, I downloaded and installed it.

But the Errors and Exceptions are 100% Identical to the two that I had with v78.4.3 for both English and Japanese Language Sets.

So, I am 100% sure that there is an internal programming problem with Thunderbird itself.

Maybe some Programming person at Mozilla is following this thread and checking on this problem.

I tried to installed v78.5.0 but it seemed that it not turned to good condition.
After that, I don't know why, it hangs up every time I launched it.

Now I installed beta version (84.0b1) and it seems that all the problem are clear.
No slow user interfaces, immediately download of the body of the message and no hang-ups.

The following is debug message of beta versions of Thunderbird.

Balfour-san,

私も v78.5.0 をインストールしてみましたが、改善されませんでした。
その後、ハングアップがひどくなったのでベータバージョンをインストールしたのですが、そちらは何の問題もなく使えています。

21:48:17.955
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 684"  data: no] 2 L10nRegistry.jsm:684:19
    loadSync resource://gre/modules/L10nRegistry.jsm:684
    fetchFile resource://gre/modules/L10nRegistry.jsm:599
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:504
    map self-hosted:221
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:499
    generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:441
    InterpretGeneratorResume self-hosted:1468
    next self-hosted:1416
    generateBundlesSync resource://gre/modules/L10nRegistry.jsm:178
    InterpretGeneratorResume self-hosted:1468
    next self-hosted:1416
    touchNext resource://gre/modules/Localization.jsm:167
    generateBundles resource://gre/modules/Localization.jsm:473
    <匿名> chrome://messenger-smime/content/msgReadSMIMEOverlay.js:31
21:48:19.586
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 684"  data: no] 2 L10nRegistry.jsm:684:19
    loadSync resource://gre/modules/L10nRegistry.jsm:684
    fetchFile resource://gre/modules/L10nRegistry.jsm:599
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:504
    map self-hosted:221
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:499
    generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:441
    next self-hosted:1416
    generateBundlesSync resource://gre/modules/L10nRegistry.jsm:178
    next self-hosted:1416
    touchNext resource://gre/modules/Localization.jsm:167
    generateBundles resource://gre/modules/Localization.jsm:473
    <匿名> resource:///modules/OTR.jsm:15
    <匿名> resource:///modules/OTRUI.jsm:8
    connectedCallback chrome://messenger/content/chat/chat-conversation-info.js:117
    <匿名> chrome://global/content/customElements.js:217
21:48:19.587
[Exception... "Component returned failure code: 0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH) [nsIXPCComponents_Utils.readUTF8URI]"  nsresult: "0x80520001 (NS_ERROR_FILE_UNRECOGNIZED_PATH)"  location: "JS frame :: resource://gre/modules/L10nRegistry.jsm :: L10nRegistry.loadSync :: line 684"  data: no] 2 L10nRegistry.jsm:684:19
    loadSync resource://gre/modules/L10nRegistry.jsm:684
    fetchFile resource://gre/modules/L10nRegistry.jsm:599
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:504
    map self-hosted:221
    generateResourceSetSync resource://gre/modules/L10nRegistry.jsm:499
    generateResourceSetsForLocaleSync resource://gre/modules/L10nRegistry.jsm:441
    next self-hosted:1416
    generateBundlesSync resource://gre/modules/L10nRegistry.jsm:178
    next self-hosted:1416
    touchNext resource://gre/modules/Localization.jsm:167
    generateBundles resource://gre/modules/Localization.jsm:473
    <匿名> resource:///modules/OTRUI.jsm:10
    connectedCallback chrome://messenger/content/chat/chat-conversation-info.js:117
    <匿名> chrome://global/content/customElements.js:217
21:48:20.283 Successfully loaded OpenPGP library librnp.dylib from /Applications/Thunderbird.app/Contents/MacOS/librnp.dylib RNPLib.jsm:50:13
21:48:20.624 Successfully loaded OTR library libotr.5.dylib from /Applications/Thunderbird.app/Contents/MacOS/libotr.5.dylib OTRLib.jsm:43:13
21:48:20.870 public keys: 0, secret keys: 0 RNPLib.jsm:248:15
21:48:21.173
Unknown Collection "thunderbird/hijack-blocklists" RemoteSettingsClient.jsm:160
    UnknownCollectionError resource://services-settings/RemoteSettingsClient.jsm:160
    sync resource://services-settings/RemoteSettingsClient.jsm:470
    InterpretGeneratorResume self-hosted:1468
    AsyncFunctionNext self-hosted:674
21:48:21.195
Unknown Collection "thunderbird/url-classifier-skip-urls" RemoteSettingsClient.jsm:160
    UnknownCollectionError resource://services-settings/RemoteSettingsClient.jsm:160
    sync resource://services-settings/RemoteSettingsClient.jsm:470
    InterpretGeneratorResume self-hosted:1468
    AsyncFunctionNext self-hosted:674
    openWindowPrompt resource:///actors/PromptParent.jsm:160
    receiveMessage resource:///actors/PromptParent.jsm:108
    openPrompt resource://gre/modules/Prompter.jsm:1183
    openPromptSync resource://gre/modules/Prompter.jsm:1071
    nsIPrompt_promptPassword resource://gre/modules/Prompter.jsm:1562
    promptPassword resource://gre/modules/Prompter.jsm:536
    promptPassword resource://gre/modules/LoginManagerAuthPrompter.jsm:582
    _promiseAuthPrompt resource:///modules/MsgAsyncPrompter.jsm:25
    _promiseAuthPrompt resource:///modules/MsgAsyncPrompter.jsm:23
    run resource:///modules/MsgAsyncPrompter.jsm:48
    InterpretGeneratorResume self-hosted:1468
    AsyncFunctionNext self-hosted:674

We now have at least three people reporting beta (presumably 84) has helped.

For anyone who has not yet installed beta and is willing to try beta, I would ask that you first try beta 83 (not 84) http://archive.mozilla.org/pub/thunderbird/releases/83.0b2/ to see if this earlier version helps.

As recommended by Jun Yamashita and Wayne Mery, I just downloaded and installed Thunderbird Beta v84.0b1

Before I get into the results, let me clear up one thing.

The Beta Version makes a NEW Profile on the Local Drive and so any and all of your Contacts, Names, etc, etc...that you had with the last Non-Beta Version of Thunderbird, will not show up when you run the program.

Now, the old profile is still there in the same folder as the new Beta Profile.

What I did was, I deleted the Beta Profile, reinstalled Thunderbird Beta v84.0b1 and BANG, all of my Contacts, Names, etc, etc., are back.

So, on the results...

It works OUTSTANDING!!!...

Smooth, fast run-up...No more delays...immediate high-lighting of items within each section, when you point your mouse and click...scrolls are normal again...

Someone misprogrammed something in the Non-Beta version and it needs to be compared with the Beta Version, to see where the problem(s) is/are...

Thank you Jun and Wayne...


山下様、
上に書いた通り、完全に”Non-Beta"バージョンに何かの問題があるようですね。

まあ、とりあえず、この”Beta"バージョンをしばらく使います。

いずれ、Mozillaがほんちゃんをなおすでしょう。

何か、新しい出来事がありましたら、ご連絡お願い致します。よろしく。

私も何かあったら、そうします。

ありがとうございます。

バルフォア

Allow me to reemphasize and expand on my prior comment.

This is likely a core bug that firefox fixed in a core component, in version newer than 78 - and therefore NOT a bug in Thunderbird itself per se. If that assumption is true, then we are seeing this in Thunderbird 78 because they have not yet uplifted the fix to ESR versions.

Therefore, we need to know at what version of Thunderbird beta this issue is fixed - so please start by test 83 beta, NOT version 84. And we may need to go to even earlier versions.

Wayne,
I'd be more than happy to help narrow this down...but I am not able to find the location where any Beta Version other than v84.0b1 can be downloaded.

Do you have a URL where I can go?

Art

I posted a starter link for 83 beta in comment 27. You can use that to navigate the directory to other versions. To be more specific:

If you start at the oldest beta you will need to start thunderbird with --allow-downgrade switch once in Mac terminal. But if you go backward from newer to older versions, you will need to use that switch on every older version.

(In reply to Wayne Mery (:wsmwk) from comment #31)

Wayne,
Sorry it took so long...

It took me a while to figure out how to enter the -allow-downgrade into the command line.

But this worked;
1st Entry: cd /Applications/Thunderbird.app/Contents/MacOS

2nd Entry: ./thunderbird -ProfileManager -allow-downgrade


But anyway, here's the results;

Tests for "Sluggishness" using various versions of Thunderbird Beta

v80.0b2 (64-bit) - NO GOOD - Sluggish just like Release v78.4.3

v81.0b2 (64-bit) - GOOD - No Sluggishness at all

v82.0b2 (64-bit) - GOOD - No Sluggishness at all

v83.0b2 (64-bit) - GOOD - No Sluggishness at all

v84.0b1 (64-bit) - GOOD - No Sluggishness at all


Art

(In reply to Art Balfour from comment #32)

Tests for "Sluggishness" using various versions of Thunderbird Beta
v80.0b2 (64-bit) - NO GOOD - Sluggish just like Release v78.4.3
v81.0b2 (64-bit) - GOOD - No Sluggishness at all

Art, nice progress!

Next tests:

(In reply to Wayne Mery (:wsmwk) from comment #33)

Next tests:

OK, Wayne, here's the latest results;

Tests for "Sluggishness" using various versions of Thunderbird Beta

  • v80.0b4 (64-bit) - NO GOOD - Sluggish just like Release v78.4.3

  • v80.0b5 (64-bit) - NO GOOD - Sluggish just like Release v78.4.3

  • v81.0b1 (64-bit) - GOOD - No Sluggishness at al

Art

Long shot perhaps, but perhaps in the area of compiler used?

Have you tried corresponding Firefox releases? Do they show similar behaviour?

Flags: needinfo?(mkmelin+mozilla)

Magnus,
I am using Firefox v83.0 (64-bit) and I have no "sluggishness" issues there.

I mean, not that I can tell. Perhaps, there is a "slow down" but honestly it's not apparent as it is with the really bad "sluggishness" experienced with Thunderbird when using Release v78.4.3.

If there is something that I can help with, in getting more info, I would be more than happy to help. Just need some simple guidance on what to do, as Wayne has kindly done for me.

I'm a "Motorhead" and so, I need to be led to the water...lol...

Art

For Firefox 83 that would be expected if Thunderbird 83 beta was ok for you. For trying older Firefoxes (e.g. 78) you would use the same procedure as for Thunderbird. Builds are at http://archive.mozilla.org/pub/firefox/releases/

Magnus,
Ok, I guess I can use a "Speed Checker" on some site as a basis. First with this Firefox v83.0 that I currently have installed and downgrade it from there, to see if there is any difference.

I'll do the testing tomorrow. It's 17:57 here in Tokyo...so, in the morning I will get on to it and report back with my findings.

Thanks for the input.

Art

If https://hg.mozilla.org/releases/mozilla-beta/pushloghtml?fromchange=FIREFOX_80_0b8_RELEASE&tochange=FIREFOX_81_0b1_BUILD1 is correct then
http://archive.mozilla.org/pub/firefox/releases/80.0b8/mac/en-US/ will fail
http://archive.mozilla.org/pub/firefox/releases/81.0b1/mac/en-US/ will work

But, only if the code that causes the failure also causes the symptoms in Firefox - which it very well might not. (I'm not optimistic)
In which case, we might need to bisect Thunderbird nightly builds.

Flags: needinfo?(abalfour)

p.s. Anyone can test the items above - just first backup your Thunderbird profile

(In reply to Wayne Mery (:wsmwk) from comment #43)

p.s. Anyone can test the items above - just first backup your Thunderbird profile

Wayne,
I just tested it and here's the result;

Done - v81.0a1 (64-bit) Time-Stamped 19AUG2020 - GOOD - No Sluggishness at all
Done - v81.0a1 (64-bit) Time-Stamped 21AUG2020 - GOOD - No Sluggishness at all
Done - v81.0a1 (64-bit) Time-Stamped 23AUG2020 - GOOD - No Sluggishness at all
Done - v81.0a1 (64-bit) Time-Stamped 24AUG2020 - GOOD - No Sluggishness at all

Art

Flags: needinfo?(abalfour)

Wayne and Magnus,

I decided not to test Firefox, since I am not having any issues with it on my iMac with macOS Big Sur.

But, I have done another test, but this time on my Wife's iMac 27" (Early 2019), the same model as mine.

The only difference is that, on hers, it still has macOS Catalina v 10.15.7 since we didn't want to upgrade until we resolved this issue with Thunderbird.

Not that, that matters, as she does not use either Thunderbird or Firefox.

Anyway, I installed the following two versions of Thunderbird, which were NO GOOD on my iMac and here's the results;

Done - v78.4.3 (64-bit) - GOOD - No Sluggishness at all

Done - v78.5.0 (64-bit) - GOOD - No Sluggishness at all

Hope this info plays into the fix.

All the best,

Art

Sorry, I should have been more clear - similar to comment 33, it was not necessarily to test all of those nightly choice. What we want to do is bisect or do a binary search to find the smallest interval where day-N fails and day-N+1 works. So when you discovered 19AUG2020 worked, you would not need to have tested the three newer versions because we can assume they would have worked.

Next step - a reminder to backup your profile. We can now use nightly builds and https://mozilla.github.io/mozregression/install.html to help automate the process. The app is not signed for the Mac so you will need to control+click to open it. For repository use comm-central. Pick your profile. Then pick dates - the earliest 81.0a1 is 2020-07-28 ( http://archive.mozilla.org/pub/thunderbird/nightly/2020/07/2020-07-28-10-41-21-comm-central/ ) which will hopefully fail and also supply the 2020-08-19 date for the build that we know works. After a few tests, you should have a one day regression range.

Wayne,
I couldn't get the mozregression GUI.app to work, so I did it Old School and downloaded all of the Daily .dmg files and checked to see where the last failure is and the first good one is.

I have of course, left out the ones in-between, where they were also BAD and only listed the few, to show exactly where the NO GOOD to GOOD, occurred.

Here's my findings;

Done - v81.0a1 (64-bit) Time-Stamped 28JUL2020 - NO GOOD - Sluggish

Done - v81.0a1 (64-bit) Time-Stamped 17AUG2020 - NO GOOD - Sluggish

Done - v81.0a1 (64-bit) Time-Stamped 19AUG2020 - GOOD - No Sluggishness at all

BTW, there is no Daily for 18AUG2020.

Art

In that range there is at least bug 1657440 which was fixing big sur only(?) issue.

Can we make a build of 18AUG2020 to further narrow the range?

Flags: needinfo?(rob)

(In reply to Magnus Melin [:mkmelin] from comment #48)

In that range there is at least bug 1657440 which was fixing big sur only(?) issue.

Or, do you want to make a try build wiht that patch?

Flags: needinfo?(mkmelin+mozilla)

The tree was busted on 2020-08-18, that's why there's no Nightly for that day. I could come up with something sort of close though.

I'm going to try an uplift of bug 1657440 first though. If it compiles locally I'll fire up a try build.

Flags: needinfo?(rob)

Sounds like a plan.

Flags: needinfo?(mkmelin+mozilla)

Wayne, Magnus, Rob and others,

Just to provide an update, I installed the latest Beta (v84.0b2) and below are the results;

JFI: I am using macOS Big Sur (v11.0.1) on a 27" Early 2019 iMac, which was used for the testing below.

<<< Beta Versions Testing >>>

Here's my findings;

Done - v81.0a1 (64-bit) Time-Stamped 17AUG2020 - NO GOOD - Sluggish

Done - v81.0a1 (64-bit) Time-Stamped 19AUG2020 - GOOD - No Sluggishness at all

Done - v84.0b2 (64-bit) Time-Stamped 25NOV2020 - GOOD - No Sluggishness at all

<<< Release Versions Testing >>>

Here's my findings;

Done - v60.9.1 (64-bit) Time-Stamped 05NOV2019 - GOOD, but missing many Lines/Characters - No Sluggishness at all

Done - v68.0 (64-bit) Time-Stamped 27AUG2019 - NO GOOD - Sluggish

Done - v78.5.0 (64-bit) Time-Stamped 18NOV2020 - NO GOOD - Sluggish


But on another identical 27" Early 2019 iMac running macOS Catalina v10.15.7, here's the result;

Done - v78.5.0 (64-bit) Time-Stamped 18NOV2020 - GOOD - No Sluggishness at all


Art

Oops, I never hit "Save changes" the other day...

Here is the try build:
https://treeherder.mozilla.org/jobs?repo=try-comm-central&revision=6598dd7bd8cd1360d101cd53fd0576e9829a157d

If that doesn't fix it, I can mangle together something for 2020-08-18 "nightly"

(In reply to Rob Lemley [:rjl] from comment #51)

The tree was busted on 2020-08-18, that's why there's no Nightly for that day. I could come up with something sort of close though.

I'm going to try an uplift of bug 1657440 first though. If it compiles locally I'll fire up a try build.

Art, please try https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/D3268XFVT-mXVLdSKb8J-w/runs/0/artifacts/public/build/target.dmg

Flags: needinfo?(abalfour)

(In reply to Wayne Mery (:wsmwk) from comment #55)

(In reply to Rob Lemley [:rjl] from comment #51)

The tree was busted on 2020-08-18, that's why there's no Nightly for that day. I could come up with something sort of close though.

I'm going to try an uplift of bug 1657440 first though. If it compiles locally I'll fire up a try build.

Art, please try https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/D3268XFVT-mXVLdSKb8J-w/runs/0/artifacts/public/build/target.dmg

Wayne,
I downloaded and tested the target.dmg above but it is No Good...

Done - v78.5.1 (64-bit) Time-Stamped 26NOV2020 - NO GOOD - Sluggish

Art

Flags: needinfo?(abalfour)

Magnus, do you have another high probability regression bug for another try build? If not, then we need "mangle together something for 2020-08-18 "nightly""

Flags: needinfo?(mkmelin+mozilla)

(In reply to NISHI from comment #2)

I have a question.
Is it only in Japan?

On Twitter of Japan, many users claim the issue.
https://twitter.com/search?q=thunderbird%20big%20sur&src=typeahead_click

Version: 78.5.0 64bit
Language: Chinese

has this problem(very slow on macOS Big Sur) too.

Going through the regression range, I'm seeing many Mac issues although the commits don't indicate Mac, especially font related. https://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2020-08-17+06%3A00%3A00&enddate=2020-08-19+08%3A00%3A00

An example is Bug 1659453 - Accelerate font fallback searches using family character map

the same here.
Version: 78.5.0 (64-bit)
Language: Korean.

(In reply to pkyoung from comment #60)

the same here.
Version: 78.5.0 (64-bit)
Language: Korean.

and as described above, Version: 84.0b2 (64-bit) has solved the issue.
Thanks.

(In reply to Rob Lemley [:rjl] from comment #54)

Oops, I never hit "Save changes" the other day...

Here is the try build:
https://treeherder.mozilla.org/jobs?repo=try-comm-central&revision=6598dd7bd8cd1360d101cd53fd0576e9829a157d

If that doesn't fix it, I can mangle together something for 2020-08-18 "nightly"

Looks like we will need it.

Flags: needinfo?(rob)

There are also some interesting core bugs

  • Bug 1678116 - Slow layout in gfxMacFontFamily::FindStyleVariations .SF NS after upgrade to Big Sur. (perhaps fixed in TB 84.0b2
  • Bug 1669855 - Excessive jank due to reading font info after startup
  • Bug 1675431 - When building with newer macOS SDKs, there is worse graphical performance than there is with the 10.11 SDK (both with WebRender enabled)

(I don't really have anything to add.)

Flags: needinfo?(mkmelin+mozilla)

Here's a build resembling a 2020-08-18 Nightly.

https://treeherder.mozilla.org/jobs?repo=try-comm-central&revision=f4e73dcec5849d7558ad497cb72f3d3f0816d884

Specifically, it's built against m-c revision 483ef87aa6e85cb340d1c17b5b87bb7c217fb3b8 which I got from the failed Nightly Decision task log file.

The comm-central revision is 088f530a8658a9cffb7546c9a0f014303a7aef10, which includes taskgraph and build fixes which would not have had an impact on the final Thunderbird executable.

Flags: needinfo?(rob)

Thanks Rob.

Art (and anyone else), the Mac opt build to be tested is https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/CAfGqEnETWChrp-VUuhchw/runs/0/artifacts/public/build/target.dmg. Let us know whether it fails, or succeeds

Flags: needinfo?(abalfour)

Wayne and Rob,

https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/CAfGqEnETWChrp-VUuhchw/runs/0/artifacts/public/build/target.dmg

The "About Thunderbird" says < Thunderbird Daily 81.0.a1 (2020-12-01) (64-bit) >

Anyway, it is GOOD...no sluggishness...

Art

Flags: needinfo?(abalfour)

Thanks Art.

https://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2020-08-17+06%3A00%3A00&enddate=2020-08-19+08%3A00%3A00 is still quite a big list.

Rob, can you do a build using 2a823bfe88959bebfc61a4f5015fa25e5024a8e7 ? I'm betting Art will find that it works - my money is on those font fixes.

Flags: needinfo?(rob)

Rob,

Ok, I downloaded the .dmg as you stated;

https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/RvRGTt2zQG2FNcyEUMqM5g/runs/0/artifacts/public/build/target.dmg

First of all, the "About Daily" says; Thunderbird Daily 81.0a1 (2020-08-17)...

Shouldn't it be ...2020-08-18...???...

Anyway, it's NO GOOD...it's SLUGGISH...

The one yesterday, was GOOD as I stated...

Art

Rob and wayne,
I also noticed that a new "Release" Version 78.5.1 was out so I downloaded it and it is still NO GOOD and SLUGGISH...just like 78.5.0 was...

Art

Bummer. Well, two possible tests remain

  • 508a0cc2f6d446e4b016ebb6d2c740c80f830dd9 Mon Aug 17 21:46:02 2020 +0000
  • aa98a6ece5fbbe2b09796d543fa91db5735a44a9 Tue Aug 18 04:15:48 2020 +0000

Unless someone has a different idea, Rob, can you do build against the first one?

Flags: needinfo?(rob)

(In reply to Art Balfour from comment #71)

Rob and wayne,
I also noticed that a new "Release" Version 78.5.1 was out so I downloaded it and it is still NO GOOD and SLUGGISH...just like 78.5.0 was...

Art

+1
Version: 78.5.1
Language: Chinese
macOS Big Sur: 11.0.1

https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/XVeu5RA_R127Wws5XhWPHA/runs/0/artifacts/public/build/target.dmg

comm-central rev 088f530a8658a9cffb7546c9a0f014303a7aef10
mozilla-central rev 508a0cc2f6d446e4b016ebb6d2c740c80f830dd9

Flags: needinfo?(rob)

Rob,

Ok, I downloaded the .dmg as you stated;

https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/XVeu5RA_R127Wws5XhWPHA/runs/0/artifacts/public/build/target.dmg

The "About Daily" says; Thunderbird Daily 81.0a1 (2020-08-18)...

Anyway, it's GOOD...NO SLUGGISHNESS...

Art

Thanks Art and Rob.

So bug 1659453 looks like a prime candidate. Rob, can you build with 2a823bfe88959bebfc61a4f5015fa25e5024a8e7 (which failed) and add the patch for bug 1659453?

And if Art finds that build to be good, then we get that patch for esr, or is there a workaround?

Flags: needinfo?(rob)

Rob,

Ok, I downloaded the .dmg as you stated;

https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/YpaNZcxlSfau0lrBsD18Hg/runs/0/artifacts/public/build/target.dmg

The "About Daily" says; Thunderbird Daily 81.0a1 (2020-08-17)...

Anyway, it's GOOD...NO SLUGGISHNESS...

Art

Great! I'll one one more build of 78 with that added and hopefully its a winner.

And here it is...
https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/cS4TP33hS7yHdUx2l1zlyQ/runs/0/artifacts/public/build/target.dmg

This should be labeled Thunderbird version 78.6.0 -- some places might refer to it as "Thunderbird Daily" because of it being a test build though.

Anyway, this is Thunderbird 78.5.1 plus a build fix, built on a Firefox 78.6.0 base with the addition of bug 1659453. This should be the last test build (assuming it works) and then we can take steps to get the fix included in an actual release.

Rob,

Ok, I downloaded the .dmg as you stated;

https://firefox-ci-tc.services.mozilla.com/api/queue/v1/task/cS4TP33hS7yHdUx2l1zlyQ/runs/0/artifacts/public/build/target.dmg

The "About Daily" says; Thunderbird Daily 78.6.0...

Anyway, it's GOOD...NO SLUGGISHNESS...

Art

Blocks: 1678952
Duplicate of this bug: 1678952

We missed getting the patch from bug 1659453 into 78.6.0 - their uplifts had ended on Monday.

Unfortunately the patch in the try build didn't help older macOS Catalina in bug 1677380

Depends on: 1659453

Wayne and Rob,

...Wanted to let you know that macOS Big Sur v11.1 released a few days ago, made no differences to my previous Test Findings...

...JFYI and Records...

Art

Did anyone get a chance to check Firefox 78esr yet?

anyone on version 78, I thought we had tested this but I don't see it mentioned in the bug report - please try disabling thunderbird hardware acceleration in preferences, and let us know the results.

Flags: needinfo?(abalfour)

Wayne,
I just reinstalled Release v78.6.0 and "Unchecked" Preferences-General-Indexing-"Use hardware acceleration when available" and is does no good, Thunderbird is still "Sluggish"...

So, I am back on Beta v85.0b1

Art

Flags: needinfo?(abalfour)

Wayne and Rob,

Happy New Year!!!...

I didn't update you for Beta Release v85.0b2...

But anyway, today v85.0b3 was out so here's the Test Results FYI...

Beta Release v85.0b2 - Good, No Sluggishness

Beta Release v85.0b3 - Good, No Sluggishness

Any idea when the next "Release" Version will be out, since the fix didn't make it in time for v78.6.0 ???...

All the best,
Art

Patch landed on 2020-12-21 https://bugzilla.mozilla.org/show_bug.cgi?id=1659453#c10 so the fix should be in 78.6.1 when we build it next week. If we don't get it then, it will be in 78.7.0 ~2021-01-26

Duplicate of this bug: 1686193

(In reply to Wayne Mery (:wsmwk) from comment #89)

Patch landed on 2020-12-21 https://bugzilla.mozilla.org/show_bug.cgi?id=1659453#c10 so the fix should be in 78.6.1 when we build it next week.

Please try 78.6.1 which you can get by doing Help > About and picking up the update.

Wayne,

Ok, I downloaded and tried v78.6.1 but it is NO GOOD - Sluggish...

Art

(In reply to Wayne Mery (:wsmwk) from comment #91)

(In reply to Wayne Mery (:wsmwk) from comment #89)

Patch landed on 2020-12-21 https://bugzilla.mozilla.org/show_bug.cgi?id=1659453#c10 so the fix should be in 78.6.1 when we build it next week.

Please try 78.6.1 which you can get by doing Help > About and picking up the update.

I have also confirmed that 78.6.1 has not fixed the issue. I am running on macOS 10.15.7

Thanks
Josh

I did the update 78.6.1 - with Mac OS 11.1 - issue was not solved - even to get the about take few second until I can highlight and additional time to load

+1, 78.6.1 has not help @ macOS BigSur 11.0.1

This issue was fixed in 78.7.0.

Wayne and Rob,

I downloaded Beta v86.0b1 (Dated 28 Jan 2021) and Release v78.7.0 (Dated 26 Jan 2021) and both are GOOD - NO Sluggishness...

JFYI, I am using macOS Big Sur v11.1

Appreciate all of your work and support as well as the many others that helped get this problem resolved...

All the best,

Art

Wayne and Rob,
"Houston we have a problem!!!"...

Although Release v78.7.0 fixed the "Sluggishness" problem, it has introduced a NEW problem...

All of the "Address Book" is "NULL"...even if you copy a previously good Profile into the Contents of the Primary Drive...

So, I loaded up Beta v86.0b1 (Dated 28 Jan 2021) with the previously good Profile into the Contents of the Primary Drive and the all of the Contacts in the "Address Book" are there and good...

So, for the time being, I will use Beta v86.0b1 (Dated 28 Jan 2021)...since Release v78.7.0 is NO GOOD...

I don't know if you want to start a new "Bug" or not on this...

Art

Hello all,

As Art said, the issue is not reproduced on v78.7.0 finally even on my side.

Though a new issue seem to be observed(Regression?), the ticket can be closed.
This is because the new issue is different from the Sluggishness one.
The new issue should be tracked on a new ticket.

To Art,

I really appreciate your great contribution regarding the issue.
Without your cooperate, the issue will not be fixed.
Thank you very much.

Best regards,
Nishi

Status: NEW → RESOLVED
Closed: 1 year ago
Resolution: --- → WORKSFORME

Nishi-san,
No problem...I'm glad that the Sluggishness problem was resolved...

Many thanks to you, Wayne and Rob and others...

On the new issue of the "Address Book" being "Nulled" out, I will open a new bug report unless someone else has already opened one...

Art

I just opened a new Bug 1689906 for the above Address Book Contacts problem with Thunderbird Release v78.7.0...

Art

You need to log in before you can comment on or make changes to this bug.