Closed Bug 1677818 Opened 4 years ago Closed 4 years ago

Allow running WebRender on ANGLE in the parent process outside of Nightly

Categories

(Core :: Graphics: WebRender, task, P3)

task

Tracking

()

RESOLVED FIXED
85 Branch
Tracking Status
firefox84 --- wontfix
firefox85 --- fixed

People

(Reporter: mattwoodrow, Assigned: mattwoodrow)

References

Details

Attachments

(1 file)

This is currently restricted to nightly, but we want to try it out on beta (and hopefully release soon).

Comment on attachment 9188385 [details]
Bug 1677818 - Allow running WebRender on ANGLE in the parent process outside of Nightly. r?jrmuizel

Beta/Release Uplift Approval Request

  • User impact if declined: We want to allow running WebRender without a GPU process (for win7 users without sp1 and the platform update), and this is required for that to take effect. The pref for controlling this is set to true only for early beta, so this won't affect late beta/release.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Medium
  • Why is the change risky/not risky? (and alternatives if risky): Enables WR for more users, but pref controlled and will automatically disable for late beta.
  • String changes made/needed:
Attachment #9188385 - Flags: approval-mozilla-beta?
Pushed by mwoodrow@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/848b5ceb2df1
Allow running WebRender on ANGLE in the parent process outside of Nightly. r=jrmuizel
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch

Comment on attachment 9188385 [details]
Bug 1677818 - Allow running WebRender on ANGLE in the parent process outside of Nightly. r?jrmuizel

Approved for 84.0b3.

Attachment #9188385 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

Backed out from beta for frequent crashes on Windows 7 with AMD processors (especially in shader code) - see bug 1678808:

https://hg.mozilla.org/releases/mozilla-beta/rev/362e0d86d8a493a8def2ac1c998cc19ff2240a49

Flags: needinfo?(matt.woodrow)

Comment on attachment 9188385 [details]
Bug 1677818 - Allow running WebRender on ANGLE in the parent process outside of Nightly. r?jrmuizel

Removing the approval given the crash spike caused by this.

Attachment #9188385 - Flags: approval-mozilla-beta+ → approval-mozilla-beta-
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

This change got backed out of gecko 84 (currently beta) but is still applied for gecko 85 (central) where it only affects 1 (?) machine. Shall it also get backed out from central?

Flags: needinfo?(jmathies)

I think it's ok to leave in central.

Severity: -- → S4
Flags: needinfo?(jmathies)
Priority: -- → P3
Flags: needinfo?(matt.woodrow)
Blocks: 1685430
Status: REOPENED → RESOLVED
Closed: 4 years ago4 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: