Closed Bug 1678808 Opened 10 months ago Closed 10 months ago

many crashes on Windows 7 with mostly AMD processors in code related to shaders

Categories

(Core :: Graphics: WebRender, defect, P2)

Firefox 84
Unspecified
Windows 7
defect

Tracking

()

RESOLVED FIXED
85 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- unaffected
firefox84 blocking fixed
firefox85 + fixed

People

(Reporter: aryx, Unassigned)

References

(Blocks 2 open bugs, Regression)

Details

(Keywords: crash, regression)

Crash Data

There are several frequent crashers on Windows 7 with AMD processors for 84.0b3 which often mention shaders. This points to the enabling of WebRender on ANGLE (bug 1677818) as regressor.

Crashes:

Needinfoing Julien for a backout in 78.0b4.

Flags: needinfo?(matt.woodrow)
Flags: needinfo?(jcristau)
Crash Signature: [@ RtlpReportHeapFailure | MD4Transform] [@ RtlFreeHeap | HeapFree | ILShader::~ILShader] [@ webrender_bindings::moz2d_renderer::{{impl}}::prepare_resources] [@ RtlpReportHeapFailure | RtlUlonglongByteSwap | HeapFree | ILShader::~ILShader] [@ RtlpRepo…
Crash Signature: [@ RtlpReportHeapFailure | MD4Transform] [@ RtlFreeHeap | HeapFree | ILShader::~ILShader] [@ webrender_bindings::moz2d_renderer::{{impl}}::prepare_resources] [@ RtlpReportHeapFailure | RtlUlonglongByteSwap | HeapFree | ILShader::~ILShader] [@ RtlpRepo… → [@ atidxx64.dll | gl::Context::onSubjectStateChange] [@ R600Workaround::UpdateFetch4State] [@ RtlAllocateMemoryBlockLookaside | NDXGI::CDevice::NTStatusToHResult] [@ RtlAllocateMemoryBlockLookaside | RtlAllocateMemoryBlockLookaside | NDXGI::CDevice::NT…
Has Regression Range: --- → yes
Keywords: crash, regression

Updates for the beta channel have been turned off for this.

The change from bug 1677818 got backed out from beta. This will ship with 84.0b4 on Monday.

Leaving the bug open for Matt to decide if the crashes shall be investigated here or in a different bug.

Flags: needinfo?(jcristau)
Severity: -- → S2
Priority: -- → P2
Blocks: gfx-triage

Optimistically calling this fixed by backout for 84.

Looks like this is mostly R600 devices, with 8.56.1.15/16.

We already blocklist 8.56.1.15 for non-WebRender acceleration, but recently allowed it for WR.

8.56.1.16 appears to be available for layers acceleration and not crashing afaict.

Flags: needinfo?(matt.woodrow)

What's the next step here for 85?

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch
No longer blocks: gfx-triage
You need to log in before you can comment on or make changes to this bug.