Closed Bug 1678849 Opened 10 months ago Closed 10 months ago

Disappearing window controls using non-default theme

Categories

(Core :: Graphics: WebRender, defect)

Firefox 84
Unspecified
Windows 7
defect

Tracking

()

RESOLVED DUPLICATE of bug 1677696
Tracking Status
firefox83 --- disabled
firefox84 --- fixed
firefox85 --- fixed

People

(Reporter: yoasif, Unassigned)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(3 files)

Attached image image.png

From: https://www.reddit.com/r/firefox/comments/jy1j4t/issue_with_window_controls_when_you_have_a_theme/

If you have a theme enabled that isn't the Light or Dark one. The window controls behave erratically. Some times they fully dissappear, some times partially appear. This started to happen on version 84.0b3

I noticed that it also happens when I enable the Firefox Apenglow Theme.

I noticed the issue has to do with the hardware acceleration on version 84.0b3. If I disable it, the window controls show correctly on any theme, but if it is enabled the window controls become unstable on any theme except dark and light ones.

Issue does not happen in 84.0b2 and appeared in 84.0b3.

Attached file about:support 84.0b2
Attached file about:support 84.0b3
Keywords: regression

Looks like it switched WR on because of bug 1677818.

This should be a dupe of bug 1677696 and fixed with 84.0b4.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1677696

Thanks darkspirit!

No longer blocks: gfx-triage
You need to log in before you can comment on or make changes to this bug.