Open Bug 1678040 Opened 5 months ago Updated 4 months ago

Github: Issues or Pull Requests not reachable with VoiceOver

Categories

(Core :: Disability Access APIs, defect, P2)

Firefox 85
Desktop
macOS
defect

Tracking

()

REOPENED
Tracking Status
firefox85 --- affected

People

(Reporter: MarcoZ, Unassigned)

Details

(Whiteboard: [Mac2020_2])

Any issues or pull requests listing on Github cannot be interacted with with VoiceOver.

  1. Open this listing of NVDA pull requests.
  2. Navigate to the issues filtering form, and VoiceOver+RightArrow over the Author etc. sorting buttons.
  3. Navigate to the Issues group.
    • Expected: VoiceOver should start reading the issues.
    • Actual: VoiceOver says "Issues empty group". VoiceOver+Shift+DownArrow does not work, and VoiceOver+Shift+RightArrow skips straight to the page's footer.
  4. Go back to the empty issues group, then press Tab.
    • Result: VoiceOver speaks the focused issue title within the group, and VoiceOver+Left and Right can see the current issue's listing content. However, at either end of that issue entry, VoiceOver will fall through to the footer or the sorting section respectively.

After doing step 3 in the STR, I hear "Open pull request, empty group". This is the correct result. It is the value of first item in the first issues row. Checked on Safari and it is the same there. Maybe the "empty group" utterance is confusing? Seems like a markup/VO quirk.

Marco, can you confirm this works?

Flags: needinfo?(mzehe)

Works for me, probably fixed by bug 1675301.

Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(mzehe)
Resolution: --- → WORKSFORME

This has reappeared in today's Nightly. If I VoiceOver past the Author, Labels, ... etc menu buttons, I reach an "Issues empty group", and the next VoiceOver+RightArrow will take me straight to the "Pagination" region. If this is a result of bug 1679957 being fixed, I don't know. Fact is: It is back now, where yesterday, it was gone. Reopening.

Status: RESOLVED → REOPENED
Flags: needinfo?(eitan)
Resolution: WORKSFORME → ---

Tried again with the latest nightly - can't reproduce. "Issues" is not an empty group. "Open pull request" which is the first cell on each row is an empty group indeed. But that is true in chrome and safari too.

Flags: needinfo?(eitan)

This is intermediate, and it can always be fixed by reloading the page. I can reproduce frequently, Eitan couldn't when we tried together over Zoom just now. Dropping to P2, not a blocker for the consumr preview.

Priority: P1 → P2
You need to log in before you can comment on or make changes to this bug.