Closed Bug 1679138 Opened 11 months ago Closed 11 months ago

The separator after the "import bookmarks" button doesn't have the same spacing as other bookmarks toolbar separators

Categories

(Firefox :: Toolbars and Customization, defect, P3)

defect

Tracking

()

VERIFIED FIXED
85 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- unaffected
firefox84 --- disabled
firefox85 --- verified
firefox86 --- verified

People

(Reporter: oana.botisan, Assigned: Gijs)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Affected versions

  • Firefox 84.0b4
  • Firefox 85.0a1

Affected platforms

  • Ubuntu 18.04 x64
  • Windows 10 x64
  • macOS 10.15

Steps to reproduce

  1. Open Bookmarks Toolbar
  2. Add a few separators via context menu ( right-click on Bookmarks Toolbar and click on "New Separator").
  3. Drag two of the separators between the first two bookmarks displayed by default.

Expected result

  • The distances between the separators are the same.

Actual result

  • The distances between the separators are not constant.

Regression range

  • If it's a regression, I will try to find it asap.

** Notes**

  • This issue is reproducing on all of the themes.

Suggested severity

  • S3
Has STR: --- → yes
QA Whiteboard: [qa-regression-triage]
Has Regression Range: --- → yes

Looks like potential fallout from bug 1665442?

Severity: -- → S4
Priority: -- → P3
Flags: needinfo?(gijskruitbosch+bugs)
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Flags: needinfo?(gijskruitbosch+bugs)
Summary: The distances between the separators displayed on the Bookmark Toolbar are not constant → The separator after the "import bookmarks" button doesn't have the same spacing as other bookmarks toolbar separators
Regressed by: 1665442
Blocks: 1665353
See Also: → 1681499
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5e89d54f4951
fix spacing of the separator between the import button and other bookmarks items, r=mconley
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch

Verified the fix using latest Nightly 86.0a1 and Firefox 85.0b1 on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.13. The issue is not reproducing anymore.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.