Closed Bug 1681499 Opened 11 months ago Closed 11 months ago

Dragging Import bookmarks item or adding new items into toolbar after the Import bookmarks separator shows a grey background

Categories

(Firefox :: Toolbars and Customization, defect)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
85 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox83 --- unaffected
firefox84 --- wontfix
firefox85 --- verified

People

(Reporter: atrif, Assigned: Gijs)

References

(Regression)

Details

(Keywords: regression)

Attachments

(2 files)

Attached image customize_importb.gif

Affected versions

  • 85.0a1(20201208094500)
  • 84.0 (20201207203640)

Affected platforms

  • Windows 10x64
  • Ubuntu 18.04
  • macOS 10.15

Steps to reproduce

  1. Open Firefox with a new profile and go to Customize mode.
  2. Drag Import bookmarks.

Expected result

  • No grey background is displayed.

Actual result

  • Grey background is displayed on the dragged item.

Regression range

Notes

  • Attached a screen recording.
  • If adding a random item after the Import bookmarks one separator it makes a grey background as well. This happens only for one item. The other ones do not have grey backgrounds.
  • On 84.0 this can be reproduced by enabling the bookmarks toolbar and dragging the Import Bookmarks item to the bookmarks bar and dragging it back while in Customize mode.

Suggested Severity: S4

Has Regression Range: --- → yes
Has STR: --- → yes
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
See Also: → 1679138

We use the border to create space when dragging items to/from the toolbar,
so we shouldn't be changing its colour to create a visual border.

Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/4a35f88e0af8
ensure border is on #personal-bookmarks, not its wrapper, even in customize mode, to avoid drag/drop artifacts, r=jaws
Status: ASSIGNED → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch

The issue is verified fixed with Firefox 85.0a1 (20201210092800) on windows 10x64, macOS 10.12 and Ubuntu 20. No artifacts are presented after following steps from comment 0.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.