Closed Bug 1679456 Opened 4 years ago Closed 4 years ago

Remove popup opening tokens (replacing them by user activation consumption).

Categories

(Core :: DOM: Core & HTML, task, P2)

task

Tracking

()

RESOLVED FIXED
85 Branch
Tracking Status
firefox85 --- fixed

People

(Reporter: emilio, Assigned: emilio)

References

Details

Attachments

(3 files)

These two mechanisms serve basically the same purpose.

I think this allows us to remove TryUsePopupOpeningToken (which is a similar
concept to consuming user activation), and also the ad-hoc <iframe> timing
thing we have from bug 1514547, which should be covered by the user activation
timeout.

Depends on D97640

As the use case we know it was needed for should be covered by the previous
patch as well.

This is also process-global, which is a bit odd, given whether a popup-opening
operation succeeds ends up depending on other tabs' activity.

Depends on D98020

The test tweak is needed because user interaction isn't registered by a
single mouseup, but the test is still valid with that tweak IMO.

Depends on D98021

Severity: -- → N/A
Priority: -- → P2
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/32b16732aabc
Use transient user activation for iframe external protocol blocking. r=smaug,edgar
https://hg.mozilla.org/integration/autoland/rev/8b56e2cc3518
Disable external-protocol-blocking bypass timer in Nightly. r=smaug,edgar
Pushed by ealvarez@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/68af110cd33e
Consume user activation on popup opening and remove popup opening tokens. r=smaug,edgar
Regressions: 1680721
Regressions: 1684490
Regressions: 1685056
Regressions: 1689853
Regressions: 1690099
Regressions: 1703472
Regressions: 1789522
Regressions: 1795380
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: