Closed Bug 1680615 Opened 8 months ago Closed 6 months ago

Enabling the flag `widget.disable-native-theme-for-content` disables custom colored scrollbars

Categories

(Core :: Widget, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1619425
Fission Milestone M7

People

(Reporter: saschanaz, Assigned: spohl)

References

Details

Attachments

(1 file)

It happens on my Windows device on some dark-mode pages e.g. this Bugzilla page.

Component: Layout → Widget

I'm currently fine-tuning the Windows scrollbars for non-native theming and will try to incorporate this.

Assignee: nobody → spohl.mozilla.bugs

scrollbar-color should work on Windows with the non-native theme. That page doesn't have scrollbar-color set on the root element either (though it does have it set on the body, which is having no effect). So it's probably rather that we're still relying on the hard coded colors rather than OS-derived colors when scrollbar-color is set to auto.

Blocks: win-nnt
No longer blocks: remove-native-theming

Tracking non-native theming bugs for Fission Beta milestone (M7).

Fission Milestone: --- → M7

This is a duplicate of bug 1619425, which is expected to get fixed in bug 1615038.

Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1619425
You need to log in before you can comment on or make changes to this bug.