Closed Bug 1681950 Opened 4 months ago Closed 4 months ago

ThreadSanitizer: data race [@ __xstat64] vs. [@ __xstat64] via [@ mozilla::PreferencesWriter::Write]

Categories

(Core :: XPCOM, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
85 Branch
Tracking Status
firefox85 --- fixed

People

(Reporter: decoder, Assigned: Gankra)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

The attached crash information was detected while running CI tests with ThreadSanitizer on autoland revision 18f7558b7bb0ee71dec915906de3d4efd8e11954.

For detailed crash information, see attachment.

Looks like we are trying to write preferences from two different threads in an unsafe way.

General information about TSan reports

Why fix races?

Data races are undefined behavior and can cause crashes as well as correctness issues. Compiler optimizations can cause racy code to have unpredictable and hard-to-reproduce behavior.

Rating

If you think this race can cause crashes or correctness issues, it would be great to rate the bug appropriately as P1/P2 and/or indicating this in the bug. This makes it a lot easier for us to assess the actual impact that these reports make and if they are helpful to you.

False Positives / Benign Races

Typically, races reported by TSan are not false positives [1], but it is possible that the race is benign. Even in this case it would be nice to come up with a fix if it is easily doable and does not regress performance. Every race that we cannot fix will have to remain on the suppression list and slows down the overall TSan performance. Also note that seemingly benign races can possibly be harmful (also depending on the compiler, optimizations and the architecture) [2][3].

[1] One major exception is the involvement of uninstrumented code from third-party libraries.
[2] http://software.intel.com/en-us/blogs/2013/01/06/benign-data-races-what-could-possibly-go-wrong
[3] How to miscompile programs with "benign" data races: https://www.usenix.org/legacy/events/hotpar11/tech/final_files/Boehm.pdf

Suppressing unfixable races

If the bug cannot be fixed, then a runtime suppression needs to be added in mozglue/build/TsanOptions.cpp. The suppressions match on the full stack, so it should be picked such that it is unique to this particular race. The bug number of this bug should also be included so we have some documentation on why this suppression was added.

Blocks: 1636095
Component: General → XPCOM

Kris, could you please take a look? I'm not familiar with this code, but it looks like the nsIFile for preferences is being written to on multiple threads at once. Thanks.

Flags: needinfo?(kwright)

Sounds like Gankra has already started looking at this.

Flags: needinfo?(kwright)
Assignee: nobody → a.beingessner
Status: NEW → ASSIGNED
Pushed by abeingessner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/82ef6d7419cc
properly serialize the PreferencesWriter's operations. r=KrisWright
Pushed by abeingessner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6183c0cb65cc
properly serialize the PreferencesWriter's operations. r=KrisWright
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 85 Branch
Flags: needinfo?(a.beingessner)
See Also: → 1682571
You need to log in before you can comment on or make changes to this bug.