Closed Bug 1682873 Opened 2 years ago Closed 2 years ago

Trying to use "save image as" when an image is in the message body pane no longer works

Categories

(Thunderbird :: Upstream Synchronization, defect)

Thunderbird 85
defect

Tracking

(thunderbird_esr78 unaffected, thunderbird85 affected)

RESOLVED FIXED
86 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird85 --- affected

People

(Reporter: thee.chicago.wolf, Assigned: mkmelin)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:85.0) Gecko/20100101 Firefox/85.0

Steps to reproduce:

I received an email that had an image in the message body instead of as an attachment.

Actual results:

I right-clicked the image and chose "Save Image As" to save it to desktop. It did not save to desktop. I was able to drag it from the message pane to the desktop just fine.

Error console has some useful info:

09:25:37.852 aInitiatingDocument is undefined contentAreaUtils.js:340
continueSave chrome://global/content/contentAreaUtils.js:340
internalSave chrome://global/content/contentAreaUtils.js:319
(Async: promise callback)
internalSave chrome://global/content/contentAreaUtils.js:311
saveURL chrome://global/content/contentAreaUtils.js:68
saveImage chrome://messenger/content/nsContextMenu.js:844
oncommand chrome://messenger/content/messenger.xhtml:1

Expected results:

Right-clicking an image in the message pane window and choosing "Save Image As" should save the image where requested.

Component: Untriaged → General

On Mac with 85 beta I see the same thing, and same error console.

Flags: needinfo?(mkmelin+mozilla)
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Component: General → Upstream Synchronization
Flags: needinfo?(mkmelin+mozilla)
Regressed by: 1679325
Target Milestone: --- → 86 Branch
Attachment #9194391 - Flags: review?(lasana)
Comment on attachment 9194391 [details] [diff] [review]
bug1679325_saveurl.patch

Review of attachment 9194391 [details] [diff] [review]:
-----------------------------------------------------------------

The fix works.
Attachment #9194391 - Flags: review?(lasana) → review+
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED

(In reply to Magnus Melin [:mkmelin] from comment #5)

https://hg.mozilla.org/comm-central/rev/dc74addeeb7065c06ac6afbec1ca511caf7b462b (maybe pulsebot was on strike?)

The commit message had bug 1679325, so Pulsebot made a comment there.

So this still doesn't seem to be working as of 86.0b2. I just got an image, right-clicked on it to "Save Image As" and the Save Image box pops up with a blank name and wants to save as type "All Files." Even if you give it a name and try to save it, nothing saves.

If you click the Save button it prompts with the file name pre-populated and file type of jpg file. This works ok. Drag and drop still works ok.

It was fixed. Looks like tb-fission broke it again. Going to file a bug.

See Also: → 1691935
You need to log in before you can comment on or make changes to this bug.