Closed Bug 1684530 Opened 2 years ago Closed 2 years ago

Focusring / outline / highlight is cut off on buttons inside the Saved Addresses/ Saved Credit Cards dialogs

Categories

(Firefox :: Preferences, defect, P5)

defect

Tracking

()

VERIFIED FIXED
86 Branch
Tracking Status
firefox84 --- wontfix
firefox85 --- wontfix
firefox86 --- verified

People

(Reporter: Anca, Assigned: itiel_yn8)

References

Details

Attachments

(2 files)

Attached image Screenshot issue.png

Affected versions

  • 84.0
  • 85.0b4
  • 86.0a1 (2020-12-28)

Affected platforms

  • Ubuntu 18.04
  • Windows 10

Steps to reproduce

  1. Make sure extensions.formautofill.available is set to on
  2. Go to about:preferences#privacy
  3. Open the Saved Address panel
  4. Save an address
  5. Select the new saved address and navigate the panel with Tab
  6. Observe the Remove and Edit buttons highlight

Expected result

  • The highlight is not cut off

Actual result

  • The highlight is cut off

Regression range

  • Not a regression, since the tab navigation inside the panel was not possible on a “good” build, the issue is visible starting with Fx 65.0a1 (pushlog, probably introduced by 1511394)

Additional notes

  • Visible regardless the theme or if the Saved Address/ Credit Cards panel is resized
  • No other panels from about:preference seems to be affected

Suggested severity

  • S4
Has STR: --- → yes
Severity: -- → S4
Priority: -- → P5
Product: Toolkit → Firefox
Summary: Cut off highlight on margin buttons inside the Saved Addresses/ Saved Credit Cards → Focus outline / highlight is cut off on buttons inside the Saved Addresses/ Saved Credit Cards dialogs
Summary: Focus outline / highlight is cut off on buttons inside the Saved Addresses/ Saved Credit Cards dialogs → Focusring / outline / highlight is cut off on buttons inside the Saved Addresses/ Saved Credit Cards dialogs
Assignee: nobody → itiel_yn8
Status: NEW → ASSIGNED
Pushed by btara@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/c39478cd3068
Minor improvements to the Saved Addresses and Saved Credit Cards dialogs r=sfoster
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch

Verified fixed with the latest Nightly 86.0a1 (2021-01-07) on Windows 10 and Ubuntu 18.04.

Status: RESOLVED → VERIFIED
See Also: → 1710407
You need to log in before you can comment on or make changes to this bug.