Closed Bug 1684950 Opened 10 months ago Closed 2 months ago

Use sentence casing for the Firefox Accounts panel

Categories

(Firefox :: Firefox Accounts, task, P2)

task
Points:
1

Tracking

()

VERIFIED FIXED
93 Branch
Tracking Status
firefox93 --- verified

People

(Reporter: mconley, Assigned: mhowell)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-hamburger-menu] [priority:2a])

Attachments

(3 files, 2 obsolete files)

This panel is used both from the Accounts button, and from the App Menu. We should use sentence casing for it.

Note that sync should be lowercase s as well, per a change in our copy guidelines.

(In reply to mheubusch from comment #1)

Note that sync should be lowercase s as well, per a change in our copy guidelines.

Can you point me to the guidelines?

That's a pretty huge can of worms, because "Sync" is (was?) a brand name for the feature. Changing the main string will have consequences way beyond this panel for English, and I would need some guidance on what other locales are expected to do.

To make it clearer. "Sync" as a brand is defined here

https://searchfox.org/mozilla-central/source/browser/branding/official/locales/en-US/brand.properties
https://searchfox.org/mozilla-central/source/browser/locales/en-US/browser/branding/sync-brand.ftl

All other strings are only using references to these definitions. On top of that, "Sync" was one of the features that was considered fully localizable, since it carries a meaning and it's not just a name
https://transvision.flod.org/string/?entity=browser/branding/official/brand.properties:syncBrandShortName&repo=gecko_strings

Component: General → Firefox Accounts

I touched base with Flod and we are moving ahead with the change to sentence-casing 'sync.' It's a larger scope of work than anticipated: strings will need to be updated and re-translated.

Flod needs to communicate this to localizers ahead of the change to make sure they understand what's happening, and I'm working with him on the guidance to be provided.

For ENG, all references to the brand name (Sync, title case) will need to be replaced by "sync". Proton is focused on core UI now, but we should update the casing across product (so, in our about:pages, too). Please let me know if you need any more information from me. As an FYI, here is the draft guidelines which I've asked Flod to review:

Definition: To synchronize information. Commonly referred to syncing data and preferences across devices with a Firefox account.
Usage example: "You’ll need to sign in to every installation of Firefox to sync your information."
Notes: Sentence case 'sync' unless it is the first word in a sentence. We no longer use ‘sync’ as a proper noun to describe a feature: Avoid “Firefox sync” where possible; variants are syncing, synced. Can also be used as a noun (but not a proper noun): “If you would like all of your profile data to be the same on all installations of Firefox, you can use a { -fxaccount-brand-name } to keep them in sync.” When referring more specifically to saving data to the cloud on one device, use “back up” instead: "Sign in to your account to back up your passwords, bookmarks, and history.”
About the change in ‘sync’ definition and casing: “Sync” used to be the name of a feature, but has since become the verb for something one does with a Firefox account. Casing ‘sync’ as a proper noun introduces a lot of confusion because the word is also a common noun and a verb.

Flags: needinfo?(mconley)

Roger, thanks Meridel.

Flags: needinfo?(mconley)

Hey flod, so here's my game plan on this. I'm hoping you can tell me if it makes sense, and won't overburden or incur wasted work for our localizers:

  1. Fold the Sync brand strings into the strings that refer to them, and drop the Sync brand strings altogether.
  2. Convert any strings that originally used the Sync brand to Fluent, since our localizers will need to re-translate them anyways
  3. Land patches for (1) and (2) this cycle to give our localizers an opportunity to do the translations
  4. Write patches to put those strings into sentence case where appropriate (forking with migrations where needed) targeted for next release. My hope is that this patch will incur 0 work on the part of our localization community.

Does that sound reasonable?

Flags: needinfo?(francesco.lodolo)

(In reply to Mike Conley (:mconley) (:⚙️) (Catching up on needinfos) from comment #6)

Does that sound reasonable?

That sounds like a great plan, and it reduces the risk/impact on localization.

Flags: needinfo?(francesco.lodolo)

Hey sledru, not sure if you're the right person to ask, but I know you have your feelers in some distros... are we aware of any alternative forks of Firefox that might have a differently branded version of "Sync" that might be impacted by these changes? I don't think that should block this effort, but we might want to reach out to them to let them know it's happening.

Flags: needinfo?(sledru)
Assignee: nobody → mconley
Status: NEW → ASSIGNED

Hey flod, do you know what we should do for this one?: https://searchfox.org/mozilla-central/rev/07342ce09126c513540c1c343476e026cfa907bf/browser/locales/en-US/browser/branding/sync-brand.ftl#7-9

The comment suggests that "Sync" can already be translated... do we just leave it as it is? How does something like this work?

Here's how it's used in context: https://searchfox.org/mozilla-central/rev/07342ce09126c513540c1c343476e026cfa907bf/browser/locales/en-US/browser/newInstallPage.ftl#31

Flags: needinfo?(francesco.lodolo)

I think that's more a question for Meridel (see also Avoid “Firefox sync” where possible in her comment above). We currently have two strings using that brand term.

(Enter your email) to continue to { -sync-brand-name }
First time using { -sync-brand-name }? You’ll need to sign in to every installation of Firefox to sync your information.

How should those two strings look like? Just using "sync" doesn't seem great. Maybe something like

(Enter your email) to start syncing
First time syncing? You’ll need to sign in to every installation of Firefox to sync your information.
Flags: needinfo?(francesco.lodolo) → needinfo?(mwalkington)

Correction: the first string doesn't exist anymore in mozilla-central, it was removed at some point after 78 (which we still support in l10n repositories).

So, it's only about the second string, where I think "syncing" would make sense.

First time using { -sync-brand-name }? You’ll need to sign in to every installation of Firefox to sync your information.

Looking at the affected strings in the current patch on Phabricator, I think there are a few patterns that actually need UX eyes.
https://phabricator.services.mozilla.com/D101642

If we simply replace "Sync" with "sync", we'll end up with some weird strings.

Sync Options/Preferences

Should those say "options/preferences/settings for sync", or something like that, instead of "sync options/preferences/settings"?

login-intro-instruction-fxa-settings = Make sure you’ve selected the Logins checkbox in Sync Settings

enable-password-sync-notification-message =
  { PLATFORM() ->
      [windows] Want your logins everywhere you use { -brand-product-name }? Go to your Sync Options and select the Logins checkbox.
     *[other] Want your logins everywhere you use { -brand-product-name }? Go to your Sync Preferences and select the Logins checkbox.
  }

enable-password-sync-preferences-button =
  .label =
    { PLATFORM() ->
        [windows] Visit Sync Options
       *[other] Visit Sync Preferences
    }
  .accesskey = V

get-started-configured = Open Sync preferences

Sign in to Sync

I think "Sign in to sync" still makes some sense, but the meaning is completely different from the original ("sign in to this feature" vs "sign in to start syncing").

appmenu-remote-tabs-sign-into-sync =
  .label = Sign in to Sync…

get-started-not-logged-in = Sign in to Sync…

sync-signedout-account-signin2 =
    .label = Sign in to Sync…
    .accesskey = i

Disconnect Sync

This one definitely needs rephrasing.

sync-disconnect-dialog-title = Disconnect Sync?
  1. Do you have a screenshot handy of the new install message?
  2. Re: Preferences— it was my understanding that about:pages were out of scope for Proton. Is the sync casing change forcing an exception?
  3. As an FYI, I am re-working the FxA menu within the hamburger/application menu. Strings will be final by Jan 25, but here is the latest draft: https://docs.google.com/presentation/d/1Ufd0A3HsziyXXAjXYNH84P2bu7RdTxARsA0xpKmwIWs/edit?ts=6002078a#slide=id.gb548051def_0_1
Flags: needinfo?(mwalkington) → needinfo?(mconley)
Attached image about:newinstall

Hi Meridel,

  1. Yep! Attached. That's about:newinstall if you want to look at it locally.
  2. Yes, that's true - however, I thought we were going to verb-ify "Sync" across the board. I'll see if I can restrict it to the menus for now - that might actually make my job simpler.
  3. Thanks for the draft!
Flags: needinfo?(mconley)

I don't know if any distro rebranded Sync (seems unlikely).
What is the potential impact if they did?

Flags: needinfo?(sledru) → needinfo?(mconley)

(In reply to Sylvestre Ledru [:Sylvestre] from comment #17)

I don't know if any distro rebranded Sync (seems unlikely).
What is the potential impact if they did?

Slowly but surely (starting in our panels), we're going to be removing the separate sync branding string. This means that any rebranded sync offered by repacks are going to eventually lose that branding capability.

Flags: needinfo?(mconley)
See Also: → 583381
Depends on: 1692737
Whiteboard: [proton-hamburger-menu]
Blocks: 1682022
No longer blocks: 1682015
Priority: -- → P2
Assignee: mconley → nobody
Status: ASSIGNED → NEW
Depends on: 1700638
Whiteboard: [proton-hamburger-menu] → [proton-hamburger-menu][priority:2a]
Attachment #9199853 - Attachment is obsolete: true
Attachment #9196906 - Attachment is obsolete: true

Now that Sync branding has been removed from these strings, I believe the only work here involves to actual transition to sentence case, which doesn't require localizers to do anything.

Whiteboard: [proton-hamburger-menu][priority:2a] → [proton-hamburger-menu] [priority:2a]
Assignee: nobody → mhowell
Status: NEW → ASSIGNED
Points: --- → 1

Only two strings that appear in the accounts panel are still in title case,
but those two need to be forked, because they are also used in other menus
where they need to remain in title case.

This patch adds the two "new" strings and the necessary switch to select
between them and the existing strings, since all of these menus are dynamically
constructed by the same code.

Blocks: 1682015
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fe5daa513a14
Change the remaining Firefox Account panel strings to sentence case. r=Gijs,flod,fluent-reviewers
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

Strings on Firefox Account panel are verified as fixed using latest Nightly 93.0a1 across platforms: Windows 10 x64, macOS 11 and Ubuntu 18.04 In regards to the overall consistency and the fact that our understanding is that the context menu should not use sentence casing, “Send tab to device” shouldn’t be in title case when the context menu is opened from a random tab?

Flags: needinfo?(mhowell)

Ooh, yeah, that shouldn't have changed. Can you file a bug for that as a regression from this bug? Thanks.

Flags: needinfo?(mhowell) → needinfo?(anca.soncutean)

(In reply to Molly Howell (she/her) [:mhowell] from comment #25)

Ooh, yeah, that shouldn't have changed. Can you file a bug for that as a regression from this bug? Thanks.

Filled as 1727484.

Flags: needinfo?(anca.soncutean)

As per comment 24 I will mark this bug as verified.

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.