Closed Bug 1686607 Opened 4 months ago Closed 4 months ago

wpt-serve fails on Windows, trying to call .decode() against a tuple

Categories

(Testing :: web-platform-tests, defect)

x86_64
Windows 10
defect

Tracking

(firefox-esr78 unaffected, firefox84 unaffected, firefox85 unaffected, firefox86 fixed)

RESOLVED FIXED
86 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox84 --- unaffected
firefox85 --- unaffected
firefox86 --- fixed

People

(Reporter: saschanaz, Assigned: saschanaz)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Error running mach:

    ['wpt-serve']

The error occurred in code that was called by the mach command. This is either
a bug in the called code itself or in the way that mach is calling it.
You can invoke |./mach busted| to check if this issue is already on file. If it
isn't, please use |./mach busted file wpt-serve| to report it. If |./mach busted| is
misbehaving, you can also inspect the dependencies of bug 1543241.

If filing a bug, please include the full output of mach, including this error
message.

The details of the failure are as follows:

AttributeError: 'tuple' object has no attribute 'decode'

  File "C:\Users\Kagami\Documents\GitHub\gecko-dev\testing/web-platform/mach_commands.py", line 559, in wpt_serve
    return wpt_serve.run(**params)
  File "C:\Users\Kagami\Documents\GitHub\gecko-dev\testing/web-platform/mach_commands.py", line 270, in run
    return 0 if serve.run(route_builder=get_route_builder, **kwargs) else 1
  File "C:\Users\Kagami\Documents\GitHub\gecko-dev\testing\web-platform\tests\tools\serve\serve.py", line 1021, in run
    with stash.StashServer(stash_address, authkey=str(uuid.uuid4())):
  File "C:\Users\Kagami\Documents\GitHub\gecko-dev\testing\web-platform\tests\tools\wptserve\wptserve\stash.py", line 44, in __enter__
    self.manager, self.address, self.authkey = start_server(self.address,
  File "C:\Users\Kagami\Documents\GitHub\gecko-dev\testing\web-platform\tests\tools\wptserve\wptserve\stash.py", line 81, in start_server
    address = address.decode("ascii")

address can be tuple as implied in https://phabricator.services.mozilla.com/D99875

Assignee: nobody → krosylight
Status: NEW → ASSIGNED
Pushed by krosylight@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/ef3f23be3adf
Decode address only when it's bytes r=jgraham
Failed to create upstream wpt PR due to merge conflicts. This requires fixup from a wpt sync admin.
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 86 Branch
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/27228 for changes under testing/web-platform/tests
Upstream PR merged by moz-wptsync-bot
You need to log in before you can comment on or make changes to this bug.