Closed Bug 168762 (thai-unix.js) Opened 17 years ago Closed 12 years ago

RFE: unix.js needs font definitions for Thai locale

Categories

(Core :: Layout: Text and Fonts, defect, P3)

Sun
Solaris
defect

Tracking

()

RESOLVED DUPLICATE of bug 284265

People

(Reporter: arthit, Assigned: jshin1987)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Keywords: intl)

Attachments

(1 file)

1.12 KB, patch
jshin1987
: review?
roland.mainz
brendan
: superreview+
Details | Diff | Splinter Review
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.2a) Gecko/20020910
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.2a) Gecko/20020910

pref("font.name.serif.th", "monotype-angsana-tis620-0");
pref("font.name.sans-serif.th", "monotype-cordia-tis620-0");
pref("font.name.monospace.th", "logic-gothic-tis620-0");

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
please add these lines to defaults/pref/unix.js

----
pref("font.name.serif.th", "monotype-angsana-tis620-0");
pref("font.name.sans-serif.th", "monotype-cordia-tis620-0");
pref("font.name.monospace.th", "logic-gothic-tis620-0");

pref("font.size.variable.th", 16);
pref("font.size.fixed.th", 12);
----

Alias: thai-unix.js
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: RFE: please add font definitions for Thai locale → unix.js please add font definitions for Thai locale
Easy enough to do, but not up to me to decide whether it is a desirable
addition. ->Intl.
Assignee: bnesse → yokoyama
Component: Preferences: Backend → Internationalization
QA Contact: rvelasco → ruixu
Code issue, QA to yokoyama@netscape.com for now.
Keywords: intl
QA Contact: ruixu → yokoyama
Can anyone provide a patch, please (or would that be my job :) ?
Component: Internationalization → Complex Text Layout
Attached patch patchSplinter Review
it's unbelievable that this easy bug has been left often more than a year.
Comment on attachment 138255 [details] [diff] [review]
patch

asking for r/sr.



min font size spec. for Thai is in the tree. so that I don't have to patch it.
Attachment #138255 - Flags: superreview?(brendan)
Attachment #138255 - Flags: review?(Roland.Mainz)
those fonts in the patch were tested against Solaris 8,
never tested against Solaris 9, Solaris 10 or Linux.

monospace:
logic-gothic-tis620-0 is available on Solaris only, and is a bitmap font.

Lucida TypeWriter may be more suitable
(was not available at the time of proposing patch)
- available in at least 4 platforms (Sol,Lin,Win,Mac / comes with Sun JVM)
- scalable font
Comment on attachment 138255 [details] [diff] [review]
patch

rs=me, and you can use my rubberstamp for similar such changes in the future.

/be
Attachment #138255 - Flags: superreview?(brendan) → superreview+
Thanks, brendan, for rs. There's a problem, though.

I'm afraid I was too hasty to ask for review. I didn't notice that fonts in the
patch may not be available widely. It seems like 'monotype' fonts are default on
Solaris for Thai, but may not be available for Linux users (or other Unix
users). It should  not be a big deal in practice, but I'm  still a bit
uncomfortable specifying fonts not in the 'public domain' as the default. 

In case of other langGroups, we're rather conservative in font selection. For
instance, CJK fonts specified in unix.js are those included in X11R5 (yes, more
than a decade ago) although there are a lot better fonts available. 

There are a few Thai experts on CC. What do you think? 





Assignee: yokoyama → jshin
jshin:
IMHO it is better to implement the fontlist feature as soon as possible... then
we can fill the prefs with defaults for all platforms and Mozilla will pickup
the right one without problems...
Blocks: thai
related bug,
bug 61883 : Smarter default prefs for the 5 basic CSS fonts
Depends on: 61883
Priority: -- → P3
Summary: unix.js please add font definitions for Thai locale → RFE: unix.js needs font definitions for Thai locale
BugAThon Thailand

from Bug 284265, we settled with this:

Windows:
serif: Tahoma
sans-serif: Tahoma
monospace: Tahoma

Linux:
serif: serif
sans-serif: sans-serif
monospace: monospace

Mac OS X:
serif: Thonburi
sans-serif: Thonburi
monospace: Ayuthaya


----

notes:
in Linux, we use font aliases.
for Thonburi problem on Mac OS X, we decide to file it to Apple.
Default font for Thai should be "sans-serif"

pref("font.default.th", "sans-serif");


although not quite precise, we will close this bug as duplicate of Bug 284265, which covers settings on all platform (Windows, Mac OS X, Linux, etc.).

all other additional comments (e.g. on size, minimum-size for each platform) should be done there.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 284265
Component: Layout: CTL → Layout: Text
QA Contact: tetsuroy → layout.fonts-and-text
You need to log in before you can comment on or make changes to this bug.