Default Thai fonts should be set appropriately on each platform

RESOLVED FIXED

Status

()

Core
Internationalization
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: Samphan Raruenrom, Assigned: smontagu)

Tracking

(Blocks: 1 bug, {fixed1.9.0.2, intl})

Trunk
fixed1.9.0.2, intl
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

5.04 KB, patch
Arthit Suriyawongkul
: review+
Samuel Sidler (old account; do not CC)
: approval1.9.0.2+
Details | Diff | Splinter Review
(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20050206 Firefox/1.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.5) Gecko/20050206 Firefox/1.0

Currently default Thai fonts after installation on each platform are not set
appropriately. For example, on Windows the default are  'Times New Roman' for
serif, "Arial" for sans-serif, "Courier New" for monospace and "Comic Sans MS"
for cursive. All don't have Thai glyphs. See modules/libpref/src/init/all.js.

Reproducible: Always

Steps to Reproduce:
Install Mozilla/Firefox on any platform
Actual Results:  
The default Thai fonts are set up inappropriately, some platforms using Western
fonts. The Thai web pages that don't set Thai font in the HTML/CSS will not be
readable.

Expected Results:  
The default Thai fonts should be set up so that Thai can be used instantly after
installed.

I think this is because lack of information on which Thai font to be used for
each category on each platform. This bug is an attempt to gather information
regarding this.
(Reporter)

Updated

13 years ago
Summary: Default Thai fonts should be set appropriately on each platform → Default Thai fonts should be set appropriately on each platform
(Reporter)

Updated

13 years ago
Blocks: 65896
(Reporter)

Comment 1

13 years ago
Fonts for Windows:    serif,        san-serif,         monospace
                     Angsana New?, Browallia New?,         ??

Fonts for MacOSX:     serif,        san-serif,         monospace
                     Thonburi?,    Krungthep?,         Ayuthaya?

Fonts for Unix/Linux  serif,        san-serif,         monospace
                        ??              ??                 ??

Fonts for OS2:        serif,        san-serif,         monospace
                        ??              ??                 ??
On Linux, the candidates can be

Serif: Kinnari or Norasi
San-serif: Loma or Garuda
Monospace: Tlwg Typewriter

Kinnari, Norasi and Garuda (Free license or GPL, not clear) are fonts from
National font project. Loma (GPL) is from Linux TLE distribution. Tlwg
Typewriter (GPL) is from Thai Linux Working project.

Further information can be found at
http://linux.thai.net/plone/TLWG/thaifonts_scalable/

Comment 3

13 years ago
On Linux, actually, it doesn't matter because the default fonts are ONLY used by
X11core build for which we have to specify
FFRE(foundry-family-repertoire?-encoding). (see bug 168762) gtk2+xft build get
the default font from user's gtk2 setting. (of course, we could have specified
the default fonts for gtk2+xft, but blizzard doesn't like the idea). 

Since I can access Mac OS X, I'll take care of this. Thanks for info. in comment
#1. 
Assignee: smontagu → jshin1987
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: intl
(Reporter)

Comment 4

13 years ago
Thanks. For Mac OSX, Some Thai say Thonburi/Krungthep don't work. Only 'Lucida
Grande' works.

Comment 5

13 years ago
we didn't put a good font pref for all platform when we wrote those pref back in
2000 because we do not know which one are good. The best way is to find out is
find a native Thai reader and setup the pref in his/her build and then attach
his/her pref here. 

Comment 6

13 years ago
Samphan, please add your comment to bug 159809 (comment #4 is in agreement with
what's being done in bug 159809)

Comment 7

12 years ago
since Bug 225217, default font for Thai on Mac should be "Lucida Grande" and
"Monaco". This issue still happens on 1.5 Beta 1.

Comment 8

10 years ago
Isriya, are the "Lucida Grande" and "Monaco" fonts still the right choice for Gecko 1.9?

If so, jshin, smontagu, is this low risk enough to get onto 1.9 still?
(Reporter)

Comment 9

10 years ago
On Windows the best choice should be :-
Serif: Tahoma
San-serif: Tahoma
Monospace: Tahoma

The rationale is that UPC fonts are too tall. And we can't expect any other fonts like Loma or any free monospace font in users' machine.
Many howto-config-thai-for-firefox suggest the same setting. So I suggest using this formula.

How about Linux? What Thai fonts can we expect to see on the user machine?
And what's the best for Mac?
For Linux, Poonlap's comment #2 still applies, with some updates:

Serif: Kinnari or Norasi
San-serif: Loma, Waree or Garuda
Monospace: Tlwg Typewriter or Tlwg Typist

User preference varies. My personal choice would be:

Serif: Kinnari
San-serif: Loma
Monospace: Tlwg Typist

Kinnari looks most compatible to Times and Angsana, the serif font used in most official documents. Problem is the only distro that ships it at present is Debian (lenny/sid). Ubuntu hardy has not been synchronized yet. If somebody could do a sync for thaifonts-scalable there, it would be much appreciated. And I have no information about its availiblity in other distros yet. For Norasi, it's not a popular candidate yet, AFAIK.

Then, the most suitable San-serif counterpart would be Garuda. But users appear to prefer fonts with more compact line spacing like Loma or Waree. Waree is DejaVu compatible, giving users the closest experience to international users. But it's still new. (Ubuntu hardy release will be its debut to wider range of users.) Meanwhile, user feedback for Loma is still good. So, for now, it's still the most popular one.

Tlwg Typist is a redesigned Tlwg Typewriter. The choice is just my personal taste, as I have less info about user feedback.

However, I wonder if this font preference should still be set, when the other parts of modern Linux desktops are already based on fontconfig.

Comment 11

10 years ago
for ease of reading, I found many users prefer these Sans-serif fonts

Windows
Sans-serif: Tahoma

Linux
Sans-serif: Loma

I personally never tried Waree (mentioned by Theppitak in comment #10)

Comment 12

10 years ago
I would say the default font on Windows, for easy reading, it would be Tahoma. Windows users are now familiar with the font since it is also used as the system's default font.

About Mac OS, I think there is a little problem with the font. Well, this problem persists even with the system itself. I'll try to keep this short.

In Leopard, there is a change where the Thai glyphs have been removed from Lucida Grande. The system then uses Thonburi as the default font. It is still under debate whether people will like it or not but surely its not so familiar with some Mac users. In addition to this, there are some bugs with Thonburi itself (including the variety of the TypeFace and spacing.)

So I don't know. But some of the people who are using Leopard are now using the Lucida Grande from Tiger just to get away from the mess of Thonburi.

Any ideas? Mac users?

Comment 13

10 years ago
For Mac, Lucide Grande is not a good option, as Ian pointed out. Combination of  Thonburi,    Krungthep,   Ayuthaya for serif, san-serif, and monospace is maybe the best choice because these fonts are included in 10.3[1], 10.4[2], and 10.5[3]. So, they guarantee that FF will be able to display  Thai text correctly on most OS X installation.

[1]http://docs.info.apple.com/article.html?artnum=25710
[2]http://docs.info.apple.com/article.html?artnum=301332
[3]http://docs.info.apple.com/article.html?artnum=307069

Comment 14

10 years ago
Note that we dropped support for 10.3, so if that's restricting your choice of fonts, happily neglect it.
I've created a page showing Thai fonts available in Linux:

http://linux.thai.net/~thep/font-samples/thaifonts-scalable-img.html

Comment 16

10 years ago
I'm somewhat disagree on using Thonburi as the primary font in FF3 on OS X. The only reason is that Thonbori lacks bold and italic type faces. I think this is the bug in the OS itself, as the font shouldn't lack of the typeface.

Also, Lucida Grande is somewhat look nicer than Thonburi. :D

Comment 17

10 years ago
On Linux I'm using loma both serif and sans-serif, Tahoma is greatest on Windows

Comment 18

10 years ago
For Mac, Lucida Grande is suitable now for backward compatible.

Thonburi bug is painful for Thai Mac user. I've filed a bug to Apple but no response from there. Actually that bug occurs long time ago.

For Linux font pack (a.k.a. Thai scalable fonts), I prefer Umpush rather than Waree because of its sharpness. But it isn't suitable for Mac now because of floating vowels.

P.S. kind of out of topic.

Comment 19

10 years ago
Oh, I hope Thonburi is a bug, not standard change.

I have also reported it through feedback but I'm sure there would be no response. Anyone have access to 10.5.2 and see any changes regarding the Thai glyphs in Lucida Grande?

Comment 20

10 years ago
Mac should use the system font  (Lucida Grande Regular) for default. Because this font is used for text in menus, modeless dialogs, many controls, and titles of document windows. User should expect this font for default. This is a defensive choice :)
In windows, Serif font should be "Tahoma" and for Sans Serif, I prefered to use Arial Unicode instead of tahoma or MS-Sans serif
Serif: Tahoma
San-serif: Tahoma
Monospace: Tahoma

On top of that, the default minimum font size should be 13, since with the smaller font size, it's quite difficult to read.
(In reply to comment #18)
> For Linux font pack (a.k.a. Thai scalable fonts), I prefer Umpush rather than
> Waree because of its sharpness. But it isn't suitable for Mac now because of
> floating vowels.

Note that Umpush is also only available in Debian lenny/sid for the time being. It doesn't hit Ubuntu hardy yet. (So, a sync would also allow this choice, in addition to Kinnari, for Ubuntu.) No info for other distros, anyway.

These fonts are not for Mac at all, until its OpenType support is improved to handle Thai-specific features well enough.

Comment 24

10 years ago
For OSX 10.4 I preferred Lucida Grande for all (serif, san, mono). 
But anyway I would like to hear from 10.5 users first, anyone?

Comment 25

10 years ago
(In reply to comment #24)
> For OSX 10.4 I preferred Lucida Grande for all (serif, san, mono). 
> But anyway I would like to hear from 10.5 users first, anyone?
> 

I preferred Lucida Grande for 10.5

Comment 26

10 years ago
AFAIK, in Leopard (10.5), Lucida Grande doesn't have Thai glyph. Somehow, Apple changed default Thai front from Lucida Grande to Thonburi, but they don't put bold face to Thonburi font. 

Comment 27

10 years ago
(In reply to comment #26)
> AFAIK, in Leopard (10.5), Lucida Grande doesn't have Thai glyph. Somehow, Apple
> changed default Thai front from Lucida Grande to Thonburi, but they don't put
> bold face to Thonburi font. 

yes. should this also an important factor for consideration ?
-- having bold/italic faces or not for that font.
For Linux, I don't think that Kinnari or Norasi will be suitable to be diplayed in the web page. They are fonts for printed documents. IMO, Loma or Waree will be suitable for both Serif and San-Serif, while I prefer TlwgTypist for fixed font.

So, in conclusion:

Windows:

Serif - Tahoma
San - Tahoma
monospace - ??

Linux:

Serif - Waree
San - Waree
Monospace - TlwgTypist

Thank you.
For the record, there is another set of options for Linux: Arundina fonts [1]. Samples [2] are also available. (Again, it's only available in Debian lenny/sid, not yet in Ubuntu hardy.)

  [1] http://linux.thai.net/projects/thaifonts-arundina
  [2] http://linux.thai.net/~thep/font-samples/thaifonts-arundina-img.html

If possible, I'd rather avoid using the same font for sans serif and serif, as web pages that explicitly specify the different generic families in their stylesheets must have some designing purpose for doing so.

It seems we are lacking good Thai serif font for screen display that everybody is happy with. So, users usually end up with workarounds like Loma and Tahoma, which are both sans serif.

For me, after trying all choices (Kinnari, Norasi, Arundina Serif), I think Kinnari is still the optimal choice we can get, if we are not to resort to workarounds.

In terms of line spacing, Norasi is the winner, and Arundina Serif gives the tallest line. Kinnari is in the middle.

In terms of readability, Norasi seems to be the hardest to read at small sizes, while Kinnari and Arundina Serif can still keep the glyphs to their shapes. This point alone can get Norasi out of consideration.

So, from what we currently have, Kinnari is my optimal choice for serif. Of course, it's not comparable to Loma in terms of suitablility for screen display, as Loma is specially designed with all compromises for that purpose, unlike fonts for printings like Kinnari. But if we want a default serif font that is really serif, it can be the one.
I'd say font  Microsoft San Serif for Windows for both San and Serif.



Comment 31

10 years ago
Nothing change with Thonburi on Mac OS X 10.5.2.

I'm not sure about Thonburi's face on 10.4.x, but I rather choose Thonburi to be a default on Mac OS X due to Thai glyph on Lucida Grande (10.4.x) is quite ugly.

Once the Thonburi bug is fixed (definitely should be fixed) this solution should be ok.

Comment 32

10 years ago
(In reply to comment #31)
>
> Once the Thonburi bug is fixed (definitely should be fixed) this solution
> should be ok.

That's output of control by Mozilla. 

Or Thai Mac users should raise this font issue to Apple.

Comment 33

10 years ago
(In reply to comment #32)
> 
> Or Thai Mac users should raise this font issue to Apple.
> 

Somebody (including me) has raised it but no response from there.
There is a case like this with Ayuthaya font but it is fixed during Leopard beta period. At that time (I think), nobody investigated Thonburi.
(Reporter)

Comment 34

10 years ago
(In reply to comment #28)
> Windows:
> Serif - Tahoma
> San - Tahoma
> monospace - ??

I suggest using Tahoma for monospace, after seeing the same conslusion in many thai-on-FF-on-windows-howtos and trying different fonts for years myself.
Other Thai monospace fonts are not as easy to read and you need to install 
them yourself so shouldn't be the default if Tahoma works

> Linux:
> Serif - Waree
> San - Waree
> Monospace - TlwgTypist

On Linux and Mac, should we choose the fonts that should be available on
as many well-known distros as possible, because they are supposed to be the 
minimum default. Says what should work on LinuxTLE, Ubuntu, Fedora, Debian, ...
On Mac too, choose the best possible choice, taking into consideration the 
systems that are mostly used.

I think it's impossible to find the best-overall solution. 
It's possible for us to go on like this for a long time. If it is possible to get this
into FF 3 (esp. for Windows)? it'd be a good chance now.
I think we have closed the ticket for Windows. Let's decide the as-good-as-possible, 
real-world solution for Linux and Mac ASAP.

Comment 35

10 years ago
so I vote "Lucida Grande" to be default Thai font for Mac version.
Because Thonburi have more problems than a-good-old-version of Lucida Grande.

Problems: (correct me if I misunderstand)
- Thonburi 10.4 : spacing
- Thonburi 10.5 : spacing, typeface (bold/italic), harmony of TH and EN in the same passage
- Lucida Grande 10.4 : -
- Lucida Grande 10.5 : no Thai glyph

 

Comment 36

10 years ago
(In reply to comment #35)
> so I vote "Lucida Grande" to be default Thai font for Mac version.
> Because Thonburi have more problems than a-good-old-version of Lucida Grande.
> 
> Problems: (correct me if I misunderstand)
> - Thonburi 10.4 : spacing
> - Thonburi 10.5 : spacing, typeface (bold/italic), harmony of TH and EN in the
> same passage
> - Lucida Grande 10.4 : -
> - Lucida Grande 10.5 : no Thai glyph
> 

Since Lucida Grande has no Thai glyph on 10.5, it's no point to use Lucida Grande at all.

I still support Thonburi to be the default Thai font.

Comment 37

10 years ago
(In reply to comment #35)
> - Lucida Grande 10.5 : no Thai glyph
> 

Actually, there are Thai glyphs available in it but "intensionally" removed from supporting character set by Apple. That is why browsers cannot use it.

From now, I think Thonburi is the most suitable choice since Thai text in Leopard uses Thonburi. We must wait for Apple to correct this issue.

PS. They just mark Thonburi bug as duplicated. So a little hope, isn't it?

Comment 38

10 years ago
So default Thai font for Firefox Mac should base on Leopard supported font (Thonburi) and hope Apple will fix it soon. 
 
That's the final result for Mac, any objection?
(Reporter)

Comment 39

10 years ago
Agree for Mac to use Thonburi, the default should work on most/all cases, even though not perfectly.

Comment 40

10 years ago
So, in conclusion:

Windows:

Serif - Tahoma
San - Tahoma
monospace - ??

Linux:

Serif - Waree
San - Waree
Monospace - TlwgTypist

Mac OS X:
Serif - Thonburi
San - Thonburi
Monospace - Monaco (??)
(In reply to comment #34)

> On Linux and Mac, should we choose the fonts that should be available on
> as many well-known distros as possible, because they are supposed to be the 
> minimum default. Says what should work on LinuxTLE, Ubuntu, Fedora, Debian, ...
> On Mac too, choose the best possible choice, taking into consideration the 
> systems that are mostly used.

For Linux, I think we can't cover vanilla Fedora, for sure. Or we will end up with some X bitmap fonts.

Waree, Loma and TlwgTypist are all available in TLE 9, Ubuntu hardy and Debian lenny/sid.

Kinnari is only available in TLE 9 and Debian lenny/sid for now. This is only temporary, until the new thaifonts-scalable reaches hardy. (An Ubuntu developer has promised to do the sync.) In the mean time, or as the worst case, one still gets Waree as a fontconfig fallback in current Ubuntu hardy snapshot. 

I wonder how lenny/sid/hardy users feel about Loma and Waree. Which one do you prefer? Can Waree replace Loma? (For me, Loma is still the safe choice for San-serif.)

We can also safely specify Kinnari as the default Serif font, as explained above.

In summary, my proposal for Linux:
Serif - Kinnari
San - Loma (or Waree)
Mono - TlwgTypist

Comment 42

10 years ago
(In reply to comment #40)
> Mac OS X:
> Serif - Thonburi
> San - Thonburi
> Monospace - Monaco (??)
> 

Use Ayuthaya because it looks the same as Monaco (and bug fixed!).

Comment 43

10 years ago
In reply to Theppitak(In reply to comment #41)
> 
> For Linux, I think we can't cover vanilla Fedora, for sure. Or we will end up
> with some X bitmap fonts.

I think we don't need to worry about this since each distro has their own configuration for Firefox. The solution is to file separate bug on Fedora (also SUSE) for the font issue and let they decide.

Comment 44

10 years ago
(In reply to comment #42)
> (In reply to comment #40)
> > Mac OS X:
> > Serif - Thonburi
> > San - Thonburi
> > Monospace - Monaco (??)
> > 
> 
> Use Ayuthaya because it looks the same as Monaco (and bug fixed!).
> 

So the default fonts for Mac OS X should be:
Serif - Thonburi
San - Thonburi
Monospace - Ayuthaya

Comment 45

10 years ago
from BugAThon Bangkok 29 Mar 2008,
we all agree for this:

Windows:
serif: Tahoma
sans-serif: Tahoma
monospace: Tahoma

Linux:
serif: serif
sans-serif: sans-serif
monospace: monospace

Mac OS X:
serif: Thonburi
sans-serif: Thonburi
monospace: Ayuthaya


----

notes:
in Linux, we use font aliases.
for Thonburi problem on Mac OS X, we decide to file it to Apple.

(In reply to comment #45)
> notes:
> in Linux, we use font aliases.

So, we end up with this at last. It's also what I had in mind to propose as the last resort. Let's go on, then.

Updated

10 years ago
Duplicate of this bug: 168762

Comment 48

10 years ago
BugAThon Thailand proposal for default font and default font sizes:

font.default.th = sans-serif

Windows:
font.size.variable.th = 16
font.size.fixed.th = 13
font.minimum-size.th = 10

Linux:
font.size.variable.th = 16
font.size.fixed.th = 13
font.minimum-size.th = 13

Mac OS X:
font.size.variable.th = 16
font.size.fixed.th = 13
font.minimum-size.th = 10
(In reply to comment #48)

> Linux:
> font.size.variable.th = 16
> font.size.fixed.th = 13
> font.minimum-size.th = 13

Aren't the proposed sizes too large? Please note that basic Thai fonts on Linux are already scaled up.

Comment 50

10 years ago
(In reply to comment #49)
> 
> Aren't the proposed sizes too large? Please note that basic Thai fonts on Linux
> are already scaled up.

Kamthorn informed us about Firefox didn't use DPI to calculate the real font size to be drawn on screen, which, in turn, makes the size smaller than expected
(i.e. 10 on Firefox/Linux will be smaller than 10 on Firefox/Windows).

Comment 51

10 years ago
the proposed Thai font sizes are actually inline with other languages e.g.

font.size.variable.x-western = 16
font.size.fixed.x-western = 12
font.minimum-size.x-western = n/a

font.size.variable.x-unicode = 16
font.size.fixed.x-unicode = 12
font.minimum-size.x-unicode = n/a
(In reply to comment #50)

> Kamthorn informed us about Firefox didn't use DPI to calculate the real font
> size to be drawn on screen, which, in turn, makes the size smaller than
> expected
> (i.e. 10 on Firefox/Linux will be smaller than 10 on Firefox/Windows).

Oh, I just realize I based my estimation on a different assumption, as my main browser is Epiphany.

Does this setting affect other browsers than Firefox itself? If not, your proposal should already be reasonable.

Comment 53

10 years ago
(In reply to comment #52)
> Oh, I just realize I based my estimation on a different assumption, as my main
> browser is Epiphany.
> 
> Does this setting affect other browsers than Firefox itself? If not, your
> proposal should already be reasonable.

I added Kamthorn in, he may better explain this krub.

Comment 54

10 years ago
I'm waiting for new version with better default thai font. ;)
Newbies uses does not know how to fix it!
and they do not want to find how to fix it!

:)

Comment 55

10 years ago
Simon, can you still create a patch for this?
(Assignee)

Comment 56

10 years ago
Created attachment 313910 [details] [diff] [review]
Patch based on comment 45 and comment 48
Assignee: jshin1987 → smontagu
Status: NEW → ASSIGNED
Attachment #313910 - Flags: superreview?(l10n)
Attachment #313910 - Flags: review?(arthit)
(Assignee)

Updated

10 years ago
Attachment #313910 - Flags: superreview?(l10n) → superreview?(roc)
Attachment #313910 - Flags: superreview?(roc) → superreview+

Comment 57

9 years ago
On Mac platform, Thai character show "???".

Comment 58

9 years ago
(In reply to comment #57)
> On Mac platform, Thai character show "???".
> 

Please verify this build - http://thai-l10n.googlecode.com/files/firefox-3.0.2pre.en-US.mac.dmg

for other OS - http://code.google.com/p/thai-l10n/downloads/list

Comment 59

9 years ago
(In reply to comment #58)
> (In reply to comment #57)
> > On Mac platform, Thai character show "???".
> > 
> 
> Please verify this build -
> http://thai-l10n.googlecode.com/files/firefox-3.0.2pre.en-US.mac.dmg
> 
> for other OS - http://code.google.com/p/thai-l10n/downloads/list
> 

All of these builds are based on Simon's patch - https://bugzilla.mozilla.org/attachment.cgi?id=313910

Comment 60

9 years ago
The patch works well for me (Mac OS X 10.4.11)

Comment 61

9 years ago
The patch work on those 3 platforms.

Seems the patch is superreviewed, it should be ok to mark this bug as fixed.

Updated

9 years ago
Attachment #313910 - Flags: review?(arthit) → review+
can we put this as fixed ?

Comment 63

9 years ago
No, this still needs to land, I guess we should land this on both mozilla-central and 1.9.0x, Simon?
(Assignee)

Comment 64

9 years ago
Yes, agreed. I'll land it on mozilla-central at the first opportunity, and ask branch approval after some baking time.
(Assignee)

Comment 65

9 years ago
Pushed to mozilla-central. http://hg.mozilla.org/mozilla-central/index.cgi/rev/406de4802d5c
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Assignee)

Updated

9 years ago
Attachment #313910 - Flags: approval1.9.0.2?
Comment on attachment 313910 [details] [diff] [review]
Patch based on comment 45 and comment 48

Approved for 1.9.0.2. Please land in CVS. a=ss
Attachment #313910 - Flags: approval1.9.0.2? → approval1.9.0.2+
(Assignee)

Updated

9 years ago
Keywords: fixed1.9.0.2
You need to log in before you can comment on or make changes to this bug.