Mail panes resize when attachment box is present

VERIFIED FIXED in mozilla1.2beta

Status

VERIFIED FIXED
16 years ago
14 years ago

People

(Reporter: jim.laurent, Assigned: sspitzer)

Tracking

Trunk
mozilla1.2beta

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2a) Gecko/20020915
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.2a) Gecko/20020915

When view a 3 pane mail window, if the message has an attachment the left most
pane resizes automatically to a smaller size.  Then, when you click on a message
without an attachment, the left most pane gets larger again.

This is very visually annoying and makes it difficult to view the mailbox list.

Reproducible: Always

Steps to Reproduce:
1. Open mail in 3 pane view.
2. click on a mail with no attachment.  Left pane is large
3. click on a mail with attachment.  Attachment widget appears on right making
mail message window larger and mailbox pane smaller.

Actual Results:  
Mailbox pane resized by itself.

Expected Results:  
Mailbox pane should not resize itself.

This is a new bug.
(Reporter)

Comment 1

16 years ago
Additional information.

The amount that the mailbox pane resizes is related to the length of the email
address and "Real Name" that is displayed in the From field.

Also, clicking the triangle to show brief mail headers also resizes the mailbox
pane because the attachment box now turns in to a smaller icon.

Comment 2

16 years ago
WorksForMe using FizzillaCFM/2002091014 on 10.1.5. The size of the mailbox pane
was unaffected by the appearance of the attachments box.

Jim, what theme are you using? Does this happen using both Modern and Classic?

Comment 3

16 years ago
Happened to me too on Win2K until I manually resized the panes a bit.

Comment 4

16 years ago
Yes, happens with 9-16 commercial trunk. 
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: nsbeta1
QA Contact: olgam → laurel
I probably forgot to specify a default width.

I'll need to do it in the 3 pane js, so that if users don't have a width, we 
set it.

accepting.
Status: NEW → ASSIGNED
OS: MacOS X → All
Hardware: Macintosh → All
Target Milestone: --- → mozilla1.2beta
fix on the way.
fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 9

16 years ago
Comment on attachment 99478 [details] [diff] [review]
patch

Um, what was wrong with directly setting the width attribute on the box?

Comment 10

16 years ago
OK using nov1 commercial trunk: win98, linux rh6.2,mac os 10.2
Status: RESOLVED → VERIFIED

Comment 11

16 years ago
This is still being reported with newer builds, NT and Solaris:
bug 190820, bug 194713
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.