Message pane resizes inappropriately when header/attachment window combo too long for current message pane

VERIFIED DUPLICATE of bug 188138

Status

VERIFIED DUPLICATE of bug 188138
16 years ago
14 years ago

People

(Reporter: rcharbon, Assigned: sspitzer)

Tracking

({regression})

Trunk
x86
All
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030125
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.3b) Gecko/20030125

When the default Mail window layout is chosen (the left of the two available
from Preferences/Mail and Newsgroups/Windows, the one which uses the whole left
side of the window to list mail folders), the message pane resizes, growing if
the combination of the header and the attachment is too long to fit within the
current message pane, or shrinking if it's shorter. The message pane resizes at
the expense of the left hand folder pane.  

Reproducible: Always

Steps to Reproduce:
1. Have a list of messages in your folder, some with short recipients
(foo@bar.org), some with long (desktop-engineering-list - Desktop Plann
<desktop-engineering-list@lists.mitre.org>).  Some with attachments, some without.
2. Scroll through the messages in the list pane.  


Actual Results:  
The divider between the left-hand folder pane and the list and message panes
will jump back and forth, depending on the total width of the recipients name
and whether the attachment window is shown.

Expected Results:  
The divider should remain in place, leaving the sizes of the three panes alone.
 Having the panes resize is disconcerting.

Updated

16 years ago
Whiteboard: [dupeme]

Comment 1

16 years ago
I'm seeing this too.  Happens to me when there is a long "To:" list that is
separated by semicolons or commas, but no spaces (it will wrap if there are
spaces).  The panes freak out.  The columns in the header pane seemingly stretch
out to the virtual width of long header line, which for me usually only leaves
the sender and subject columns visible.  This is annoying because for me these
messages often tend to be spam that is sent to a long list of recipients, and I
can't click the junk column to mark the message as junk without having to
actually select it into the message pane.  I'm currently running build 2003020404.

Regards,

Ian

Comment 2

16 years ago
*** Bug 194713 has been marked as a duplicate of this bug. ***

Comment 3

16 years ago
*** Bug 194445 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
*** Bug 195195 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
The older instance i find is fixed, bug 168937
This seems to be a newer regression. Resolving as new for now, based on dups.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression

Comment 6

16 years ago
Three dupes include Linux & Solaris -> all
OS: Windows 2000 → All

Comment 7

16 years ago
*** Bug 168489 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
*** Bug 201999 has been marked as a duplicate of this bug. ***

Comment 9

16 years ago
I've marked bug 201999 as a dupe, and also of note is that I only use the
default skin (Classic?)

Comment 10

16 years ago
Is this a dupe of bug 188138?  Looks like it.

Comment 11

16 years ago
Duping due to [dupeme] keyword and confirmation from Felix in another bug.

Move your votes!

*** This bug has been marked as a duplicate of 188138 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 12

16 years ago
v dupe
Status: RESOLVED → VERIFIED

Comment 13

15 years ago
*** Bug 209076 has been marked as a duplicate of this bug. ***
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.