Closed Bug 1692083 Opened 2 months ago Closed 2 months ago

"helpSafeMode" button in app menu is not updated when in safe mode

Categories

(Firefox :: General, defect)

defect

Tracking

()

VERIFIED FIXED
Tracking Status
firefox86 + verified
firefox87 --- unaffected

People

(Reporter: emalysz, Assigned: emalysz)

References

(Regression)

Details

Attachments

(1 file)

We also will need to update the app menu's string here: https://searchfox.org/mozilla-beta/source/browser/base/content/browser.js#1948-1951

This only affects beta right now, as another patch had landed to remove this button.

The string being referenced in this patch is thankfully already available: https://searchfox.org/mozilla-beta/rev/31b356aa5ed840f59796f7aedcb8dc24cb12e962/browser/locales/en-US/browser/appmenu.ftl#130-132, so we don't need a new string here.

[Tracking Requested - why for this release]:

Users will see "Restart With Add-ons Disabled…" in the AppMenu "Help" subview even when Safe Mode is engaged, which might be confusing for users trying to debug an issue.

Comment on attachment 9202454 [details]
Bug 1692083, update the helpsafemode string in the app menu

Beta/Release Uplift Approval Request

  • User impact if declined: The help menu string will incorrectly remain the same in safe mode (Restart with Add-ons disabled), whereas it should be updated to "Restart with add-ons enabled".

The top menu string currently behaves correctly, and we need to match this.

  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Nightly is not affected, since the element was removed. This is why there is a patch on the beta branch.
  • String changes made/needed: n/a
Attachment #9202454 - Flags: approval-mozilla-beta?
Attachment #9202454 - Flags: approval-mozilla-beta?

Comment on attachment 9202454 [details]
Bug 1692083, update the helpsafemode string in the app menu

Beta/Release Uplift Approval Request

  • User impact if declined: The help menu string will incorrectly remain the same in safe mode (Restart with Add-ons disabled), whereas it should be updated to "Restart with add-ons enabled". The menu panel's string currently behaves correctly, and we need to match this.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: Yes
  • If yes, steps to reproduce: 1. Open a current beta version of Firefox
  1. Navigate to the app menu --> Help
  2. Notice string: "Restart with add-ons disabled..."
  3. Click button to restart in safe mode.
  4. Navigate to the app menu --> Help (in safe mode)
  5. Notice string has been updated to: "Restart with Enabled"
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): The strings are already available, so we won't be introducing any new strings. Nightly is not affected, since the element was removed. This is why there is a patch on the beta branch.
  • String changes made/needed: n/a
Attachment #9202454 - Flags: approval-mozilla-beta?
Flags: qe-verify+

Comment on attachment 9202454 [details]
Bug 1692083, update the helpsafemode string in the app menu

Low risk, approved for our last beta, thanks.

Attachment #9202454 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
QA Whiteboard: [qa-triaged]

I managed to reproduce the issue using Firefox 86.0b8 on Windows 10 x64.
I retested everything using the steps from comment 5 on Firefox 86.0b9 on Windows 10 x64, Ubuntu 18.04 x64 and macOS 10.13. The issue is not reproducing anymore. The string is updated to "Restart with Enabled".

But I see that the status of the bug is still NEW, will this bug need further patches of uplifts or can the status be changed to Resolved Fixed?

Flags: needinfo?(emalysz)

No additional uplifts are required, marking as Resolved Fixed

Status: NEW → RESOLVED
Closed: 2 months ago
Flags: needinfo?(emalysz)
Resolution: --- → FIXED

Thank you for your response. According to comment 8 and comment 9 I will mark this bug as verified fixed.

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.