Closed Bug 1692668 Opened 10 months ago Closed 9 months ago

[Proton] Update bookmarks context menu for clarity

Categories

(Firefox :: Bookmarks & History, enhancement, P1)

Desktop
All
enhancement

Tracking

()

VERIFIED FIXED
88 Branch
Tracking Status
firefox88 --- disabled
firefox89 --- verified

People

(Reporter: Gijs, Assigned: ewright)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-context-menus])

Attachments

(1 file)

Specific changes:

  • Change "Open All in Tabs" to "Open All Bookmarks"

  • Change "New Bookmark/Separator/Folder..." to "Add Bookmark/Separator/Folder..."

  • Add "Manage Bookmarks..." item at the bottom of the menu. This should open the library.

  • Change the order of the bookmarks toolbar visibility submenu (might happen in bug 1690575)

  • Change "Properties" to "Edit Bookmark..." and "Delete" to "Remove Bookmark", and put them in one group immediately after the separator following the "Open In ..." context menu items.

  • Keep "Paste" where it is on the empty bookmarks toolbar, but move the Cut/Copy/Paste group before "Add Bookmark/Separator/Folder" when opening the context menu on an existing item (after the group for edit/remove bookmark)

Type: defect → enhancement
Assignee: nobody → ewright
Status: NEW → ASSIGNED

As per guidance from Vicky, for tracking, we're marking all the bugs that people are working on as P1.

Priority: P3 → P1
Pushed by lando_landing_worker@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b3df95f06470
Update bookmarks context menu for clarity. r=Gijs,fluent-reviewers,flod
Pushed by ewright@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/9a043bb287a5
Update bookmarks context menu for clarity. r=Gijs,fluent-reviewers,flod
Flags: needinfo?(ewright)
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

Verified that the changes mentioned in comment 0 are indeed reflected in Latest Nightly 88.0a1 across platforms (Windows 10, macOS 11.3 and Ubuntu 18.04) and their functionality is not affected. Removing firefox87 flag since this was targeted for Firefox 88.

Status: RESOLVED → VERIFIED
Regressions: 1700929
Regressions: 1701474

We've backed this out of beta to fix the 2 regressions filed about it.

See Also: → 1727606
You need to log in before you can comment on or make changes to this bug.