Closed Bug 1693276 Opened 3 years ago Closed 3 years ago

Add proton styles for in-content buttons

Categories

(Toolkit :: Themes, task)

Desktop
All
task

Tracking

()

RESOLVED FIXED
88 Branch
Tracking Status
firefox88 --- fixed

People

(Reporter: Gijs, Assigned: Gijs)

References

(Blocks 1 open bug, Regressed 1 open bug)

Details

(Whiteboard: [proton-foundations])

Attachments

(1 file)

See specs in the "Basic-Components" figma.

Padding should be 6/7/8px vertically for small/medium/large buttons, with horizontal padding double that.

4px border radius everywhere.

Colours are settled for light theme, not for dark theme.

Blocks: 1693277
Depends on: 1693282

I presume making these styles shared with toolbarbutton's in the browser chrome is out of scope for this bug?

(In reply to Mike Conley (:mconley) (:⚙️) (Catching up on needinfos) from comment #2)

I presume making these styles shared with toolbarbutton's in the browser chrome is out of scope for this bug?

I wasn't planning on trying to address that in this bug, no - sorry. I'll try to update for ntim's suggestions ASAP and then you could try building off of this patch - does that work for you?

Flags: needinfo?(mconley)

Most definitely.

Flags: needinfo?(mconley)
Summary: Add proton styles for buttons → Add proton styles for in-content buttons
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/1a95ba3c4f1b
update button styles for proton r=desktop-theme-reviewers,ntim
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch
Regressions: 1694427

The patch landed in nightly and beta is affected.
:Gijs, is this bug important enough to require an uplift?
If not please set status_beta to wontfix.
If yes, don't forget to request an uplift for the patches in the regression caused by this fix.

For more information, please visit auto_nag documentation.

Flags: needinfo?(gijskruitbosch+bugs)
Flags: needinfo?(gijskruitbosch+bugs)
Type: defect → task
Depends on: 1698349
Blocks: 1698355
Blocks: 1698356
Depends on: 1699439
Regressions: 1831299
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: