Closed Bug 1695383 Opened 9 months ago Closed 9 months ago

[Proton] Downloads panel context menu item actions have no effect (clicking them does nothing)

Categories

(Firefox :: File Handling, defect, P1)

Firefox 88
Desktop
Windows 10
defect

Tracking

()

VERIFIED FIXED
88 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox86 --- unaffected
firefox87 --- disabled
firefox88 --- verified

People

(Reporter: h23ggxb2, Assigned: Gijs)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression, Whiteboard: [proton-context-menus])

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:88.0) Gecko/20100101 Firefox/88.0

Steps to reproduce:

1.Open Firefox Nighty
2.Download Anything from web
3.open download button from toolbar
4. right click and choose copy download link

Actual results:

Nothing is copied

Expected results:

The file download link must be copied

The Bugbug bot thinks this bug should belong to the 'Firefox::File Handling' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → File Handling

Hi Fros

I tried to replicate this on windows10 64 bit and also on Ubuntu 20 64 bit with latest Firefox nightly version 88.0a1

for example on windows i went to this site: https://www.winzip.com/win/en/landing/prodpagewz.html?gclid=EAIaIQobChMI8viove2P7wIVytSzCh3Ymw1eEAAYASAAEgJU5PD_BwE

downloaded winzip, and clicked the download button on the toolbar, right click and copy download link and this is what got copied:
copied https://download.winzip.com/gl/gad/winzip25.exe

Is there any specific link you ca provide that does not work?
can you test again with the latest version of firefox? and with a new profile?

thanks.

Flags: needinfo?(h23ggxb2)

(In reply to Pablo from comment #2)

Hi Fros

I tried to replicate this on windows10 64 bit and also on Ubuntu 20 64 bit with latest Firefox nightly version 88.0a1

for example on windows i went to this site: https://www.winzip.com/win/en/landing/prodpagewz.html?gclid=EAIaIQobChMI8viove2P7wIVytSzCh3Ymw1eEAAYASAAEgJU5PD_BwE

downloaded winzip, and clicked the download button on the toolbar, right click and copy download link and this is what got copied:
copied https://download.winzip.com/gl/gad/winzip25.exe

Is there any specific link you ca provide that does not work?
can you test again with the latest version of firefox? and with a new profile?

thanks.

Hi Pablo,
My Specs-
Browser - firefox nighty 88.0.a1
Updated - (2021-03-01)
OS- windows 10 64 bit
Here what i found after recreating new profile and tested you winzip link.I enabled the proton in previous one and suspected that browser.proton.contextmenus.enabled cause this problem.
Anyway To reproduce issue:
Before do anything above follow below steps:
1.type about:config in urlbar
2.agree warning then type and enable the below commands:
---->browser.proton.contextmenus.enabled
---->proton
---->browser.proton.enabled
3. If step 2 failed In my browser these configs are also enabled so you can try if above contextmenu.enabled not work
---->browser.proton.appmenu.enabled
---->browser.proton.tabs.enabled
---->browser.proton.toolbar.version
---->browser.proton.urlbar.enabled

3.Now repeat all steps above to recreate situation.

Flags: needinfo?(h23ggxb2)

I was able to replicate the issue with Windows10 64bit. (It works fine on MacOs10.15 and Ubuntu 20 64.bit)
Reproduceed on Firefox beta 87.0b5 and Firefox nightly 88.0a1

  1. created a user.js with
    user_pref("browser.proton.contextmenus.enabled", true);
    user_pref("browser.proton.enabled", true);

  2. Downloaded any file like this program https://www.winzip.com/win/en/landing/prodpagewz.html?gclid=EAIaIQobChMI8viove2P7wIVytSzCh3Ymw1eEAAYASAAEgJU5PD_BwE

  3. opened the download menu, right click and copied download link.

the .exe link did not get copied.

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → Windows 10
Hardware: Unspecified → Desktop

This is broken because the downloads panel keeps track of selection based on mouse hover state, and the new context menu's big box shadow area is eating mouse events, which means that when the context menu opens, the hovered item in the downloads panel is no longer hovered, which means it is no longer selected, which means that when executing any of the commands in the menu, they don't work because the downloads panel does not know which item is selected.

Fixing bug 1692084 would likely fix this. We could also fix it orthogonally by changing the downloads view to "fixate" selection on the context menu'd item when opening the context menu, and then "release" the selection back to the mouse hover / keyboard behaviour when the context menu closes. In fact, this last thing is already what the code is trying to do, but it's not working -- Marco and me aren't sure off-hand precisely why the selection is being lost...

Severity: -- → S2
Depends on: 1692084
Priority: -- → P1
Regressed by: 1682522
See Also: → 1686694
Summary: Download Links are not copied from toolbar → [Proton] Downloads panel context menu is almost completely broken
Whiteboard: [proton-context-menus]
Keywords: helpwanted
Keywords: helpwanted
See Also: → 1697916
Summary: [Proton] Downloads panel context menu is almost completely broken → [Proton] Downloads panel context menu item actions have no effect (clicking them does nothing)
Depends on: 1699427
Duplicate of this bug: 1699659

Fixed by bug 1699427.

Assignee: nobody → gijskruitbosch+bugs
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

Reproduced the initial issue using old Nightly from 2021-02-26, verified that all labels from download context menus work as expected in latest Nightly 88.0a1.

Status: RESOLVED → VERIFIED
See Also: → 1707204
You need to log in before you can comment on or make changes to this bug.