Closed Bug 1695671 Opened 7 months ago Closed 6 months ago

Update strings for the global menubar

Categories

(Firefox :: Menus, task, P3)

task

Tracking

()

RESOLVED FIXED
88 Branch
Tracking Status
firefox88 --- fixed

People

(Reporter: mconley, Assigned: gregtatum)

References

(Blocks 1 open bug)

Details

(Keywords: helpwanted, Whiteboard: [proton-hamburger-menu])

Attachments

(1 file)

I believe most of these strings are found in https://searchfox.org/mozilla-central/rev/644e42ded761d4f3ce108fa776197730a9a2c535/browser/locales/en-US/browser/menubar.ftl.

  • "Find in This Page" should become "Find in Page"
  • "Add-ons" should become "Extensions and Themes"
  • "Sign-in to {brand short name}" should become "Sign in"
  • "Options/Preferences" should become "Settings" (we are intentionally converging to "Settings" on all platforms)
  • "Customize…" should become "Customize Toolbar…"
  • The View > Toolbars > Bookmarks Toolbar items should become "Always", "Only on New Tab", "Never"
  • "Restore All Tabs" should become "Reopen All Tabs"
  • "Restore All Windows" should become "Reopen All Windows"
  • "Bookmark This Page" should become "Bookmark Current Tab"
Keywords: helpwanted

(In reply to Mike Conley (:mconley) (:⚙️) (Catching up on needinfos) from comment #0)

  • The View > Toolbars > Bookmarks Toolbar items should become "Always", "Only on New Tab", "Never"

The context menu spec had "Always Show" and "Never Show" here, and the ordering change has already been executed, so I'd leave this alone unless we get confirmation from UX that the labeling change there was intentional.

I reviewed labels again based on decisions in app menu and the more recent updates to context menus. What Mike listed is all accurate with the exception of a few small things (which present no change from what has been implemented for context menus). I bolded the updates:

"Find in This Page" should become "Find in Page..."
"Add-ons" should become "Extensions and Themes"
"Sign-in to {brand short name}" should become "Sign in"
"Options/Preferences" should become "Settings" (we are intentionally converging to "Settings" on all platforms)
"Customize…" should become "Customize Toolbar…"
The View > Toolbars > Bookmarks Toolbar items should become "Always Show", "Only Show on New Tab", "Never Show"
"Restore All Tabs" should become "Reopen All Tabs"
"Restore All Windows" should become "Reopen All Windows"
"Bookmark This Page" should become "Bookmark Current Tab"
"Mozilla Firefox > Help & Tutorials" should become "Mozilla Firefox > Get Help" to be consistent with application menu label

(In reply to Meridel from comment #2)

"Mozilla Firefox > Help & Tutorials" should become "Mozilla Firefox > Get Help" to be consistent with application menu label

Note that this is one of the default bookmarks. We can update this for new users, I think, at https://searchfox.org/mozilla-central/rev/c24ecdc6f5025ea7e60d0691673de030bd5bf411/browser/locales/en-US/profile/bookmarks.inc#26 . I'm not sure we can reliably update this for existing users (it might have been moved or renamed or the URL may have been changed or ...). I'm assuming that that is OK.

Priority: P5 → P3
Severity: -- → N/A
Assignee: nobody → gtatum
Pushed by gtatum@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/79e9fa618141
Update strings in the global menubar r=Gijs,flod
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch
Regressions: 1697082

(In reply to Mike Conley (:mconley) (:⚙️) (Catching up on needinfos) from comment #0)

I believe most of these strings are found in https://searchfox.org/mozilla-central/rev/644e42ded761d4f3ce108fa776197730a9a2c535/browser/locales/en-US/browser/menubar.ftl.

  • "Options/Preferences" should become "Settings" (we are intentionally converging to "Settings" on all platforms)

This looks really bad - other cross platform software doesn't do this - see Chrome and Edge, or Opera, or Microsoft Word. Not even smaller open source apps like Joplin or Signal Desktop. Why is Firefox special in this regard? I would argue that it isn't, and that a little platform smarts go a long way for an app to feel like it belongs on the platform.

No longer regressions: 1697082
Duplicate of this bug: 1697082
Regressions: 1698379
Regressions: 1698550
Depends on: 1698577

I don't see why we couldn't change the label (In reply to :Gijs (he/him) from comment #3)

(In reply to Meridel from comment #2)

"Mozilla Firefox > Help & Tutorials" should become "Mozilla Firefox > Get Help" to be consistent with application menu label

Note that this is one of the default bookmarks. We can update this for new users, I think, at https://searchfox.org/mozilla-central/rev/c24ecdc6f5025ea7e60d0691673de030bd5bf411/browser/locales/en-US/profile/bookmarks.inc#26 . I'm not sure we can reliably update this for existing users (it might have been moved or renamed or the URL may have been changed or ...). I'm assuming that that is OK.

I don't see why the label change would be a problem in this context. The fact that it is a default bookmark that Firefox generates should just be more reason for us to have a consistent label with the Firefox-generated application menu. Ideally we would update for all users but if this is more work for ENG, having the update for new users is good.

"Customize…" should become "Customize Toolbar…"

FWIW, I find this change weird. First because about:customize has more knobs than just for the toolbar, and secondly because the item appears in the tabbar context-menu.

Emma and I discussed options for placement of the Task Manager item within the menubar. Since the information architecture is different from application menu to menubar, this is the best solution for consistency:

Task Manager should appear beneath "Tools" in the menubar, in this order:

Tools
Downloads
Extensions & Themes
Sync Now

Web Developer
Task Manager
Page Info

Mike, please let me know if have concerns or questions.

Flags: needinfo?(mconley)

To note, I am not sure why funky bold large formatting is showing up in my comment. =/

After additional discussion of options here, the plan has changed. Option A will be more consistent with the app menu information architecture and less work for ENG: https://docs.google.com/presentation/d/1Ufd0A3HsziyXXAjXYNH84P2bu7RdTxARsA0xpKmwIWs/edit#slide=id.gc84e86edce_5_15

Tools
Downloads
Extensions & Themes
Sync Now

Browser Tools>
Page Info

Browser Tools Submenu >
Web Developer Tools
Task Manager
Remote Debugging
Browser Console
Responsive Design Mode
Eyedropper
Page Source
Extensions for Developers

Romain, please review and sign off, thank you.

Flags: needinfo?(rtestard)

No concerns. This work is occurring in bug 1691140.

Flags: needinfo?(mconley)

Apologies for delay, missed this one, ok with me

Flags: needinfo?(rtestard)
You need to log in before you can comment on or make changes to this bug.