Closed Bug 1695923 Opened 7 months ago Closed 7 months ago

Unchecked 'Spellcheck As You Type' turns back on when saving message as draft

Categories

(Thunderbird :: Message Compose Window, defect)

Thunderbird 87
defect

Tracking

(thunderbird_esr78 unaffected, thunderbird87 wontfix)

VERIFIED FIXED
88 Branch
Tracking Status
thunderbird_esr78 --- unaffected
thunderbird87 --- wontfix

People

(Reporter: paully.littlefield, Assigned: darktrojan)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/88.0.4324.182 Safari/537.36

Steps to reproduce:

Have 'Spell check as you type' unticked and turned off in Preferences and the Compose Window options.

Actual results:

When you save the unsent message, 'Spell check as you type' turns back on.

Expected results:

When you save a message, 'Spell check as you type' should be kept off.

That's right Paul, TB should respect your decision to turn inline spellcheck OFF (e.g. for multi-lingual texts which we don't handle well).

Confirming for 88.0a1 (2021-03-01) (64-bit).

Maybe Geoff has ideas after fixing the other spellcheck issue.

Severity: -- → S4
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Spell Check As You Type turns back on Save in Compose Window → Unchecked 'Spellcheck As You Type' turns back on when saving message as draft

Weirdly this seems to be caused by the copying of the message into the drafts folder. I've no idea how that could cause spell checking to be enabled, so I'm starting to wonder if the copy operation causes the message to be reloaded and that somehow enables spell checking.

It is. The problem's in updateEditableFields (via ToggleWindowLock and stateListener.ComposeProcessDone). Setting flags on the editor causes the spell checker to become enabled (even if you add the skip spell check flag!).

Assignee: nobody → geoff
Status: NEW → ASSIGNED

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/3b1645fde19a
Avoid spell checker becoming enabled when a draft is saved. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

Awesome, thanks Geoff!

Status: RESOLVED → VERIFIED
Regressions: 1718492
You need to log in before you can comment on or make changes to this bug.