Closed Bug 1697349 Opened 8 months ago Closed 7 months ago

[css-flexbox] Include flex item's margins and flex container's padding in the flex container's overflow area

Categories

(Core :: Layout: Flexbox, enhancement)

enhancement

Tracking

()

RESOLVED FIXED
89 Branch
Tracking Status
firefox88 --- wontfix
firefox89 --- fixed

People

(Reporter: TYLin, Assigned: TYLin)

References

(Regressed 1 open bug)

Details

Attachments

(1 file, 1 obsolete file)

+++ This bug was initially created as a clone of Bug #1527539 +++

I'd like to explore the implementation of flexbox in this bug, and the original bug 1527539 for grid.

We have existing tests overflow-area-001.html and overflow-area-002.html added by fantasai in https://github.com/web-platform-tests/wpt/pull/23445

Depends on: 1697325

This patch incorporates flex item's margin and flex container's padding
when computing flex container's overflow area in both the inline axis
and block axis.

flexbox_stf-table-singleline-2.html and overflow-top-left.html start
failing because both tests have flex items with margin contributing to
the overflow area now. I believe they test other browsers current
behavior, so I leave them untouched.

Depends on D107935

Assignee: nobody → aethanyc
Status: NEW → ASSIGNED
Attachment #9208259 - Attachment description: Bug 1697349 Part 1 - Add two simple helper methods used in the next part. → Bug 1697349 Part 1 - Add some helper methods used in the next part.
Blocks: 1698428

Blink fixed their version of this bug in https://bugs.chromium.org/p/chromium/issues/detail?id=1069614, and is targeting M91 released on May 25, 2021. We are approaching soft freeze for 88, and our time frame for 89 (released on May 18, 20201) is similar to blink's M91. So let's land my patches after 89 cycle begins next week. NI myself as a reminder.

Depends on: 1699327

Comment on attachment 9208259 [details]
Bug 1697349 Part 1 - Add some helper methods used in the next part.

Revision D107935 was moved to bug 1699327. Setting attachment 9208259 [details] to obsolete.

Attachment #9208259 - Attachment is obsolete: true
Attachment #9208260 - Attachment description: Bug 1697349 Part 2 - Incorporate flex item's margin and flex container's padding when computing flex container's overflow area. → Bug 1697349 - Incorporate flex item's margin and flex container's padding when computing flex container's overflow area.
Pushed by aethanyc@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/94323c03b3da
Incorporate flex item's margin and flex container's padding when computing flex container's overflow area. r=dholbert
Created web-platform-tests PR https://github.com/web-platform-tests/wpt/pull/28175 for changes under testing/web-platform/tests
Flags: needinfo?(aethanyc)
See Also: → 748518
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch
Upstream PR merged by moz-wptsync-bot
Flags: in-testsuite+
Duplicate of this bug: 1563485
Regressions: 1712496
Regressions: 1712875
Regressions: 1712904
You need to log in before you can comment on or make changes to this bug.