Closed Bug 1697806 Opened 9 months ago Closed 4 months ago

De-duplicate colored extension SVG icons

Categories

(Toolkit :: Themes, task, P3)

task

Tracking

()

RESOLVED DUPLICATE of bug 1708008
88 Branch
Tracking Status
firefox88 --- affected

People

(Reporter: ntim, Assigned: ntim)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-icons] [proton-cleanups])

Attachments

(1 file)

browser/components/extensions/extension.svg
toolkit/themes/shared/extensions/extensionGeneric.svg

are the same, but at different sizes.

Assignee: nobody → ntim.bugs
Status: NEW → ASSIGNED

Hey Rob, would you mind to pick up the review for the attached patch?

(I kind of recall this and so I have the feeling that we may have another duplicate of this issue, I have the feeling it may have been a good first bug that was never completed, but I haven't checked and so I may be wrong about the duplicate, but if you find it let's close it as a duplicate of this one)

Flags: needinfo?(rob)
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/18909220355a
De-duplicate colored extension SVG icons. r=robwu

1421039(In reply to Luca Greco [:rpl] [:luca] [:lgreco] from comment #2)

(I kind of recall this and so I have the feeling that we may have another duplicate of this issue, I have the feeling it may have been a good first bug that was never completed, but I haven't checked and so I may be wrong about the duplicate, but if you find it let's close it as a duplicate of this one)

I think that you're thinking of bug 1421039

Flags: needinfo?(rob)
See Also: → 1421039
Status: ASSIGNED → RESOLVED
Closed: 9 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

The icon for a few custom extension I have (no icon included) just changed from green to gray, is that intended?

Flags: needinfo?(ntim.bugs)

(In reply to Justin Peter from comment #6)

The icon for a few custom extension I have (no icon included) just changed from green to gray, is that intended?

Nope, definitely not, could you please file a bug with some steps to reproduce/screenshot? Thanks!

Flags: needinfo?(ntim.bugs) → needinfo?(1justinpeter)

Alright, see bug 1698237.

Flags: needinfo?(1justinpeter)
Regressions: 1698237

This is getting backed out because of bug 1698237 comment 4:
https://hg.mozilla.org/integration/autoland/rev/c3fdb26099a3

Rob, what do you think of this?

Probably easiest path is to remove the unpackaged colored extensionGeneric.svg in toolkit and (optionally) rename the browser extension.svg file to extension-colored.svg.

This is how categories-extensions.svg is packaged twice btw: https://searchfox.org/mozilla-central/rev/897104d3f309f1901190bcc8be87437ca3dab630/toolkit/themes/shared/mozapps.inc.mn#11,29

Would you mind taking this if you have time? I'm not sure what the expected end result regarding icons is (where to use the colored one, the monochrome category one, or the 16x16 extension one), it'd be faster if someone from your side takes this IMO.

Status: RESOLVED → REOPENED
Flags: needinfo?(rob)
Resolution: FIXED → ---
Assignee: ntim.bugs → nobody

Obviously it's not my call, but I will note that the green icon did generally look a bit out-of-place in the UI. (I suppose the point is that any change be intentional, though.)

Whiteboard: [proton-foundations]
Priority: -- → P3
Whiteboard: [proton-foundations] → [proton-icons] [proton-cleanups]

An almost identical patch landed in bug 1708008.

The icon is still not green, but that has been deemed acceptable by the extension team. We mostly care that the icon looks different from the "Extensions" tab icon at about:addons (a hollow puzzle piece), which is the case (the default extension icon is a filled grey puzzle piece).

Status: REOPENED → RESOLVED
Closed: 9 months ago4 months ago
Flags: needinfo?(rob)
Resolution: --- → DUPLICATE
Duplicate of bug: 1708008
Assignee: nobody → ntim.bugs
You need to log in before you can comment on or make changes to this bug.