Closed Bug 1708008 Opened 7 months ago Closed 5 months ago

De-duplicate extensions icons

Categories

(Toolkit :: Add-ons Manager, task, P3)

task
Points:
1

Tracking

()

VERIFIED FIXED
92 Branch
Tracking Status
firefox92 --- verified

People

(Reporter: mconley, Assigned: sfoster)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-cleanups][proton-icons] [priority:2b])

Attachments

(2 files, 1 obsolete file)

Bug 1706415 introduced some new Proton-y icons, and the following extension-related icons were identified as duplicates:

  • chrome/toolkit/skin/classic/mozapps/extensions/extension.svg
  • chrome/toolkit/skin/classic/mozapps/extensions/extensionGeneric.svg

We should de-duplicate them.

Priority: -- → P2
Whiteboard: [proton-cleanups][proton-icons] → [proton-cleanups][proton-icons] [priority:2b]
Priority: P2 → P3
Depends on: 1707950

in Bug 1707950 I'm making extension.svg the hollow icon, since it should have been from the beginning. extensionGeneric.svg will keep being the filled icon

Just dropping some notes here and info from other bugs...

It's not clear right off what icons are used for what ui, and well there are the dups. IIUC the direction is to use outlines for the icons where the functionality is ours (Firefox) and filled in icons where it belongs to an addon and is a fallback or generic for whatever reason.

all the icons: https://searchfox.org/mozilla-central/search?q=extension%5Cw*%5C.svg&path=&case=false&regexp=true
a nice visual: https://docs.google.com/spreadsheets/d/1hazjiPGC7tam6rZ4OInRrFjwdgdVPbXdihwxcPlfM1M/edit#gid=0

There are 4 icons currently, I suspect duplicated for some random reason, it would be great to reduce this to two icons to help make their use clear.

Attached file extension-dot-svg-uses (obsolete) —
I compiled a rough list based on Shane's query above. Some of them may be off – this list is just based on me trying to follow functions through Searchfox to figure out the icon's context. I included sizes when I knew them offhand or it was obvious from the CSS.

The line numbers here are current as of revision 92be70819506d269df7c192bfbddc8c6ce581990.

Whoops, I posted the other file too soon.

Attachment #9219625 - Attachment is obsolete: true
Severity: -- → N/A

Some details from other bugs related to the extension icons that may be worth considering while looking into this one:

  • Bug 1697806 was aiming to also deduplicate extension svg icons, it has a patch attached and signed-off, but unfortunately it has been backed out because it was regressing (see Bug 1697806 comment 9, and/or Bug 1698237 comment 4)
  • As part of Bug 1709655 we have updated the extensions category sidebar icon in about:addons (which was supposed to be 20x20 outlined one but it was the 16x16 filled one instead) and to do that we had to remove on remapping that was being done from toolkit/themes/shared/mozapps.inc.mn (See D114884)

While updating allow-dupes.mn for D114884 I briefly double-checked if any of the entries related to the extension.svg, extensionGeneric.svg etc. listed in allow-dupes.mn were not detected as dupes anymore and (quoting from D114884 comment):

it seems that if I remove chrome/toolkit/skin/classic/mozapps/extensions/extension.svg the mach package comment is still happy.

extensionGeneric.svg instead has still to be listed in the allow-dupes.

I think that it is a bit confusing that browser/chrome/browser/content/browser/extension.svg
and chrome/toolkit/skin/classic/mozapps/extensions/extension.svg are not the same icon (the first one is filled, the second one is outlined), but I think that I would leave that to a separate bug.

In the end I decided to don't remove chrome/toolkit/skin/classic/mozapps/extensions/extension.svg from allow-dupes.mn in Bug 1709655 and leave it for this issue instead, so that along with deduplicating them we can also evaluate if some of those svg files should be renamed to make it easier to recognize how they differ from each other and/or what role they should have in the UI.

Points: --- → 1
Assignee: nobody → sfoster
Status: NEW → ASSIGNED

Looks like a lot of this work was already done, with the correct hollow icon being used everywhere it should be. I worked through all of instances from comment 2, and they were all already done.
I've got a patch that removes chrome://browser/content/extension.svg and points references to it to chrome://mozapps/skin/extensions/extension.svg, and ensures the default icon for extension is always chrome://mozapps/skin/extensions/extensionGeneric.svg. I'll push for review.

Pushed by sfoster@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0c7fb4e78d1c
Remove browser's extension icon, always use extensionGeneric as default extension icon. r=mixedpuppy
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch
Duplicate of this bug: 1697806

Verified in latest nightly build 92.0a1 (2021-07-30) (64-bit)
Extensions icon is hollow (correct hollow icon being used everywhere it should be, including about:addons, on the bookmark bar, in the title bar, in the side bar, in the URL etc)
I'm updating flags accordingly.
Best,
Clara

Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.