Closed Bug 169816 Opened 18 years ago Closed 15 years ago

ability to sort bookmarks

Categories

(Camino Graveyard :: Bookmarks, defect, P3)

PowerPC
macOS
defect

Tracking

(Not tracked)

VERIFIED FIXED
Camino1.5

People

(Reporter: bugzilla, Assigned: sfraser_bugs)

References

Details

(Keywords: fixed1.8.0.1, fixed1.8.1)

saw this on the chimera mozdev newsgroup: would it be possible to implment
sorting of bookmarks? say, within the bookmark sidebar.
What do you specifically? Do you want to sort the bookmarks by using the columns?

Anayway, we haven't got a sidebar anymore, wont't fix?
Is bug 227363 a dup of this bug?
*** Bug 227363 has been marked as a duplicate of this bug. ***
Assignee: sfraser → pinkerton
Target Milestone: --- → Camino0.9
What exacty is meant by "sorting bookmarks"? I can't come up with a way in which
that makes sense. Seems like searching would be the right thing to do in any
case where you might want to "sort" bookmarks... Bookmark, as they are displayed
in the bm manager, reflect their menu organization. Displaying them another way
would get awfully complicated when moving them around in the bm manager, and
probably be profoundly confusing. I think we should WONTFIX this bug, and I'll
do that a week from now if there aren't any good objects posted to the bug by then.
Assignee: pinkerton → joshmoz
Target Milestone: Camino0.9 → Future
Sorting the entries name or url alphabetically really seems useless to me
aswell. Why would you want to do that? And I agree that allowing sorting and
also allowing re-arranging can become very trouble some.
On the contrary. It is extremely useful. When I click on my Stock Photo bookmark folder (which 
most entries do not have favicons) i don't want to have to search through all my entries to find 
Corbis. I should just have to scroll a little ways down to the Cs to find it easily. Currently, its a 
process of exporting Camino bookmarks to Safari, using Safari Sorter and then using Safari 
Bookmark Exporter to get my alphabetized bookmarks back to Camino. Its a pain. It's quicker 
using sorted bookmarks than it is to to search through the bookmark manager. Maybe if you could 
keep bookmarks in a tab searching would be more useful.
we get this request often on camino-feedback. i think if we can do what safari
does we're ok. yeah, it might be hard, but it's prolly worth the pain. Maybe for
1.0?
*** Bug 296591 has been marked as a duplicate of this bug. ***
I wish camino would sort bookmarks for me; once in a while I try to click the
table view headers to see if it can be done.

For me it's not primarily important for sorting my bookmarks -- rather it's to
sort my bookmark folders (yes I have lots of these, and some of them contain
lots of them too)

Therefore, I request another feature: Give us the preference to sort folders
before bookmarks when sorting.
I'll work on this.
Assignee: joshmoz → sfraser_bugs
Severity: enhancement → normal
Status: NEW → ASSIGNED
Priority: -- → P3
Target Milestone: Future → Camino1.0
Simon, any work on this and if so, enough for 1.0 or should we push this?
Not gonna happen for 1.0
Target Milestone: Camino1.0 → Camino1.1
Done. The bookmarks sort button now has Arrange items, and they are also on the context menu. The behavior is as follows:

1. If no items are selected, all the top-level items in the current collection will be sorted (not deep).
2. If you select more than one item in a collection or folder, the selected items will be arranged (and brought together if the selection is discontiguous).
3. If you select a single folder, its children will be sorted (not deep).
4. If you hold down the option key in any of the above cases, the sort becomes deep.
5. If you select items which do no share a common parent, nothing happens.
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.