Java applet incorrectly positioned when scrolling

VERIFIED DUPLICATE of bug 162134

Status

()

Core
Plug-ins
P2
normal
VERIFIED DUPLICATE of bug 162134
16 years ago
14 years ago

People

(Reporter: Ari, Assigned: Peter Lubczynski)

Tracking

Trunk
Future
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
When the main news page is loaded, the applet appears in the correct position,
but when the page is scrolled, instead of being scrolled out of view, the applet
stays at the top of the scrolled view and covers page content. This causes major
painting problems.

This problem appears to be specific to Mac OS X because I know that it doesn't
occur on Linux and I don't think it occurs on Windows either. I don't think that
it is a recent regression because it occurs in both the latest mozilla trunk
builds and in Chimera. I don't have much of an idea about where the problem is,
but I don't think it's just a gfx problem because the applet continues to update
its content and repaint itself in its incorrect location. I don't think it's an
OS bug either because the applet works fine on IE.
(Reporter)

Comment 1

16 years ago
Created attachment 99993 [details]
screenshot showing problem

Comment 2

16 years ago
ajfeldman@brown.edu, what build ID are you reporting this bug against?
(Reporter)

Comment 3

16 years ago
It's in Build ID: 2002091908, but it's been in builds as far back as I can
remember. It's also in Chimera 0.5 which I think is based on mozilla 1.0.1.

Comment 4

16 years ago
Confirmed using FizzillaCFM/2002091014 on 10.1.5. I wonder if there's a dup to
be found. To Plug-ins or OJI?
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Priority: -- → P2
-> Plugins
Component: Layout → Plug-ins

Updated

16 years ago
Target Milestone: --- → Future

Comment 6

16 years ago
*** Bug 173297 has been marked as a duplicate of this bug. ***

Comment 7

16 years ago
Dup of bug 72391?

Comment 8

16 years ago
Let's assign this to someone who still works here...
Assignee: attinasi → beppe
QA Contact: petersen → shrir

Comment 9

16 years ago
welcome, petersen (new oji qa)
QA Contact: shrir → petersen

Comment 10

16 years ago
Chris: can you verify this one?

Comment 11

16 years ago
Yes, this is a problem on both OS X 10.2.1 and 10.1.5 when scrolling the page.
Resizing the page under 10.2.1 will cause applet to reposition over the
application's toolbar. Tested with 2002-10-17-08 trunk.

Comment 12

16 years ago
Chris: does this happen with any object (img, plug-in) or does it happen only
with applet?

Comment 13

16 years ago
reassign
Assignee: beppe → peterl

Comment 14

16 years ago
Seems fixed in 2002122004

Comment 15

16 years ago
*** Bug 193216 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago

*** This bug has been marked as a duplicate of 162134 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.