Closed Bug 1699506 Opened 10 months ago Closed 10 months ago

Add fullscreen toolbar-shifting behavior behind a pref

Categories

(Core :: Widget: Cocoa, enhancement, P1)

enhancement
Points:
5

Tracking

()

RESOLVED FIXED
88 Branch
Iteration:
88.2 - Mar 8 - Mar 21
Tracking Status
firefox88 --- fixed

People

(Reporter: bugzilla, Assigned: bugzilla)

References

Details

(Whiteboard: [mac:fullscreen])

Attachments

(5 files)

The patch in bug 738335 introduces a 1px white flickering line at the top of the window in fullscreen. See https://phabricator.services.mozilla.com/D106847 for the current debugging efforts. We should land the patches current in that bug so they don't become bitrotted and so QA can test the behaviour, but we need to address the flickering line before enabling them. With I'll land the patches in this bug since bug 738335 won't be complete until the behaviour is enabled by default.

Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/f4dfcad8b881
Part 1 - Add a NSTitlebarAccessoryViewController to ToolbarWindow to track when the titlebar is shown in fullscreen. r=mac-reviewers,mstange
https://hg.mozilla.org/integration/autoland/rev/8ec37432c5b1
Part 2 - Add CSS rules to shift the toolbar over the content when the macOS menubar is shown. r=mstange
https://hg.mozilla.org/integration/autoland/rev/507074c89a49
Part 3 - Add pref to control shifting behaviour. r=mstange

(In reply to Harry Twyford [:harry] from comment #0)

The patch in bug 738335 introduces a 1px white flickering line at the top of the window in fullscreen. See https://phabricator.services.mozilla.com/D106847 for the current debugging efforts. We should land the patches current in that bug so they don't become bitrotted and so QA can test the behaviour, but we need to address the flickering line before enabling them. With I'll land the patches in this bug since bug 738335 won't be complete until the behaviour is enabled by default.

Hi Harry!
Can you please help us with some steps on how we should verify this fix after it lands? Or some scenarios to test? Thank you!

Please see the comment above! Sorry for spam

Flags: needinfo?(htwyford)

Hey Alex!
I added a screen cast that shows the difference between the old behavior and the new behavior.

In the current version, when Firefox is in fullscreen and you move the cursor to the top of the screen, the menu bar will slide on top of the Firefox UI. With the patch applied, the Firefox UI will slide down.

So in order to verify this, move Firefox to fullscreen with the pref flipped and try to trigger the menubar by moving the cursor to the top of the screen :)

Status: ASSIGNED → RESOLVED
Closed: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → 88 Branch

(In reply to Martin Balfanz [:mbalfanz] from comment #7)

Created attachment 9210225 [details]
side-by-side.2021-03-17 09_25_58.gif

Hey Alex!
I added a screen cast that shows the difference between the old behavior and the new behavior.

In the current version, when Firefox is in fullscreen and you move the cursor to the top of the screen, the menu bar will slide on top of the Firefox UI. With the patch applied, the Firefox UI will slide down.

So in order to verify this, move Firefox to fullscreen with the pref flipped and try to trigger the menubar by moving the cursor to the top of the screen :)

Thank you, Martin!
We will verify this after landing in Nightly using full-screen-api.macos.shiftToolbar and native fullscreen pref and report here. Clearing the ni? request.

Flags: needinfo?(htwyford)

Just to be sure, this is the same line that comment 0 talks about? So basically it is a known issue? Thank you!

Flags: needinfo?(mbalfanz)

Yes, that's how I understand it. I can't reproduce the white line myself on 10.15 with an external display.

Flags: needinfo?(mbalfanz)

(In reply to Martin Balfanz [:mbalfanz] from comment #11)

Yes, that's how I understand it. I can't reproduce the white line myself on 10.15 with an external display.

My colleague can't either on macOS 10.15 so maybe this is macOS 11.2.3 related. Waiting for the confirmation from Harry as well regarding the white line from comment 10.

Flags: needinfo?(htwyford)

Yes, that's the white line. Interesting that it can't be reproduced on 10.15. I can reproduce it on macOS 11.1 on both my MacBook display and an external display. Alexandru, if you team finds that the line can't be reproduced on macOS <11, we might consider preffing it on for those users.

In any case, knowing whether it's only a macOS 11+ issue will help with debugging.

Flags: needinfo?(htwyford)

Confirming that we cannot reproduce the issue on macOS 10.12, 10.13, 10.14, and 10.15. But on those, we can reproduce bug 1699688. So basically macOS 11 has a smooth transition and white line and macOS <11 has a jumpy transition and no white line.

See Also: → 1699688
Blocks: 1700178
You need to log in before you can comment on or make changes to this bug.