Closed Bug 1701690 Opened 2 months ago Closed 28 days ago

The spacing of the text of the “Import Error” modal is smaller than it should be

Categories

(Firefox :: about:logins, defect, P3)

Desktop
All
defect

Tracking

()

VERIFIED FIXED
89 Branch
Tracking Status
firefox88 --- disabled
firefox89 --- verified

People

(Reporter: mheres, Assigned: jenyabrentnall, Mentored)

References

(Blocks 1 open bug)

Details

(Keywords: good-first-bug)

Attachments

(2 files)

Attached image spacing.png

[Affected Versions]:

  • Firefox Beta 88.0b4 (Build ID: 20210328185936)
  • Firefox Nightly 89.0a1 (Build ID: 20210329095128)

[Affected Platforms]:

  • Linux Mint 20
  • Windows 10
  • macOS 10.15.7

[Prerequisites]:

  • Have Firefox open.

[Steps to reproduce]:

  1. Navigate to “about:logins”.
  2. Click the meatball menu button (“...”).
  3. Choose the “Import from a File...” option.
  4. Choose a CSV file without a header and import it.
  5. Observe the text of the “Import Error” modal.

[Expected result]:

  • The spacing for both the “File Format Issue” text and for the text follows it are larger.

[Actual result]:

  • The spacing for both the “File Format Issue” text and for the text that follows seems smaller than in the documentation.

[Notes]:

  • Attached is a screenshot of the issue compared to the documentation.
Mentor: dlee
Keywords: good-first-bug
Priority: -- → P3

Hey, its Jane from Outreachy. Could I please work on this bug? Thanks!

Hi Evgenia,
Sure, thank you for helping! Please let me know if you have any question.

Assignee: nobody → jenyabrentnall

Hey Dimi, big thanks for that!
Few short questions here:
1 - when we are talking about step 1 - is it here?
2 - my meatball menu doesn't gives me an option to Import from a file. Am I looking somewhere wrong?
3 - where do I take SCV file?
Thanks and hope its not too much, sorry for silly q.
https://drive.google.com/file/d/1RDs5jt0OhFPyriEvKHiBgYd4qbasbekm/view?usp=sharing
(In reply to Dimi Lee [:dimi][:dlee] from comment #2)

Hi Evgenia,
Sure, thank you for helping! Please let me know if you have any question.

Oops sorry, just found mini UX spec for bug. However still cannot find "Download from file option".

and when I am clicking on Content Strategy - string documentation - it doesn't give me anything..says I don't have permission to view it. I request one via google but for now cannot open it unfortunately :(

2 - my meatball menu doesn't gives me an option to Import from a file. Am I looking somewhere wrong?

Ah, sorry, I should mention this earlier, this is currently disabled by default.
You have to open about:config and set signon.management.page.fileImport.enabled to true. (See Bug 1702336)

3 - where do I take SCV file?

An easy way to create the CSV file is using Export Logins features, which you can find it right below the "Import from a File" menu button.

Thanks and hope its not too much, sorry for silly q

Not at all, let me know if anything is unclear or you have more questions.

Aww thats amazing, all worked great and it looks like I already resolved the issue. Last couple ones are:
If you changed few css rules, how to see if they took place in your nightly? Run again ./mach build ? If I do ./mach run there are no changes seen.

(In reply to Dimi Lee [:dimi][:dlee] from comment #6)

2 - my meatball menu doesn't gives me an option to Import from a file. Am I looking somewhere wrong?

Ah, sorry, I should mention this earlier, this is currently disabled by default.
You have to open about:config and set signon.management.page.fileImport.enabled to true. (See Bug 1702336)

3 - where do I take SCV file?

An easy way to create the CSV file is using Export Logins features, which you can find it right below the "Import from a File" menu button.

Thanks and hope its not too much, sorry for silly q

Not at all, let me know if anything is unclear or you have more questions.

Oops, all resolved already! hah. Last one - in reviewer should I tag you? how will I find you? just by typing "dimi" Are they case-sensitive? Thanks!
and when I submitting a patch, I face it a bit challenging at first. I figure out my commit msg, I ran tests mach test browser/components/aboutlogins/tests/ --headless and mach lint and they all went through. What would be my next steps to submit. patch? using Phabricator?
Thanks heaps!

(In reply to Evgenia Kotovich from comment #7)

Aww thats amazing, all worked great and it looks like I already resolved the issue. Last couple ones are:
If you changed few css rules, how to see if they took place in your nightly? Run again ./mach build ? If I do ./mach run there are no changes seen.

(In reply to Dimi Lee [:dimi][:dlee] from comment #6)

2 - my meatball menu doesn't gives me an option to Import from a file. Am I looking somewhere wrong?

Ah, sorry, I should mention this earlier, this is currently disabled by default.
You have to open about:config and set signon.management.page.fileImport.enabled to true. (See Bug 1702336)

3 - where do I take SCV file?

An easy way to create the CSV file is using Export Logins features, which you can find it right below the "Import from a File" menu button.

Thanks and hope its not too much, sorry for silly q

Not at all, let me know if anything is unclear or you have more questions.

Hey there!
Sorry, im not quite sure do I have to tag you here as well to make a review or its done automatically.
Thanks and sorry for disturbing!
(In reply to Dimi Lee [:dimi][:dlee] from comment #6)

2 - my meatball menu doesn't gives me an option to Import from a file. Am I looking somewhere wrong?

Ah, sorry, I should mention this earlier, this is currently disabled by default.
You have to open about:config and set signon.management.page.fileImport.enabled to true. (See Bug 1702336)

3 - where do I take SCV file?

An easy way to create the CSV file is using Export Logins features, which you can find it right below the "Import from a File" menu button.

Thanks and hope its not too much, sorry for silly q

Not at all, let me know if anything is unclear or you have more questions.

(In reply to Evgenia Kotovich from comment #10)

Hey there!
Sorry, im not quite sure do I have to tag you here as well to make a review or its done automatically.
Thanks and sorry for disturbing!

Sorry for the delay and thank you for the work.
No, you don't have to tag me, You are doing it right! I'll review it ASAP.

Attachment #9215295 - Attachment description: Bug 1701690 - [aboutlogins] Change css of error dialog window in login to have correct width and line-height of text. r=sfoster → Bug 1701690 - Fix error dialog window text in about:logins to have correct line-height. r=sfoster
Attachment #9215295 - Attachment description: Bug 1701690 - Fix error dialog window text in about:logins to have correct line-height. r=sfoster → Bug 1701690 - Fix error dialog window text in about:logins to have correct line-height. r=tgiles
Pushed by tgiles@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/83f460ae8255
Fix error dialog window text in about:logins to have correct line-height. r=tgiles
Status: NEW → RESOLVED
Closed: 28 days ago
Resolution: --- → FIXED
Target Milestone: --- → 89 Branch

I have verified that the text now extends further to the right. Tested using Firefox Nightly 89.0a1 (Build ID: 20210419094740) on Windows 10, Linux Mint 20 and macOS 11.1.

Status: RESOLVED → VERIFIED
See Also: → 1706320
You need to log in before you can comment on or make changes to this bug.