When replying, should be able to override reply-to field and reply to sender directly

RESOLVED DUPLICATE of bug 77304

Status

MailNews Core
Composition
--
enhancement
RESOLVED DUPLICATE of bug 77304
15 years ago
10 years ago

People

(Reporter: Jason Bennett, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
I'm on several Yahoo Groups lists. These lists are great for setting the
reply-to header to the list, so when I reply, I only get the list, not the
sender of the message. The problem is, if I want to reply off-list to the
sender, I have to reply to the list and change the address (which I might not
have in my address book), or compose a new message and paste in quoted text.

The context menu for the "To" address should include a choice to reply directly
to that address when the reply-to flag is set.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 1

15 years ago
This is what the "Reply to Sender" button from bug 110136 should actually do.

Comment 2

15 years ago
See also bug 140333.

Comment 3

15 years ago
Is anything happenning on this bug? Granted that MS Outlook doesnt seem to have
this feature, but lots of unix mail readers do and it is very useful as
mentioned in bug 110136

Comment 4

15 years ago
According to RFC 822 (http://www.ietf.org/rfc/rfc0822.txt see section 4.4.4)
currently Mozilla does *the right thing*.

However there are really mailing-list servers misusing the Reply-To headers.

The Emacs mail client Gnus lets you mark a mail-folder with "broken-reply-to". 
So if you are replying within such a folder, Reply-To is just ignored.  See
http://www.gnus.org/manual/gnus_30.html#IDX259

I think it would be a neat feature to implement using the folder properties.

Comment 5

15 years ago
Quoted from rfc822 section 4.4.4

Sometimes, a recipient may actually wish to  communicate  with the  person  that
 initiated  the  message  transfer.  In such cases, it is reasonable to use the
"Sender" address.

Mozilla does not implement the above feature. "Reply to Sender only" sends it to
the reply-to address and not to the "sender" address. All other unix mail
readers like mutt, pine, elm have a the option of overriding the reply-to
header. Makes replying to lists a lot more convenient than having to cut and
paste the senders email address.
Product: MailNews → Core

Comment 6

13 years ago
dupe of Bug 77304?

Comment 7

10 years ago
Yes, it is!
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 77304
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.