Closed Bug 1702290 Opened 10 months ago Closed 10 months ago

Camera Permission Propagation in Private Window

Categories

(Firefox :: Private Browsing, defect, P2)

Firefox 87
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox87 --- wontfix
firefox88 --- wontfix
firefox89 --- wontfix

People

(Reporter: rvernica, Unassigned)

References

(Regression)

Details

(Keywords: regression)

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:87.0) Gecko/20100101 Firefox/87.0

Steps to reproduce:

I use Google Meet in Private mode. When using the Camera, Google Meet ask for permission. I want to skip this prompt.

In regular (non-private) mode, I added meet.google.com to Settings - Camera Permissions and set permission to Allow. This permission propagated to Private mode and the camera worked in Google Meet without getting the permission prompt.

Starting Firefox 87.0 this permission no longer propagates in Private mode.

The Bugbug bot thinks this bug should belong to the 'Firefox::Site Permissions' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Site Permissions

Thanks for filing a bug!
This is caused by Bug 1680237 which enables isolated permissions between normal and private browsing windows.
I'm working on a fix for Bug 1701814 which should also fix the issue for other permissions like camera. The idea is to apply permissions set via about:preferences for both normal and private browsing windows.

Severity: -- → S3
Status: UNCONFIRMED → NEW
Component: Site Permissions → Private Browsing
Ever confirmed: true
Priority: -- → P2
Regressed by: 1680237
See Also: → 1701814
Has Regression Range: --- → yes

I've discussed this bug with :johannh. We came to the conclusion that the issue you're describing is expected behavior, now that the permissions are isolated. We consider being prompted again in private browsing a privacy feature. Private browsing permissions should not persist, but only be valid for the duration of the session.
For Bug 1589608 we would like to show the private browsing permissions in the permission lists so users can update the state (allow,block,...) or revoke them. However, PB permissions should remain session-only.

Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.