Closed Bug 1702298 Opened 6 months ago Closed 5 months ago

Cannot scroll fully expanded bookmarks panel

Categories

(Firefox :: Bookmarks & History, defect, P2)

defect

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox89 --- verified
firefox90 --- verified

People

(Reporter: mtigley, Assigned: mhowell)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-door-hangers][priority:2a] [proton-uplift])

Attachments

(2 files)

Attached image Bookmarks Panel

On smaller screen sizes, the bottom of the bookmarks panel isn't accessible when fully expanded.

This was an issue even before Proton, but is more apparent now with the more spacious design.

Component: Messaging System → Bookmarks & History
Priority: -- → P3
Whiteboard: [proton-door-hangers]
Priority: P3 → P2
Whiteboard: [proton-door-hangers] → [proton-door-hangers][priority:2a]
Assignee: nobody → mhowell
Status: NEW → ASSIGNED

fwiw, the right solution here would be to fix bug 1464580. I understand we want a short term solution here and thus it may be fine, but a scrollbar here doesn't seem great as a final solution.

I also don't think this is critical, one can always close one of the 2 pickers, and using both at the same time is unlikely to be common (no numbers here though).

Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/851ad4f16be3
Allow the bookmark create/edit panel to scroll. r=mconley
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

We've verified this issue on latest Nightly 90.0a1, under Win 10 x64, macOS 10.15 and Ubuntu 18.04 x64. The bug is not reproducing anymore, we simulated the smaller screens with pref layout.css.devPixelsPerPx.

Status: RESOLVED → VERIFIED

Molly, is there a reason not to have an uplift request to beta since this is marked as [priority:2a]? Thanks

Flags: needinfo?(mhowell)

No, the only reason is that I forgot about it, I'll request that now. Thanks for the reminder!

Flags: needinfo?(mhowell)

Comment on attachment 9216883 [details]
Bug 1702298 - Allow the bookmark create/edit panel to scroll. r=mconley

Beta/Release Uplift Approval Request

  • User impact if declined: Required for MR1 / Proton
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): This is a small, targeted fix to add a scrolling container to one panel, already verified on Nightly.
  • String changes made/needed:
Attachment #9216883 - Flags: approval-mozilla-beta?
Whiteboard: [proton-door-hangers][priority:2a] → [proton-door-hangers][priority:2a] [proton-uplift]

Comment on attachment 9216883 [details]
Bug 1702298 - Allow the bookmark create/edit panel to scroll. r=mconley

Approved for 89 beta 5, thanks.

Attachment #9216883 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

This is also verified as fixed on latest Beta 89.0b5, under macOS 10.15, Win 10 x64 and Ubuntu 18.04 x64.

Blocks: 1706815
You need to log in before you can comment on or make changes to this bug.